Author Topic: T3i 600d won't turn on  (Read 13981 times)

whisama

  • Just arrived
  • *
  • Posts: 1
T3i 600d won't turn on
« on: March 02, 2013, 09:56:54 PM »
I finished putting my pictures and videos on my computer and when I went to put the card back in my Canon T3i/600d the camera wouldn't start. The red led lit up when I took the battery out but now even the led doesn't come on. I've recharged the battery, tried a different battery, taken the battery grip off, cleaned the battery connectors, tried a new sd card, redownloaded ml, downloaded Canon's origional firmware, downloaded the led test, removed the lense, replaced the lens, made sure the button was fully on, recharged the battery again, made sure the screen wasn't turned off. I've got nothing. Now there are no lights and no noise when I turn it on other than the button moving from off to on. I've even shined a light into the sd card slot to make sure the pins were all sraight but it won't even start without a card in it.

The led blink test didn't work and a startup logger didn't work. There are still no signs of life.

Is there any hope or is it time to look at sending it to a Canon support center?
Thanks for your help.

kihlbahkt

  • Member
  • ***
  • Posts: 176
Re: T3i 600d won't turn on
« Reply #1 on: March 08, 2013, 11:05:01 PM »
My first thought is that you formatted the card on your PC and the bootflag is enabled which means your camera will not start, since there are no ML files on the card. Use EOScard deal with a card in that state.

EOScard:
http://wiki.magiclantern.fm/3rd_party_software

Let us know how that works out or what else you did to fix the issue.
600D x2

Francis

  • Hero Member
  • *****
  • Posts: 818
Re: T3i 600d won't turn on
« Reply #2 on: March 08, 2013, 11:08:30 PM »
He says that he used a new card also, that didn't have ML on it (thus probably no bootflag) and also tried turning on with no card. That eliminates that as an issue.

Tried turning on in different shoot modes?

jimmiceman

  • Just arrived
  • *
  • Posts: 1
Re: T3i 600d won't turn on
« Reply #3 on: May 10, 2013, 12:45:06 AM »
Any luck the same thing just happened to my camera.

deletedAcc.0021

  • Member
  • ***
  • Posts: 238
  • 600d x 4
Re: T3i 600d won't turn on
« Reply #4 on: May 10, 2013, 02:09:25 AM »
Check the battery compartment and CF card door micro switches.  If not depressed, the camera will not turn on.  Apparently, these have been an issue across the canon line.

With the camera off, try depressing switch manually, then turn on. 

 Good luck.