Author Topic: Canon 6D / Firmware 1.1.3  (Read 1281978 times)

Sidneywish

  • New to the forum
  • *
  • Posts: 25
Re: Magic Lantern for 6D | Dev kit released
« Reply #425 on: August 11, 2014, 10:35:34 AM »
Nope I'm not talking crop mode. Just regular mlv raw shooting. Depending on the builds, the cropmark (ie widescreen mark) is sometimes off center a bit, thus not giving the exact shooting mark. In other updates, it re-adjusts.

This one needs to be really watched because we need to know, in regular mode, if the framing is correct or not.

It doesn't matter if you shoot 2.39:1 or 16/9, the right edge of the cropmark here, in the latest build, if off the monitor a slight bit. This was not in the build before that.

column

  • New to the forum
  • *
  • Posts: 11
Re: Magic Lantern for 6D | Dev kit released
« Reply #426 on: August 11, 2014, 03:49:22 PM »
Looks fine.
You still got stuck at
"Firmware update program
Loading…"?

Yes, I have tested on two different SD cards, but result is the same.

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8296
Re: Magic Lantern for 6D | Dev kit released
« Reply #427 on: August 11, 2014, 03:56:06 PM »
Just to make sure:
You downloaded Canon's firmware 1.1.3 from Pelican's site and installed it?
Set cam's settings (including Fn) to factory defaults?
Dialed M?
And installation failed again?

If so: Please contact 1% and ask him how to remove TL's bootflag.

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: Magic Lantern for 6D | Dev kit released
« Reply #428 on: August 11, 2014, 10:30:12 PM »
There's no difference in ml/tl bootflag setting. There is only 1 in camera boot flag. To swap versions you just copy the files from the zip to the card. The card still has to be bootable for ANY autoexec.bin to run.

Quote
If this doesn't work: Format card again, download Canon's firmware version 1.1.3 from here:

Reinstalling 1.1.3 doesn't remove the boot flag. Formatting the card will unmark it as bootable and then nothing will run, fix this with EOScard (overwrite anything it auto downloads with whatever you want). With luck this is what happened and you don't need to mess with the fir ever again.

column

  • New to the forum
  • *
  • Posts: 11
Re: Magic Lantern for 6D | Dev kit released
« Reply #429 on: August 12, 2014, 10:16:51 AM »
Just to make sure:
You downloaded Canon's firmware 1.1.3 from Pelican's site and installed it?
Set cam's settings (including Fn) to factory defaults?
Dialed M?
And installation failed again?

If so: Please contact 1% and ask him how to remove TL's bootflag.

Yes I have don all these things and I was not lucky. What is TL?

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: Magic Lantern for 6D | Dev kit released
« Reply #430 on: August 13, 2014, 02:15:00 AM »
Its my magic lantern fork mainly for 6D/EOSM/50D/7D and sometimes 600D. So tragic lantern, ml vs tl, etc.

Regardless though, one of 2 things is happening.

1. Your card isn't bootable. No bin runs.
2. Your camera never had ML/TL/chocolate rain and the installer is again broken by changes to fonts or something else.

So to fix #1 make SURE the card is bootable by EOScard. It should keep the bootable flags when you close/restart the program and remove the card.
To fix #2, download/extract a whatever lantern zip from around 2014-03-17, which is when the installer was made and also be sure the canon 113 firmware file isn't in the root of the card.

After you successfully boot flag the camera you can replace the support files (ie ML folder) with whatever you chose.

Card bootable -> disk bootable
Camera bootable -> boot alternate device/boot order

to put it in desktop computer terms.

Coco.s

  • Just arrived
  • *
  • Posts: 1
Re: Magic Lantern for 6D | Dev kit released
« Reply #431 on: August 13, 2014, 03:26:31 AM »
Hey guys, its my first post but ive been following this thread for awhile. Id really like to see this released, but reading through, its obvious the amount of hard work and effort you guys have been putting in this. I just wanted to say thank you for your effort. I wish i knew how to help you guys. I want to do the test runs, but im slightly worried about downloading Magic lantern, as i dont have the money to replace my camera. After one downloads the Magic lantern, does it leave any of the program on the cannon original firmware? So that if i change my card i can use the normal program?

Also, just especially thanks to 1% and A1ex .. i know you guys are working your butts off, for free, for a bunch of camera enthusiasts who arent giving you guys the credit you deserve. Great work guys.

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8296
Re: Magic Lantern for 6D | Dev kit released
« Reply #432 on: August 13, 2014, 05:11:04 AM »
Top of page -> User Guide -> FAQ

column

  • New to the forum
  • *
  • Posts: 11
Re: Magic Lantern for 6D | Dev kit released
« Reply #433 on: August 14, 2014, 09:24:46 PM »
Its my magic lantern fork mainly for 6D/EOSM/50D/7D and sometimes 600D. So tragic lantern, ml vs tl, etc.

Regardless though, one of 2 things is happening.

1. Your card isn't bootable. No bin runs.
2. Your camera never had ML/TL/chocolate rain and the installer is again broken by changes to fonts or something else.

So to fix #1 make SURE the card is bootable by EOScard. It should keep the bootable flags when you close/restart the program and remove the card.
To fix #2, download/extract a whatever lantern zip from around 2014-03-17, which is when the installer was made and also be sure the canon 113 firmware file isn't in the root of the card.

After you successfully boot flag the camera you can replace the support files (ie ML folder) with whatever you chose.

Card bootable -> disk bootable
Camera bootable -> boot alternate device/boot order

to put it in desktop computer terms.


Now my card is bootable (previously it was not because of wrong card reader).
I tried to install ML build 2014-03-17 , but got the same result.

baaz

  • New to the forum
  • *
  • Posts: 2
Re: Magic Lantern for 6D | Dev kit released
« Reply #434 on: August 18, 2014, 12:34:21 PM »

Hello,

And thanx for this forum that got me into filming into RAW.
Unfortunately, I find the 6D very limited due to bitrate limitations and want to get rid of ML.

Has anyone tried to remove Magic Lantern from a Canon 6D?
I saw videos about the 5D mark III showing a simple way to remove bootflag (reupdate firmware on camera then turn a dial at success install screen), then simply format the card.

I can't find any post or video on the web showing this working on a 6D, so I'm a bit afraid to try.

Thanx you in advance if you have any info regarding to this  :)

Best Regards,

Baz

ahlongslide

  • New to the forum
  • *
  • Posts: 2
Re: Magic Lantern for 6D | Dev kit released
« Reply #435 on: August 18, 2014, 02:17:08 PM »
Baaz,

It says how to uninstall ML in the first post of this thread. It is very easy.

Thanks to everyone who is working on getting a stable build for the 6D! You guys are awesome!

baaz

  • New to the forum
  • *
  • Posts: 2
Re: Magic Lantern for 6D | Dev kit released
« Reply #436 on: August 18, 2014, 04:58:44 PM »

Thanks ahlongside !

I didn't see that ^^
It worked perfectly, I ran fimrware update again from the menu, then waited the 30 seconds at the startup screen as written and the bootflag uninstalled itself automatically.
After that I formatted the card, and everything seems to work well.

Have a nice day :)

rishabhkaul

  • New to the forum
  • *
  • Posts: 2
Can't find the Dual ISO for Photos
« Reply #437 on: August 18, 2014, 06:36:12 PM »
Hello everyone

I just downloaded ML on my 6D but can't find the Dual ISO option for photos.

What am I doing wrong?

Thanks a ton in advance.

Rishabh

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8296
Re: Magic Lantern for 6D | Dev kit released
« Reply #438 on: August 18, 2014, 06:56:56 PM »
Access modules tab ...

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1740
  • 6d - Nightly build user
Re: Magic Lantern for 6D | Dev kit released
« Reply #439 on: August 18, 2014, 09:23:59 PM »
Made an extra tab in NikFreaks spreadsheet

https://docs.google.com/spreadsheets/d/1esD8gjphQh3_Y1wnJoUXikMXgY0fNvxIy909_Cf9EM8/edit?pli=1#gid=2125558592

Now there's a tab where we can put interesting ADTG2 and CMOS registers, and write descriptions of what the registers do.
Feel free to add your findings



rishabhkaul

  • New to the forum
  • *
  • Posts: 2
Re: Magic Lantern for 6D | Dev kit released
« Reply #440 on: August 18, 2014, 10:13:56 PM »
@Walter Schulz
Thanks, that solved it.
Now if only I could get Aperture to read the DNG files.

monni

  • Just arrived
  • *
  • Posts: 1
Re: Magic Lantern for 6D | Dev kit released
« Reply #441 on: August 21, 2014, 12:14:44 PM »
Hi all! First of all thanks for the ML for 6D, highly appreciated. Used stable rel in my 60D for ages now, cant live without it. Now finally I have it with 6D as well!

Question: is it known feature that when in liveview mode, the ML menu drops out back to liveview after few seconds if nothing is pressed? It's bit difficult to change silent picture options, as the options are only avail in liveview mode. In normal mode, the ML menu stays on as it should.

I am using magiclantern-Nightly.2014Aug20.6D113

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1197
Re: Magic Lantern for 6D | Dev kit released
« Reply #442 on: August 21, 2014, 12:54:32 PM »
70D.112 & 100D.101

Semiconductor

  • New to the forum
  • *
  • Posts: 12
Re: Magic Lantern for 6D | Dev kit released
« Reply #443 on: August 27, 2014, 10:45:02 PM »
Hey all,

just wanted to ask when a newer build will come for the canon 6d? :)

The last is over 2 months and it makes me a bit nervous since the last build is causing weird stuff lol

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Magic Lantern for 6D | Dev kit released
« Reply #444 on: August 27, 2014, 10:55:09 PM »
I'm not sure what kind of calendar you use, but in this part of the world, a month has roughly 30 days, not 3 ;)

Also, "weird stuff" is not exactly a helpful problem description; see http://www.chiark.greenend.org.uk/~sgtatham/bugs.html

substr

  • New to the forum
  • *
  • Posts: 7
Re: Magic Lantern for 6D | Dev kit released
« Reply #445 on: August 28, 2014, 12:10:42 PM »
can someone verify if formatting the card in-camera keeps ML? I just wiped my SD card in Canon menu with low-level format selected as well as "Keep ML" then after I restarted the camera ML is no longer installed. tried 5x in separate cards, still the same.

Using July.30 build on this.

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1740
  • 6d - Nightly build user
Re: Magic Lantern for 6D | Dev kit released
« Reply #446 on: August 28, 2014, 12:13:59 PM »
Keeping ML option does work on the build I use (15 March 2014).
But I have seen in some "custom" builds for testing purposes that the option of keeping ML was there in canon menu. But it didn't work. After formatting ML was gone...

So, or somewhere on the road, after march 15 of this year, this options is damaged or it is just your 30July build...
Maybe try a newer nightly build of August and see what happens ?

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8296
Re: Magic Lantern for 6D | Dev kit released
« Reply #447 on: August 28, 2014, 12:27:58 PM »
There are two July.30 builds:
builds.magiclantern.fm/jenkins/job/6D.113
If you look at build #256 you will see 5th change: Fixed ML restoring after format, after FIO changes

Sidneywish

  • New to the forum
  • *
  • Posts: 25
Re: Magic Lantern for 6D | Dev kit released
« Reply #448 on: August 28, 2014, 01:01:59 PM »
On the latest august builds, I experienced something that never happened before on the 6D. If I take the SD card out and replace it with another without ML on it, the 6D just won't boot. It stays dead like there's no battery power left. I had to re-load the build on the second card to get the 6D to boot again.

Is that normal behavior?

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8296
Re: Magic Lantern for 6D | Dev kit released
« Reply #449 on: August 28, 2014, 01:09:47 PM »
It's normal if you use a card for ML and just removed ML directory and AUTOEXEC.BIN. The card is still bootable and this will lock up your cam.
Your fault because you're not following the uninstallation procedure. Format the card using a cardreader.