[SOLVED]Compile error [92f972ed556d]

Started by gerk.raisen, September 12, 2012, 04:49:39 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


plugin Y
console Y
ptp-ml Y

ptp-ml.o: In function `ptp_handler_PTP_ML_CODE':
ptp-ml.c:(.text+0x32c): undefined reference to `send_ptp_data'
ptp-ml.c:(.text+0x360): undefined reference to `recv_ptp_data'
ptp-ml.c:(.text+0x420): undefined reference to `send_ptp_data'
ptp-ml.c:(.text+0x4b0): undefined reference to `send_ptp_data'
ptp-ml.c:(.text+0x51c): undefined reference to `send_ptp_data'



Thanks 1%,

I tried with the file from your repo but without result.

ptp-ml.o: In function `ptp_handler_PTP_ML_CODE':
ptp-ml.c:(.text+0x308): undefined reference to `send_ptp_data'
ptp-ml.c:(.text+0x3c8): undefined reference to `send_ptp_data'
ptp-ml.c:(.text+0x458): undefined reference to `send_ptp_data'
ptp-ml.c:(.text+0x4c4): undefined reference to `send_ptp_data'


Do you need ptp? Otherwise you can compile for your camera only (go to platform/your_camera/ and type make)
EOS 1100D | EOS 650 (No, I didn't forget the D) | Ye Olde Canon EF Lenses ('87): 50 f/1.8 - 28 f/2.8 - 70-210 f/4 | EF-S 18-55 f/3.5-5.6 | Metz 36 AF-5


Use this g3gg0's patch to your clean repo.
1%'s repo is based on this patch.



I forgot to enable also PTP (other than ptp-ml) in makefile but I have retained your file and compile ok.
I plan to test PTP with the sztupy "ml controller for android".

Thank you.