Author Topic: EOS M - Bricked, showing Err 70  (Read 1837 times)

tabbynoodles

  • Guest
EOS M - Bricked, showing Err 70
« on: October 20, 2021, 02:22:51 PM »
I got the same issue from a thread here and I am using the latest @Danne EOSM build crop_rec_4k_mlv_snd_raw_only_2021Jun26.EOSM202 before this happens. The issue happens after I change to different crop modes. Also I've tried the diagnostic tools and it works just fine, the log provided below.

when the card is in the camera
- green will blink few times like during a normal power up but the screen will never get powered, connecting an external monitor would show no signal
- connecting the camera to PC via cable does not work at all

when the card is not in the camera
- green will blink indefinitely and screen will power up but show nothing on it, connecting an external monitor shows current mode --- or --- Err 70 will be displayed
- connecting the camera to PC via cable works as intended but EOS Utility can't perform firmware update as it needs card in the camera

Portable Display Test Log
Code: [Select]
  Magic Lantern Rescue
 ----------------------------
 - Model ID: 0x331 M
 - Camera model: ???
 - Firmware version: 2.0.2 / 9.9.8 B8(3a)
 - IMG naming: 100?????/IMG_1333.JPG
 - User PS: CineStyle CineBooster LightForm C
 - Boot flags: FIR=0 BOOT=-1 RAM=-1 UPD=-1
 - ROMBASEADDR: 0xFF0C0000
 - DONE!


Rom Dumper Log:
Code: [Select]
  Magic Lantern Rescue
 ----------------------------
 - Model ID: 0x331 M
 - Camera model: ???
 - Firmware version: 2.0.2 / 9.9.8 B8(3a)
 - IMG naming: 100?????/IMG_1333.JPG
 - User PS: CineStyle CineBooster LightForm C
 - Boot flags: FIR=0 BOOT=-1 RAM=-1 UPD=-1
 - ROMBASEADDR: 0xFF0C0000
 - card_bootflags 10a63c
 - boot_read/write_sector 10aec8 10afbc
 - 102798 Card init => 2
 - Dumping ROM0... 100%
 - MD5: 00fb35d35a716ad9341967fd5d54aab8
 - Dumping ROM1... 100%
 - MD5: 81ed458721f0b56f41ff5b6aac98727a
 - 0: \n**** SROM(SIO%d) Menu ****\n
 - 107c64: \n**** SROM Menu ****\n
 - 107B4C: tag c022c000
 - sf_init 107B48
 - 10717c: Read Address[0x%06x-0x%06x]:0x
 - 106A94: tag c0820000
 - sf_command_sio 106A44
 - Reading serial flash... 100%
 - Writing SFDATA.BIN... 100%
 - MD5: d38b362303c1d32873c766ebc06b7611
 - Saving RESCUE.LOG ...

He had autoexec.bin fix by @a1ex mentioned by @Danne but I can't find it here in the forum

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8421
Re: EOS M - Bricked, showing Err 70
« Reply #1 on: October 20, 2021, 03:04:28 PM »
Rules -> Thou shalt not crosspost.

tabbynoodles

  • Guest
Re: EOS M - Bricked, showing Err 70
« Reply #2 on: October 21, 2021, 05:38:34 PM »
Alright thanks. I've posted a comment into the thread

theBilalFakhouri

  • UHS-I
  • Developer
  • Hero Member
  • *****
  • Posts: 996
Re: EOS M - Bricked, showing Err 70
« Reply #3 on: April 26, 2022, 12:46:37 PM »
PM has sent to you

tabbynoodles

  • Guest
Re: EOS M - Bricked, showing Err 70
« Reply #4 on: April 28, 2022, 06:45:54 PM »
The autoexec.bin works! After a long long time. Thank you so much!

theBilalFakhouri

  • UHS-I
  • Developer
  • Hero Member
  • *****
  • Posts: 996
Re: EOS M - Bricked, showing Err 70
« Reply #5 on: April 28, 2022, 07:24:10 PM »
Cool!
The same autoexec.bin fix made by a1ex worked here.

@Mods: feel free to change this case to [Solved].

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7365
Re: EOS M - Bricked, showing Err 70
« Reply #6 on: April 28, 2022, 07:33:27 PM »
Great. Same that fixed my camera twice  :P.

names_are_hard

  • Developer
  • Hero Member
  • *****
  • Posts: 506
  • 200D idiot
Re: EOS M - Bricked, showing Err 70
« Reply #7 on: April 29, 2022, 04:10:46 AM »
Should we document this better?  I don't really know what went wrong and how it was fixed, but it seems common enough that we should have a proper recovery process.

theBilalFakhouri

  • UHS-I
  • Developer
  • Hero Member
  • *****
  • Posts: 996
Re: EOS M - Bricked, showing Err 70
« Reply #8 on: April 29, 2022, 04:53:07 AM »
General info:
-PROP_VIDEO_MODE is property which change Canon video mode which include some info about crop mode (disabled/enabled), FPS (24/25/30/50/60), selected resolution and maybe other info too.
-Requesting PROP_VIDEO_MODE to change video mode while we in 1080p to Movie crop mode is fine.
-Requesting PROP_VIDEO_MODE to change video mode while we in 720p to Movie crop mode --> congrats you soft-bricked your camera.

So we should be careful from which mode we request PROP_VIDEO_MODE property change.

How EOSM users are bricking their camera (like this one)?
Just use Danne build :P Just kidding, Danne builds are good.

Danne uses PROP_VIDEO_MODE request in some crop_rec presets, in some cases PROP_VIDEO_MODE is being called at wrong moments while changing crop_rec presets which result in invalid PROP_VIDEO_MODE values --> ERR70.
I think Danne has fixed this issue (didn't notice any new reported cases), so probably nothing to worry about right now when using Danne builds.

-The autoexec.bin fix from a1ex attempts to reset PROP_VIDEO_MODE to valid values (in particular 1080p24) at startup, so this tricks the camera and no crash would be triggered then the new valid settings would be saved.

names_are_hard

  • Developer
  • Hero Member
  • *****
  • Posts: 506
  • 200D idiot
Re: EOS M - Bricked, showing Err 70
« Reply #9 on: April 29, 2022, 01:40:12 PM »
That's a great summary, thank you!  We could probably remake an autoexec.bin from that info.