Author Topic: 5D3 No Live View on photo mode Bricked?  (Read 597 times)

jay101

  • New to the forum
  • *
  • Posts: 2
5D3 No Live View on photo mode Bricked?
« on: May 18, 2021, 11:56:25 AM »
Hi there
Not sure if this is the right forum. 
  I am new to ML and video/movie making ( I hate to use the word NOOB) and I have a problem. I cannot get Live view to work in photo mode (it works in movie mode) even when I uninstall ML live view does not work.  I have trawled through pages (hours) unable to find any post to this problem

History.
  I am using a Canon 5d mk iii and I rolled back to the old recommended Canon firmware and installed the 5D Mark III 1.2.3  version of ML from the main build. It did not go well. None of the movie modules would load and I got a string of errors, so I used the ML uninstall and then reinstalled, I was able to get the movie modules to load and run (mlv_play mlv_rec mlv_snd piv_view). Still no live view in photo mode.
 I uninstalled again and got back to the old Canon firmware and still no LV everything was as it should be except when I pressed the live view button.  I only get a view through the viewfinder so the mirror is not locked up MLU works.
  As my main photographic interest is macro photography I would like to get back to using live view even at the expense of not using ML.  I have two questions:-
 1.  Can any one suggest a solution to this whilst having ML running? If not then 2
 2.  How do I get back to the Latest version Of Canon firmware 1.3.6? Do I have to update the firmware in sequence, if so where can I get the older version of the firmware? Canon only shows the latest version on its web site. Do I have to send it back to canon for an expensive repair?
  Can any one assist?

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8421
Re: 5D3 No Live View on photo mode Bricked?
« Reply #1 on: May 18, 2021, 01:17:56 PM »
1: RTFM. Page 205 -> Live View Shoot. Enable


 

jay101

  • New to the forum
  • *
  • Posts: 2
Re: 5D3 No Live View on photo mode Bricked?
« Reply #2 on: May 18, 2021, 04:30:44 PM »
Thanks for the speedy answer.
It was the solution to all my woes. I had forgotten that this was there as I do not go to the menus as I have set it up as I like it years ago.
Again my thanks and all the best and keep safe.