Author Topic: Bilal's crop_rec_4k experiments for 650D / 700D (T4i / T5i)  (Read 48598 times)

lightwriter

  • New to the forum
  • *
  • Posts: 6
Re: Bilal's crop_rec_4k experiments for 650D / 700D (T4i / T5i)
« Reply #225 on: May 11, 2022, 12:00:23 AM »
Thank you for your swift reply, Bilal.

I didn't know somebody else asked for this function, but at the same time I'm not surprised.
Maybe someday you'll manage a solution, who knows? In the mean time, thank you for everything, and I hope everything's going well with you.

Sucuk

  • Just arrived
  • *
  • Posts: 1
Re: Bilal's crop_rec_4k experiments for 650D / 700D (T4i / T5i)
« Reply #226 on: May 20, 2022, 01:02:52 PM »
Hey (Selam Bilal) everyone, I am relatively new to Magic Lantern and I am honestly a little overwhelmed by all the options I have.
I wanted to ask if somebody could help me set the optimal settings for a movie look. I make short films, but usually on other peoples cameras.

I baught this SD Card "Angelbird SD Card AV PRO UHS-II 128GB V90".
I am using Bilals newest build for my 700d and would love to use the best possible resolution in 25fps, 1/50.
I also only need to record for 20-25s max. because thats how long a Take takes.
Thanks in advance!

katekurinhd

  • Just arrived
  • *
  • Posts: 1
Re: Bilal's crop_rec_4k experiments for 650D / 700D (T4i / T5i)
« Reply #227 on: May 22, 2022, 09:32:59 PM »
download link for 650d is not working atm.

theBilalFakhouri

  • Developer
  • Hero Member
  • *****
  • Posts: 887
Re: Bilal's crop_rec_4k experiments for 650D / 700D (T4i / T5i)
« Reply #228 on: May 25, 2022, 08:27:26 AM »
it seems @Moderators are taking a bit long time to approve new posts, see, I think I should claim a moderator role  :P or at least the ability to see pending posts.

@Sucuk
Already answered on reddit. Feel free to continue chatting here.
New custom build for 100D/SL1 is up:
https://www.magiclantern.fm/forum/index.php?topic=26511.msg239125#msg239125
Porting still work in progress!

theBilalFakhouri

  • Developer
  • Hero Member
  • *****
  • Posts: 887
Re: Bilal's crop_rec_4k experiments for 650D / 700D (T4i / T5i)
« Reply #229 on: May 25, 2022, 09:11:34 AM »
New builds are posted in the first post for 650D/700D:

Changes:

crop_rec:

-Added "Fix Dual-ISO flicker" option in "Crop mode" submenu, this option will remove waterfall effect for Dual-ISO lines by reducing FPS a tiny bit, this option will work in all "Crop mode" presets except for "Full-Res LiveView" preset.
This option is enabled by default and will only have effect when Dual-ISO is enabled.



-Adjusted analog gain for lower bit-depths, now it's accurate. LiveView brightness is identical among 12/11/10/9/8 bit-depths, it was a bit off, now it's accurate.
-Added 11-bit option, it can be a sweet spot for some resolutions.

mlv_lite:
-Added  LVICV_ReleaseResource hack:



You can find it in RAW video submenu, under "Two more hacks":
"1" enables CartridgeCancel a.k.a "One more hack" before.
"1 + 2" enables both CartridgeCancel and LVICV_ReleaseResource.

Please note: that LVICV_ReleaseResource hack may result in worse write speed performance, please make your own tests and see if it's actually enhance write speed or not, if not, it's better to avoid it and use only "1" option.

dual_iso:
-Added DISO block, I took it from crop_rec_4k_mlv_snd branch, now you will have Dual ISO info inside MLV file and you can view it using MLVApp:

DISO" border="0

-Dual ISO would be disabled in x10 mode automatically, to be used for focusing.

crop_new:
-Added 11-bitdepth option.
-Adjusted analog gain and LiveView brightness, now it's accurate.
-Detect binning mode change, LiveView will refresh automatically after you change binning mode.


Source code is also updated:
Source-code:
magic-lantern-bilal (25-5-2022).7z (crop_rec_4k branch)

Sorry I tried to convert it to git, but I encountered errors and the process failed, will try again later.
New custom build for 100D/SL1 is up:
https://www.magiclantern.fm/forum/index.php?topic=26511.msg239125#msg239125
Porting still work in progress!

theBilalFakhouri

  • Developer
  • Hero Member
  • *****
  • Posts: 887
Re: Bilal's crop_rec_4k experiments for 650D / 700D (T4i / T5i)
« Reply #230 on: June 15, 2022, 06:47:19 PM »
-Looking for more recording times?

Check Image quality and its effect on memory (more RAM 4 free)

-Results on 700D:

-1736x2214 @ 11 bit-lossless at 23.976 FPS, 240 MHz overclock, no GD (~78MB/s required write speed):

JPG:  first clip: 1 Minutes and 54 Seconds, second clip: 1 Minutes and 13 Seconds.
RAW: I have to stop it manually after 6 Minutes of recording :D

-By setting "Image quality" to RAW from Canon menu this fixes "Simple" silent picture on 700D, probably 650D too.
New custom build for 100D/SL1 is up:
https://www.magiclantern.fm/forum/index.php?topic=26511.msg239125#msg239125
Porting still work in progress!

Icaab

  • New to the forum
  • *
  • Posts: 34
Re: Bilal's crop_rec_4k experiments for 650D / 700D (T4i / T5i)
« Reply #231 on: June 17, 2022, 01:03:37 PM »
Hello. Installed new firmware on 650d. Dual iso "ISOless LV err(2)" error periodically appears.

theBilalFakhouri

  • Developer
  • Hero Member
  • *****
  • Posts: 887
Re: Bilal's crop_rec_4k experiments for 650D / 700D (T4i / T5i)
« Reply #232 on: June 17, 2022, 01:13:39 PM »
Hi Icaab, I didn't mention that I fixed "ISOless LV err(2)" on 650D.

Well, if you are asking for a fix, try this build and report back please:

crop_rec_4k.2022May25.650D104_ISOless.zip
New custom build for 100D/SL1 is up:
https://www.magiclantern.fm/forum/index.php?topic=26511.msg239125#msg239125
Porting still work in progress!

Icaab

  • New to the forum
  • *
  • Posts: 34
Re: Bilal's crop_rec_4k experiments for 650D / 700D (T4i / T5i)
« Reply #233 on: June 17, 2022, 02:21:47 PM »
Hi Icaab, I didn't mention that I fixed "ISOless LV err(2)" on 650D.

Well, if you are asking for a fix, try this build and report back please:

crop_rec_4k.2022May25.650D104_ISOless.zip
If you attached the firmware that was posted on May 25, I installed it. Problems with Dual ISO can only be solved this way:
Turn on P mode on camera
Camera turns off
Battery removed and inserted back
Video mode starts
Switches to manual mode (M) and everything works until the camera restarts

You can tell me how to take photos with the following combination of modules:
Dual ISO + Intervalometer + Silent Picture(Burst MLV) + Raw Video + Crop rec v1 or v2(Full-Res 1:1)

When I turn on "Raw Video", my camera hangs during the photographing, and with "Raw Video (MLV)" everything works, but in MLVApp is not recognized Dual ISO.

Thanks

theBilalFakhouri

  • Developer
  • Hero Member
  • *****
  • Posts: 887
Re: Bilal's crop_rec_4k experiments for 650D / 700D (T4i / T5i)
« Reply #234 on: June 17, 2022, 02:27:17 PM »
If you attached the firmware that was posted on May 25, I installed it.

No, the attached build is a different version from what you have tested before. So, again, do a clean install with this build (format SD card on PC then install the build):

Well, if you are asking for a fix, try this build and report back please:

crop_rec_4k.2022May25.650D104_ISOless.zip

Report back, then let's chat.
New custom build for 100D/SL1 is up:
https://www.magiclantern.fm/forum/index.php?topic=26511.msg239125#msg239125
Porting still work in progress!

Icaab

  • New to the forum
  • *
  • Posts: 34
Re: Bilal's crop_rec_4k experiments for 650D / 700D (T4i / T5i)
« Reply #235 on: June 17, 2022, 05:35:03 PM »
No, the attached build is a different version from what you have tested before. So, again, do a clean install with this build (format SD card on PC then install the build):

Report back, then let's chat.

Yes, already several times overloaded the camera and ISOless LV ERR(2)no longer. WONDERFUL! Thank you!
Also tested the included "Dual ISO" with "RAW video" and yes - they conflict with each other.

theBilalFakhouri

  • Developer
  • Hero Member
  • *****
  • Posts: 887
Re: Bilal's crop_rec_4k experiments for 650D / 700D (T4i / T5i)
« Reply #236 on: June 17, 2022, 06:18:33 PM »
Cool, so no more ISOless errors on your 650D when using crop_rec_4k.2022May25.650D104_ISOless.zip, does Dual ISO work in both photo and in video mode?

Also tested the included "Dual ISO" with "RAW video" and yes - they conflict with each other.

What do you mean by "conflict"? shows errors? could you explain more what do you mean?
New custom build for 100D/SL1 is up:
https://www.magiclantern.fm/forum/index.php?topic=26511.msg239125#msg239125
Porting still work in progress!

NykkyC

  • New to the forum
  • *
  • Posts: 4
Re: Bilal's crop_rec_4k experiments for 650D / 700D (T4i / T5i)
« Reply #237 on: June 18, 2022, 04:00:38 AM »
Hi Icaab, I didn't mention that I fixed "ISOless LV err(2)" on 650D.

Well, if you are asking for a fix, try this build and report back please:

crop_rec_4k.2022May25.650D104_ISOless.zip

I tested it in video mode around the city today and Dual ISO works overall.

Dual ISO works well except for this one time when I was trying to take a picture with Dual Iso and Crop mode 4.3k 1x3.
I got an overall ML error message and then I had to turn off the camera and remove and set the battery back in.
After turning it back on I got "ISOless LV err(2)".
When I restarted my camera, Dual ISO was working without error!

Thank you :D

Icaab

  • New to the forum
  • *
  • Posts: 34
Re: Bilal's crop_rec_4k experiments for 650D / 700D (T4i / T5i)
« Reply #238 on: June 18, 2022, 09:01:10 PM »
I tested it in video mode around the city today and Dual ISO works overall.

Dual ISO works well except for this one time when I was trying to take a picture with Dual Iso and Crop mode 4.3k 1x3.
I got an overall ML error message and then I had to turn off the camera and remove and set the battery back in.
After turning it back on I got "ISOless LV err(2)".
When I restarted my camera, Dual ISO was working without error!

Thank you :D

You have tried to take photos when the following modules are included:
Dual Iso,Crop mode v1 or v2, Raw video v1 or v2 and Silent picture (for example burst)
?

Icaab

  • New to the forum
  • *
  • Posts: 34
Re: Bilal's crop_rec_4k experiments for 650D / 700D (T4i / T5i)
« Reply #239 on: June 18, 2022, 09:04:08 PM »
Cool, so no more ISOless errors on your 650D when using crop_rec_4k.2022May25.650D104_ISOless.zip, does Dual ISO work in both photo and in video mode?

What do you mean by "conflict"? shows errors? could you explain more what do you mean?

I understood: in the video shooting mode when I turn on the modules Dual Iso, Raw video and Silent picture - the camera turns into a brick if I take a photo.

theBilalFakhouri

  • Developer
  • Hero Member
  • *****
  • Posts: 887
Re: Bilal's crop_rec_4k experiments for 650D / 700D (T4i / T5i)
« Reply #240 on: June 18, 2022, 09:52:36 PM »
@Icaab

..Raw video and Silent picture - the camera turns into a brick if I take a photo.

You can tell me how to take photos with the following combination of modules:
Dual ISO + Intervalometer + Silent Picture(Burst MLV) + Raw Video + Crop rec v1 or v2(Full-Res 1:1)

Currently full resolution presets and silent picture combination doesn't work very well on 700D (needs some memory management). Dual ISO isn't related to problem you are having.

Turning on RAW video and Silent picture will produce memory conflicts, that's why it crashes, especially with "Burst" mode.
Also, Intervalometer seems broken when using Silent picture in some/all cases? e.g. when using Full-Res LiveView. the counter will be broken.

I turn on "Raw Video", my camera hangs during the photographing, and with "Raw Video (MLV)" everything works, but in MLVApp is not recognized Dual ISO.

I can take pictures when "Raw Video" or "Raw Video (MLV)" is on without problems, how to reproduce this issue?
If crop mode is on, yeah the camera will hang, you need to either turn off crop mode or switch camera to photo mode (I noticed that Crop mode V2 will stay on in photo mode, I will make it turn off automatically in the next release).

..but in MLVApp is not recognized Dual ISO.

Could you give more details?
I recorded a clip with "RAW video (MLV)" with Dual ISO on, and MLVApp recognizes both ISOs.



-I have plans to dig into these issues and make some tries to improve memory management on 700D between crop modes modules, silent picture and RAW video . . but not in near future.
New custom build for 100D/SL1 is up:
https://www.magiclantern.fm/forum/index.php?topic=26511.msg239125#msg239125
Porting still work in progress!

theBilalFakhouri

  • Developer
  • Hero Member
  • *****
  • Posts: 887
Re: Bilal's crop_rec_4k experiments for 650D / 700D (T4i / T5i)
« Reply #241 on: June 18, 2022, 09:58:58 PM »
I tested it in video mode around the city today and Dual ISO works overall.

Cool, thanks for testing!

I was trying to take a picture with Dual Iso and Crop mode 4.3k 1x3.

You shouldn't take pictures when crop mode is on, you need to either trun off crop mode first, or switch the camera to photo mode, "Crop mode" will turn off automatically in photo mode.

I got an overall ML error message and then I had to turn off the camera and remove and set the battery back in.
After turning it back on I got "ISOless LV err(2)".
When I restarted my camera, Dual ISO was working without error!

Thanks for mentioning this, so this mean the current method of fixing "ISOless LV err(2)" error on 650D isn't perfect, but it's a lot better than before (works in most times).

Well, have fun :)
New custom build for 100D/SL1 is up:
https://www.magiclantern.fm/forum/index.php?topic=26511.msg239125#msg239125
Porting still work in progress!

Icaab

  • New to the forum
  • *
  • Posts: 34
Re: Bilal's crop_rec_4k experiments for 650D / 700D (T4i / T5i)
« Reply #242 on: June 19, 2022, 05:26:09 PM »
Turning on RAW video and Silent picture will produce memory conflicts, that's why it crashes, especially with "Burst" mode.
Also, Intervalometer seems broken when using Silent picture in some/all cases? e.g. when using Full-Res LiveView. the counter will be broken.
Intervalometer behaves stably when silent picture in burst.

Could you give more details?
I recorded a clip with "RAW video (MLV)" with Dual ISO on, and MLVApp recognizes both ISOs.
It’s working.
I used the following combination for photos with Dual ISO: video mode, Raw Video (MLV), Dual ISO and Intervalometer.
For photo manifestation program cr2hdr, after which everything is easily configured in Photoshop.
The photo gets dark after cr2hdr and when the exposure is raised - there is a noise, even if not
minor. In mlvapp is much MORE. (I think now I can take photos).
But this is not surprising, because expensive cameras like mark 3 are better at shooting at higher ISO values than 650 and 700 cameras.
Then out I do everything correctly. Correct if I made a mistake (but how to process video with dual iso
in mlvapp - I don’t know when a lot of noise comes out, unlike the manifestation in cr2hdr)

I think my main mistake was that I looked at the results with the included modules: Dual ISO + Intervalometer + Silent Picture(Burst MLV) + Raw Video + Crop v1 or v2(Full-Res 1:1) on the Mark 3 model. Unfortunately 650-700d is not yet very stable.
I was concerned earlier:
Whether I can shoot with a 14-bit(silent picture) intervalometer and a Dual ISO (instead of a bracketing) to minimally wear the shutter at the camera.
That’s why I was interested in using so many modules.

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8335
Re: Bilal's crop_rec_4k experiments for 650D / 700D (T4i / T5i)
« Reply #243 on: June 19, 2022, 05:39:44 PM »
?
If you get Silent Pic mode working it doesn't matter to have Dual-ISO loaded or not in terms of mirror/shutter actuations.

RhythmicEye

  • New to the forum
  • *
  • Posts: 4
Re: Bilal's crop_rec_4k experiments for 650D / 700D (T4i / T5i)
« Reply #244 on: July 26, 2022, 04:22:22 PM »
Bilal this build is fantastic. Thank you, great job.

Some feed back for you from my testing so far.

When formatting the card in camera the following folders are being deleted from within ML; cropmks, data, doc, docs, README, scripts. Interestingly all the names of the remaining folders are being changed to all upper case.

This has happened on all my cards when formatting in camera even with low level formatting switched off.

I'm using build; crop_rec_4k_stuckshutter_700D115 (25May2022) on Sandisk 170mb/s all sizes 64, 128, 256, 512

Has anyone else experienced this issue? I wonder... Other than this it's been working flawlessly and I can just delete files from my laptop without needing to format in camera but that's not always practical. My current understanding is that formatting cards in camera is best practice.

I shoot mainly in the 3K preset but reduced to 2.8k 2800 x 1190 @23.976fps. This way I get a beautifully centered frame in real time preview unlike the EOS M which is off centre by some margin.

I just wanted to post this quickly so I apologise if this has been raised previously.

Hope it's useful feedback and thanks again to you and the team for all your hard work.

All the best