Author Topic: Danne's crop_rec_4k experiments for EOS M  (Read 42695 times)

Francois_lune

  • New to the forum
  • *
  • Posts: 21
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2800 on: October 11, 2020, 08:06:22 PM »
Yes I tried to have a look at the code but I couldn't understand where and how the presets are made...I was searching in crop_rec.c

Is there some guidelines somewhere you could recommand?
EOS-M   /  EOS 70D

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7139
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2801 on: October 11, 2020, 08:11:27 PM »
No time atm but check in 4k regs i  4k preset. Try and work the timers reg 6014 and 6008 and thlse nearby. Also exists in crop mode sub menu. You could pro ably achange from there. Generally speaking. 4k with more than  7 fps will be hard.

Francois_lune

  • New to the forum
  • *
  • Posts: 21
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2802 on: October 11, 2020, 08:31:06 PM »
thanks, I already played on those reg directly on the cam. The fps increased but the preview and record went corrupted. 
I need to record at around 6fps but somehow need the "Liveview clock" to be faster. I will keep searching and trying :)
EOS-M   /  EOS 70D

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7139
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2803 on: October 11, 2020, 09:09:17 PM »
Liveview clock? You mean shutter? I mean. 6fps is 6fps or what am I missing? Do you refer to some kind of latency when starting to record?

Francois_lune

  • New to the forum
  • *
  • Posts: 21
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2804 on: October 11, 2020, 09:36:44 PM »
yes, it maybe sounds confusing....

I am using my Eos-m with the rec_trigger function. A Super-8 projector is sending a half-shutter signal to the camera for each frame of the film, this allows the cam to record in sync with the projector.
I record at around 6fps, this is the speed of the projector.

But it seems that the frequency the camera is "checking" for the half-shutter signal is determinate by the fps of the preset (maybe related to the "Liveview clock" from what I read). It only check 5 times a second if the cam is set at 5fps, which give bad timing in the synchronisation. If a use a preset at 18fps or 24fps, the sync is perfect.
EOS-M   /  EOS 70D

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7139
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2805 on: October 11, 2020, 09:41:48 PM »
Maybe stick to anamorphic modes  8). Or 3k preset. Eos m really can´t push 4k to 18fps.

Francois_lune

  • New to the forum
  • *
  • Posts: 21
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2806 on: October 11, 2020, 09:51:47 PM »
yes I know recording 4K @ 18fps would be too much for the cam.
I actually only need 4K @ 6fps but with the cam checking for the half-shutter signal 18 times/sec or more, this a really specific and weird need I agree ;)
EOS-M   /  EOS 70D

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7139
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2807 on: October 11, 2020, 10:00:40 PM »
Don´t think I can help you here. Maybe a1ex or g3gg0 but what happens when pushing timers too hard liveview freezes as you already experienced.

Kgncom

  • New to the forum
  • *
  • Posts: 18
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2808 on: October 11, 2020, 10:17:49 PM »
I’m just checking in if anyone on this board has had success with the 240 SD overclock settings? It seems to function for me but I don’t see the benefit, tho I’m not on the 170Mbs cards, just the 90Mbs ones.
70D | EOSM

vstrglv

  • Member
  • ***
  • Posts: 246
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2809 on: October 11, 2020, 10:31:35 PM »
I think Mythic Cinema is referring to this video by Dave McKeegan. Proprietary SanDisk transfer mode at 3:38

My SanDisk 64GB Extreme Pro 95MB/s does not work at 192MHz (only 20Mb/s w/r). It works at 160Mb/s. But SanDisk 128GB Extreme Pro 170MB/s works at 192 Mhz (175/185Mb/s w/r). So I guess that SanDisk  Extreme Pro 170MB/s a bit better than SanDisk Extreme Pro 95MB/s.
Canon 5D3,1.1.3; Canon EOS M,202,  CF-SanDisk Extreme PRO,160MB/s, 256GB, SD-SanDisk Extreme Pro, 170MB/s, 128GB.

ZEEK

  • Senior
  • ****
  • Posts: 314
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2810 on: October 11, 2020, 10:42:43 PM »
Enable 24fps when ratio 2.39:1 and 2.35:1 and set 25fps are set(yes, aware of contradiction set 25fps becomes 24fps). Will only work with framing preview. Realtime liveview will be frozen or else pink frames.
Thanks Danne, this is actually an amazing option for stills, cheers 😎👌🎥🔥
EOS M - EOS M2 - 5D2

bern047

  • New to the forum
  • *
  • Posts: 10
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2811 on: October 11, 2020, 10:45:25 PM »
I have Canon 700D and Canon EOSM, 240mhz works fine on the 700D but I can only use 195mhz max on the EOSM, both cameras have similar processors and sensors which is fine for me as I can get all the settings and resolutions with the latest build so more than happy with both cameras

fer.psd

  • Just arrived
  • *
  • Posts: 1
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2812 on: October 12, 2020, 09:16:53 PM »
I'm desperate...New EOS M ML user here, installed FD Lenses with the Pixco adapter, everything looks great on the viewfinder, settings, aperture changes etc....but when I hit the Red Dot Record Button NOTHING HAPPENDS... no recording. Anything that might help this newbie out?

ZEEK

  • Senior
  • ****
  • Posts: 314
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2813 on: October 13, 2020, 10:28:12 AM »
There is a known issue on the EOS M, especially with the Latest Build [OCT,07]. When using HDMI with a monitor, the EOS M LiveView/Monitor Screen tends to "Lockup" or freeze after exiting the Canon or Magic Lantern Menu. A Reboot is required each time. Not sure what is causing this freeze in LV.
EOS M - EOS M2 - 5D2

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7139
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2814 on: October 13, 2020, 10:39:02 AM »
There is a known issue on the EOS M, especially with the Latest Build [OCT,07].
Can´t really work wiith this info. If it´s known it´s new to me. The official build works better? Why especially with this build? What preset was used, how can we reproduce the issue. How can you avoid the issue? What presets are working better etc.

ZEEK

  • Senior
  • ****
  • Posts: 314
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2815 on: October 13, 2020, 12:29:07 PM »
It happens in all presets, no presets work better than the other. Avoiding the issue would be to not use an external monitor in general, otherwise just live with rebooting the camera after exiting the ML Menu to fix the freeze. The issue will reproduce with any preset used and after exiting the ML Menu. Haven't encountered this in the last build with HDMI or the few previous builds. It's not a Huge deal as I don't use a monitor as often, just thought I'd raise this concern thinking what the issue could be.
EOS M - EOS M2 - 5D2

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7139
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2816 on: October 13, 2020, 12:36:29 PM »
Don't think older builds works better. If so it would be good if you could present these two builds compared. Would be good also to test against an official build but right now there's simply too many variables not tested to draw any conclusions.
On a general level, thanks for feedback. If we want this fixed more work is waiting...

Kgncom

  • New to the forum
  • *
  • Posts: 18
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2817 on: October 14, 2020, 07:29:33 PM »
Heya Danne, is it possible to enable the customized button functions in picture mode? Changing iso without going through touch menus is something I didn’t know I needed!
70D | EOSM

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7139
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2818 on: October 14, 2020, 08:34:40 PM »
Yes, I was interested in this too but not a big priority and now I have no time.

canoneer

  • New to the forum
  • *
  • Posts: 39
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2819 on: October 15, 2020, 06:09:04 PM »
Re Remote triggering the EOS M. I have way back in time managed to get the Triggertrap Audio remote function to work. Now I can see the volume peek when triggering on the iPhone but it seems impossible to get a reaction. Do I need to do more than activating the function in the ML menu? If you have time to throw a lifeline?

0xanon

  • New to the forum
  • *
  • Posts: 5
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2820 on: October 16, 2020, 03:41:58 PM »
New user with a few questions:
  • Scott Torborg used to have an EOS-M teardown gallery at https://www.scotttorborg.com/canon-eos-m-teardown but it is no longer available. Does anybody have the high-res images?
  • Does anybody know if the SD card controller on the EOS-M is a separate chip from the main CPU or MPU? Is the touch screen controller a separate chip? What about other EOS cameras?
  • I've read the EOS cameras can go into thermal shutdown from heavy usage outside the specs, such as shooting raw video with ML and overclocking the SD controller. What chips are getting hot and causing the overheating?

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 7941

0xanon

  • New to the forum
  • *
  • Posts: 5
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2822 on: October 16, 2020, 04:27:56 PM »
Thank you, but I did check archive.org before posting, and none of the full resolution images (the useful ones) have been archived, and only very few any of the medium res ones.

I also emailed Scott Torborg, with no response.

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 7941
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2823 on: October 16, 2020, 04:51:30 PM »
Have you tried Twitter? https://twitter.com/storborg

0xanon

  • New to the forum
  • *
  • Posts: 5
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2824 on: October 16, 2020, 04:54:26 PM »
Oh you young whippersnappers and your electric restroom wall, of course I haven't!

Guess I'll have to swallow my pride and make an account, thanks for the tip  :)