Author Topic: Danne's crop_rec_4k experiments for EOS M  (Read 85380 times)

ctfire

  • Freshman
  • **
  • Posts: 53
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2375 on: May 19, 2020, 07:14:17 PM »
This feature does the magic: https://github.com/ilia3101/MLV-App/wiki#ca-desaturate--radius
It was thought to reduce CAs, but it works nicely for color moiree as well.
Before:

After:

Before:

After:

THANK YOU!



ЕРФТЛ НЩГ

joeyvfx

  • Just arrived
  • *
  • Posts: 1
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2376 on: May 21, 2020, 02:59:38 AM »
That CA reduction feature is super handy. Personally, i'm trying to get used to shooting with wider lenses in 3x crop mode, just so I don't have to deal with aliasing at all, but that has it's limits too.

Question, kinda off topic - would it be possible to someday fix focus peaking on external monitors? To my knowledge it hasn't displayed properly in any ML build for the EOS M, regardless of how the hdmi settings are changed. It works beautifully on my T2i, but on the EOS M everything gets shifted around and flickers in weird ways.

Here's an example of how it glitches out, this is on my FeelWorld S55: https://i.imgur.com/BkNZgI7.jpg

Mythic Cinema

  • New to the forum
  • *
  • Posts: 33
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2377 on: May 21, 2020, 06:04:18 PM »
@Danne - Do you think I can donate a little money for you to enable 10-Bit+ and Framerate Override for .H264 on EOS M and M2, whenever you have time? Thank you.
x5 Full Spectrum Canon EOS M (Blue) | x1 Full Spectrum Sony a7S III (Soon)

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7188
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2378 on: May 21, 2020, 06:15:29 PM »
Not interested. If possible it would already have been done.

Mythic Cinema

  • New to the forum
  • *
  • Posts: 33
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2379 on: May 21, 2020, 08:54:16 PM »
Not interested. If possible it would already have been done.
Oh, alright. I assummed it wasn't done because nobody cared for h264 but one of the uses I have for these is to record 8 hours straight. Not really practical at all with RAW for 1TB SD card costs and file sizes. Thanks for the response.
x5 Full Spectrum Canon EOS M (Blue) | x1 Full Spectrum Sony a7S III (Soon)

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7188
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2380 on: May 21, 2020, 08:58:14 PM »
You can set fps override to 34 fps for h.264, seems max.
You could also enable 46 fps 2.39:1 with hfs mode and then turn off raw video. You will get a nice h.264 file but needs stretching in post. Whn doing this see to it that canon menu is set to 50 or 60fps. In this mode I think you can even do fps override to 50fps.

Mythic Cinema

  • New to the forum
  • *
  • Posts: 33
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2381 on: May 21, 2020, 10:53:14 PM »
You can set fps override to 34 fps for h.264, seems max.
You could also enable 46 fps 2.39:1 with hfs mode and then turn off raw video. You will get a nice h.264 file but needs stretching in post. Whn doing this see to it that canon menu is set to 50 or 60fps. In this mode I think you can even do fps override to 50fps.
I only tried on the M2 since my M doesn't arrive until tomorrow... FPS override didn't work at all on M2 with H264. I dont think aspect ratio settings work either. I was just wanting true 24p instead of 23.976 to match my main cameras. I'll mess around with the M tomorrow to see if anything works.
x5 Full Spectrum Canon EOS M (Blue) | x1 Full Spectrum Sony a7S III (Soon)

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7188
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2382 on: May 21, 2020, 11:08:02 PM »
Practically nothing works for the eosm2. Default raw buffer, no raw_slurp due to freezes.
Most stuff works with eosm.

Mythic Cinema

  • New to the forum
  • *
  • Posts: 33
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2383 on: May 21, 2020, 11:10:57 PM »
Practically nothing works for the eosm2. Default raw buffer, no raw_slurp due to freezes.
Most stuff works with eosm.
lol... well, you can at least get it to do raw mv1080 and true 24fps stable continuous. With the merged build at least.
x5 Full Spectrum Canon EOS M (Blue) | x1 Full Spectrum Sony a7S III (Soon)

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7188
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2384 on: May 21, 2020, 11:15:40 PM »
lol... well, you can at least get it to do raw mv1080 and true 24fps stable continuous. With the merged build at least.
I know, It´s mainly my branch in there. Well, dfort and of course a1ex started it out and layed out the ground work. mv1080p is working because delimed to default raw buffer. True 24fps, what does it even mean. Anyway. You can tweak and modify anything on the eosm.

Mythic Cinema

  • New to the forum
  • *
  • Posts: 33
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2385 on: May 22, 2020, 01:42:48 PM »
I know, It´s mainly my branch in there. Well, dfort and of course a1ex started it out and layed out the ground work. mv1080p is working because delimed to default raw buffer. True 24fps, what does it even mean. Anyway. You can tweak and modify anything on the eosm.
It just means actual 24 frames per second, instead of 23.976 (23.98) broadcast framerate. Mostly used in movies and cinema DCP packages. Yeah, I might replace two of my M2s with M models just to have more options on more cameras.
x5 Full Spectrum Canon EOS M (Blue) | x1 Full Spectrum Sony a7S III (Soon)

GregZ

  • Just arrived
  • *
  • Posts: 1
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2386 on: May 31, 2020, 08:51:19 AM »
Hi  I am new to this  - I just got a sandisk extreme pro 256GB SD card and when I benchmark it in ML it says it will write/read at around 35 Mb/sec. Is this why my EOS M won't record RAW video? Is there a better card I should be getting or is it my settings (oh my, so many settings!)?

Corallaro

  • New to the forum
  • *
  • Posts: 9
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2387 on: May 31, 2020, 08:29:28 PM »
Hi Danne,
I'm starting to test ML, a new world for me.
There is a changelog for your distro of ML?
Tnx
Giovanni

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7188

fanfzero

  • New to the forum
  • *
  • Posts: 11
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2389 on: June 01, 2020, 04:17:34 AM »
I did some tests 2 days ago, mcm 1080 14 bit (except for the shot of the big fountain and the one of the white goose), graded in davinci and exported to 4k so youtube doesn't ruin the quality  I know it's not the best, but it's my first try outside home

LeeLooMultiPass

  • New to the forum
  • *
  • Posts: 2
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2390 on: June 01, 2020, 10:57:00 PM »
Hi.  Im struggling to find the eos m 2.0.3 magic lantern file.  Can someone point me in the right direction please?

Ive been using 202 with no issues, i know the 203 is experimental at this time

Thanks

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8072
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2391 on: June 03, 2020, 03:20:54 AM »
Top of page -> Downloads -> Download nightly builds -> EOS M 2.0.3

seguracine

  • New to the forum
  • *
  • Posts: 4
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2392 on: June 03, 2020, 11:40:01 PM »
Thank you. What is the bit depth that you can get at that resolution?
hola tengo la eos M6 mark II  me gustaria grabar a 3840x1600 ¿sabes ai hay algun sotfware?
seguracine@hotmail.es

avivara

  • Just arrived
  • *
  • Posts: 1
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2393 on: June 04, 2020, 02:09:35 PM »
Hi, sorry but im new on the forums, what happens if i install other magic lantern camera version on my camera?? i have EOS 6D Mark II, sorry for the stupid question, but it will be brick?

Dracnath

  • Just arrived
  • *
  • Posts: 1
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2394 on: June 04, 2020, 03:25:27 PM »
I've been reading and attempting to understand as much as possible about the ML world - as it relates to the EOS M.  So far this is what I’ve been able to pick up.

The EOS M seems to be one of the better supported cameras.  While the ML site shows the latest build is back from 2018 that doesn’t tell the whole story.  Because...

What I haven’t figured out yet?
  • I’m a little unsure why Danne has decided to stick with 2.0.2?
    Are there drawbacks to running either 2.0.2 or 2.0.3.
    Are Danne’s builds the best to be running?  It seems likely they work better than the 2018 builds on the ML site, but it’s worth asking.
    While we’re at it, why are the last builds on the main site from 2018?

Unlike most people running ML, my main objective is to use the EOS M as a webcam.  I intend to have it going out via hdmi into a capture card.
I’ve figured out I can turn overlays off by going to the “Display tab/screen” menu and enabling "Clean Overlays". 
BUT what I’m unsure of is…
Will this work for long sessions?  Will I be overheating or some other way killing the camera if I’ve got it running for a two hour VC?
How do I keep the camera turned on?  It seems to want to automatically turn off after a set period of time.
What’s the best/most stable firmware for my unique use case?

Any help or thoughts appreciated, and hopefully this is a useful post for newbs like me and can avoid some unnecessary repetitive posts asking the same questions.

LeeLooMultiPass

  • New to the forum
  • *
  • Posts: 2
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2395 on: June 04, 2020, 06:19:14 PM »
Top of page -> Downloads -> Download nightly builds -> EOS M 2.0.3

All that does is loop back to this discussion thread

Leader

  • Just arrived
  • *
  • Posts: 1
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2396 on: June 06, 2020, 01:31:46 AM »
Hi.  Im struggling to find the eos m 2.0.3 magic lantern file.  Can someone point me in the right direction please?

Ive been using 202 with no issues, i know the 203 is experimental at this time

Thanks

See this message /forum/index.php?topic=9741.msg224844#msg224844 on the page 157.
I have tested and everything seems to crash. Idk if it's my memory card's (Transcend SDHC I 400x 32GB) fault or because of unstable firmware?

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8072
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2397 on: June 06, 2020, 03:58:51 AM »
All that does is loop back to this discussion thread

It leads to a specific post by dfort which links to his repository. And there you will find
https://bitbucket.org/daniel_fort/magic-lantern/downloads/magiclantern-Nightly.2017Jan13.EOSM203.zip

Kgncom

  • New to the forum
  • *
  • Posts: 18
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2398 on: June 09, 2020, 01:59:47 AM »
Hello, I'm fairly new to the forum but I've been using Danne's build for EOSM and I've been having a lot of fun. However I've recently run into some issues (big and small) and am wondering if anyone on the forum can help.

I couldn't get the cam to record and shoot with a EFM to c mount adapter in. I had to make use of the recording delay function in the video tab, this probably has an easy fix i can't find but it was annoying to work around and was wondering what setting i need to change in ML or in camera to get that to work. I was also having issues with the SD overclock. I don't know what causes but eventually the card will refuse to record at higher bitrates, this will happen even while recording. I'll have continuous recording, everything is stable, but suddenly the write speed tanks the buffer fills up and recording stops. After that the card stays at low write Speed, I've been using a legit SanDisk Extreme pro 90MB/s 64GB and a Lexar Pro 1000x 128GB. The write speed tanking happens seemingly at random, and after that I need to clear the frame buffers, and dump the ROM, and occasionally the cards speed come back, only to invariably return to slowpoke mode. Neither of these are the big issue tho.

https://www.magiclantern.fm/forum/index.php?topic=16262.0 I ran into this problem. Flashing green LED and no boot. Camera would only boot without an SD. Regardless of what is on an SD, any SD card in Camera will make it not boot and perpetually flash the LED. I managed to save my camera by getting the camera to boot with the battery door open (i had to push in a little pin inside the battery compartment) and pushing in the SD card right after turning the camera on. This somehow avoided the flashing LED AND read the card. I used this to reinstall firmware 2.0.2 and wipe all settings and format the card again. I thought nothing of this and reinstalled ML i still had to deal with the funky SD write behaviour but everything seemed good, however after a few days it started doing the same hanging thing again, and I had to repeat the process. I am more than willing to run tests if any of the devs need some research done here as no one should have to deal with this bricked/hanging camera crap.

EDIT: So it appears that this LED hanging behaviour occurs now even when ML hasnt been installed, have to do the card thign just to get the cam to acknowledge the card. Wondering what it could be.
70D | EOSM

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8072
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #2399 on: June 09, 2020, 02:38:12 PM »
Not taking shots with adapter mounted:
C.Fn IV 7: Release shutter w/o lens. Instruction manual page 287.

Lexar Pro 1000x is an UHS-II card. This card will run in UHS-I compatibility mode and ATM nobody has a clue if SD_UHS.mo is compatible with this - or any - UHS-II card. I can only recommend not to use it ATM.

@all: Anybody else having such "drop-out" problems with Extreme Pro?

Lockups: Most likely you took a card which was prepared for ML (= bootable) and wiped autoexec.bin. Cam will lockup and FAQ/Install Guide will tell you not to delete autoexec.bin!