Author Topic: Danne's crop_rec_4k experiments for EOS M  (Read 99710 times)

ricardopt

  • Member
  • ***
  • Posts: 128
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1825 on: October 12, 2019, 09:30:06 PM »
i used the last one, will try the rewired one, thanks.

turnlemons2lemonade

  • New to the forum
  • *
  • Posts: 17
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1826 on: October 13, 2019, 08:26:07 AM »
Were the histogram and focus peaking from the magic lantern or the inbuilt monitor functions? Did you try with 12 or 10 bit?
Thanks for the tests.

From the display menu. Yes I did, same results. 14/12/10 doesnt affect too much. I still get dropped frames using a external monitor most of the times.

lightspeed

  • New to the forum
  • *
  • Posts: 39
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1827 on: October 13, 2019, 10:16:31 AM »
Why was the 11 - 8 bit removed? Its nice to have the option.

ricardopt

  • Member
  • ***
  • Posts: 128
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1828 on: October 13, 2019, 05:38:36 PM »
Why was the 11 - 8 bit removed? Its nice to have the option.

Were you powering the eos-m with the monitor using a dummy eos-m battery?

lightspeed

  • New to the forum
  • *
  • Posts: 39
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1829 on: October 17, 2019, 06:44:32 AM »
just nice to have if you push the resolution a bit. I can usually get like 2.7k

turnlemons2lemonade

  • New to the forum
  • *
  • Posts: 17
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1830 on: October 17, 2019, 10:20:49 PM »
Hey guys, just wanted to point out that the last video Zeek did on FPS Override fixed the dropped pink frames.

Here's the video:

Settings:
FPS Override: 24 FPS
Optimize for: Exact FPS
Shutter fine tune -1,26ms

BOOM, perfect 180 degree shutter, no pink frames. NOW LET'S SHOOT some cinematic 14bit RAW goodness with this beast.

ZEEK

  • Senior
  • ****
  • Posts: 321
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1831 on: October 18, 2019, 07:13:01 AM »
Ah man...... :o
Yes, fps override does work in holding the frames per second (fps) in place and it works perfectly on my Feelworld 4K Monitor and Eyeyoyo with no pink frames (they used to be unusable on the m. However, my Fotga produces a little bit, although much, much better than it used to be.

*For some reason the fps in the Canon Menu is adjusted to 25p strictly even upon setting it to 24p. It always reverts to 25p (not sure of the reason behind that. ::))

@turnlemons2lemonade have you tested the settings to see if they work for you? (your monitor, no corrupted frames?)
- make sure your camera also has sufficient battery life too and sd card space :)
EOS M - EOS M2 - 5D2

turnlemons2lemonade

  • New to the forum
  • *
  • Posts: 17
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1832 on: October 18, 2019, 09:12:44 AM »
@Zeek yup, just did 4 1 minute long clips right now testing it out and no pinky frames. We're all good to go! Just bought another EOS M.

Pacerx999

  • New to the forum
  • *
  • Posts: 12
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1833 on: October 18, 2019, 12:30:59 PM »
Interestingly, I've had no issues with an external monitor on the EOS M.

But I'm set to 25p in the Canon menu
And MCM review set to 14 bit, 25fps, 1/50 (for 180 shutter)

But without having to do any FPS override (as my experience has been the FPS override sometimes causes odd issues).


SO potentially, it is about the shutter being EXACTLY 180, that means there is a lack of pink frames with using external HDMI.

More testing, but it seems like a reasonable hypothesis.

ZEEK

  • Senior
  • ****
  • Posts: 321
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1834 on: October 18, 2019, 12:53:52 PM »
Interestingly, I've had no issues with an external monitor on the EOS M.

But I'm set to 25p in the Canon menu
And MCM review set to 14 bit, 25fps, 1/50 (for 180 shutter)

Does your monitor work with 5k Anamorphic Rewired or 2.5k Mode even with the 180 Degree rule? It would be good to know if it works as those modes are filled with pink frames when used with any monitor. MCM Rewire 1080 is all good with the 180 Degree Rule using Fine-Tuning. Cheers!
EOS M - EOS M2 - 5D2

lightspeed

  • New to the forum
  • *
  • Posts: 39
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1835 on: October 19, 2019, 04:13:43 AM »
Would it be possible to upgrade or increase the size of the image buffer memory? would this allow 3k shooting?

AF-OFF

  • Member
  • ***
  • Posts: 109
  • 50Dc EOSM
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1836 on: October 20, 2019, 03:46:18 PM »
Used this build for 2 days without problems, but no extensive testing
After starting the cam with the Oct 17 build today, it crashed.
There was a note to report the crash to ML- devs. Then Error 70 was presented and cam shut down
here are the logs and my settings folder
https://we.tl/t-IRY4rMOaYb
(link active until the Oct 27th)

@Zeek
You are on the PAL setting. I'm on NTSC @ 24fps setting, but this got changed after reboot to 30fps
ML is then reporting 23,xxx fps

Thanks to all Devs for their great work

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7195
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1837 on: October 20, 2019, 05:46:28 PM »
Thanks for logs. There is some start up log which seems pretty interesting. I can't understand what to look for or if it's important but maybe a1ex will have a look. Hopefully.

2blackbar

  • Senior
  • ****
  • Posts: 491
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1838 on: October 22, 2019, 01:15:24 AM »
Ive got crashes during startup as well, recent version and error 70 , and i figured out when it happens , its ISO climb feature thats causing this , i tested it right now, so:
-  i have fps override on
- lv digic peaking sharpening on
- histogram on
 pretty much thats it, mcm rewire 16:9, 12 bits , shutter 41, white balance 4800,magenta 3+.
But the issue is within ISO climb feature, why? Set it to 200, record then stop, then go to ISO 100 with trash button, record, stop and turn camera off then on...
Voilla - error and crash.
It was suspicious that it happened mostly when i used iso climb to go down.Im surprised no one picked up on that yet.
- Now i tested with just histogram on (without fps override and digic lv peaking) got error again when iso climbing and powering on again.
- tested without histogram, still happened, maybe not everytime but it happens after iso climbing.

yokashin

  • Member
  • ***
  • Posts: 117
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1839 on: October 22, 2019, 05:27:39 AM »
Once I had a 70 error. The same configuration inspired by ZEEK. I switched from ISO 800 to ISO 400. The error was only once after the reboot. I record the rest of the material for ISO 400 and maybe that is why the error did not return. A concert was recorded. 20-second fragments with camera off.
70D.112 [main cam] | M.202 | S110 [CHDK]

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7195
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1840 on: October 22, 2019, 07:18:58 AM »
New version:
https://www.magiclantern.fm/forum/index.php?topic=9741.msg208959#msg208959

- Changed iso updating on restart. Trying to fix occasional crashes

@2blackbar, @yokashin, please test and try to crash this version.

2blackbar

  • Senior
  • ****
  • Posts: 491
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1841 on: October 22, 2019, 11:21:36 AM »
I tested it , recorded over 20 times climbing iso up/down and had 0 errors/crashes when restarting, so it looks like You fixed it for good ! Thats great !  :D
Ah and i used this link if someone wants to test it:
https://bitbucket.org/Dannephoto/magic-lantern/downloads/crop_rec_4k_mlv_snd_raw_only_2019Oct22.EOSM202.zip

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7195
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1842 on: October 22, 2019, 02:00:54 PM »
That's good news. Updated my broken link.

marodru

  • New to the forum
  • *
  • Posts: 2
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1843 on: October 23, 2019, 03:34:57 PM »
Hello

First of all - as a new user I'd like to really thank everybody here and especially maintainers and veterans for their tremendous efforts! This is so incredible...

I have just updated for the latest version and can also help testing stuff - I have EOS M 2.0.2 and Feelworld F6 PLUS external monitor, which does work with 1080i and different 170 and 95 speed SunDisk Extreme PRO SD Cards.
I'll test pink frames with monitor and FPS override more today and will report if they are gone as well as others say...

Stuff that clearly does not work is focus peaking (on external monitor).

I'm IT person and can do custom tests and do advanced stuff so if my input could be useful - I'd be glad for that. Going to buy a second EOS M this week )))

Thanks again!!!!

Vulisha

  • New to the forum
  • *
  • Posts: 2
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1844 on: October 24, 2019, 12:00:37 AM »
Hi guys, I saw we can't use EOS M using EOS Remote because Canon disabled it :(

But is there a way to use Intervalometer, and connect EOS M to PC and just scrap content from SD card? When I connect cam to PC it goes to pPC share mode by default and shutter is disabled.  Could something like that be done with ML firmware?

Also what is best branch on bitbucket to fork from form EOS M?

Wushuliu

  • New to the forum
  • *
  • Posts: 17
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1845 on: October 24, 2019, 01:13:04 AM »
Is it possible to record audio on any of the raw settings? I know the more demanding presets like Ana etc. you can't, but is it possible mv1080 or 2.5k? I ask because I rarely see sound brought up in recent builds and the videos people post are silent.

turnlemons2lemonade

  • New to the forum
  • *
  • Posts: 17
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1846 on: October 24, 2019, 03:57:25 AM »
Yes it is, use MCM Rewire 14bit and you have sound.

gravitatemediagroup

  • Member
  • ***
  • Posts: 246
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1847 on: October 24, 2019, 05:04:25 AM »
Is it possible to record audio on any of the raw settings? I know the more demanding presets like Ana etc. you can't, but is it possible mv1080 or 2.5k? I ask because I rarely see sound brought up in recent builds and the videos people post are silent.

I personally find the audio SUPERB, even just the on board mic. here is an older build test that has a lot of good raw audio, what blew me away was all the nature sounds I was capturing while not even thinking twice about it while out shooting. If I ever needed some nature sound fx, I would be comfortable with the M getting the job done. lol
  

Wushuliu

  • New to the forum
  • *
  • Posts: 17
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1848 on: October 24, 2019, 05:41:04 AM »
I personally find the audio SUPERB, even just the on board mic. here is an older build test that has a lot of good raw audio, what blew me away was all the nature sounds I was capturing while not even thinking twice about it while out shooting. If I ever needed some nature sound fx, I would be comfortable with the M getting the job done. lol

Great vid, thanks. I can sympathize with Donnie sometimes trying to catch up with all the ML info ; )

thanks guys

w

ilia3101

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 953
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1849 on: October 25, 2019, 07:50:22 PM »
I always hear about these 4.5k 3x anaamoprphic modes - but it seems like they are a little bit cropped, as the sensor has 5184 width resolution.

Would it be it possible to get a 5.2K or 5.1K anamorphic mode? I understand this would require some vertical crop, could it be done and still have a decent aspect ratio? @Danne

Or maybe something inbetween...

Also is is possible to move the anamorphic frame around the sensor?