Author Topic: Danne's crop_rec_4k experiments for EOS M  (Read 214392 times)

Veerle

  • Member
  • ***
  • Posts: 113
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1625 on: September 06, 2019, 04:01:27 PM »
.

mix_vfx

  • New to the forum
  • *
  • Posts: 20
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1626 on: September 06, 2019, 04:47:29 PM »
Hi!

Testing Sept05 build, works very well so far. Playback sometimes gives black screen, not a big concern.

Just a suggestion, could the wheel function be switched and locked by default to Aperture? Shutter lock is already quite neat.

5K ANA gives pink frames when used with "set to 25fps" ON, also not a concern, quite edge case, may be worthy to include force 25fps off in the preset.

Maybe HDMI out could be detected, and be forced to use RealTime preview in 4K Ana, or worked out, why Framing preview gives black output there. If there's anything I can do to help debug, let me know. (Even a release with force logging what you need for it ?)

Thank you a million times
Miki

henricusmaria

  • Freshman
  • **
  • Posts: 70
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1627 on: September 06, 2019, 05:31:16 PM »
I am happy with the use ability of the present build. I also prefer 16:9, but that is easy to change. Then the mv1080p rewire 14 bit and 4K ana rewired 10 bit presets work like a charm!

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7371
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1628 on: September 06, 2019, 05:51:35 PM »
It's not much extra stuff, in 'this' scenario you would just choose advanced and so you wouldn't notice any difference.

Maybe it should, maybe it shouldn't. Either way, I do think it'll prevent issues.
I believe it´s already in easy mode. Install, start camera, start shooting. Want other presets, just tap display and select, keep on shooting. It´s not getting any easier than that imo.


Hi!

Testing Sept05 build, works very well so far. Playback sometimes gives black screen, not a big concern.

Just a suggestion, could the wheel function be switched and locked by default to Aperture? Shutter lock is already quite neat.

5K ANA gives pink frames when used with "set to 25fps" ON, also not a concern, quite edge case, may be worthy to include force 25fps off in the preset.

Maybe HDMI out could be detected, and be forced to use RealTime preview in 4K Ana, or worked out, why Framing preview gives black output there. If there's anything I can do to help debug, let me know. (Even a release with force logging what you need for it ?)

Thank you a million times
Miki
- Don´t know how to default into aperture
- Use 4k anamorphic rewired instead. Stable.
- Force 25fps OFF? Just set the preset to off and it´s in 24fps default
- Turn off Crop rec preview auto mode then select real-time preview for realtime previewing

mix_vfx

  • New to the forum
  • *
  • Posts: 20
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1629 on: September 06, 2019, 06:11:44 PM »
Thank you, that's what I do, just thought, maybe worthy to suggest to default these options, if the aim is to make the presets work as good as possible.

Nice release, I'm actually waiting each day's upload more then the next season of Rick and Morty : DD

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7371
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1630 on: September 06, 2019, 06:30:09 PM »
Thank you, that's what I do, just thought, maybe worthy to suggest to default these options, if the aim is to make the presets work as good as possible.

Nice release, I'm actually waiting each day's upload more then the next season of Rick and Morty : DD
lol!
Defaulting around hdmi out is not a priority to me. Maybe you or someone else could download the code and find out what to do here.

mix_vfx

  • New to the forum
  • *
  • Posts: 20
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1631 on: September 06, 2019, 06:39:11 PM »
lol back : )

I usually have good insights, but am fairly stupid in programming. I'm checking sources in my free time, but quite hard to digest without proper programming background. : ) Till I do, I highly appreciate every little improvement, wether it is important for me or not, and humbly accept all changes basically, while I don't want to upset anyone with these suggestions.

2blackbar

  • Hero Member
  • *****
  • Posts: 507
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1632 on: September 07, 2019, 07:36:51 PM »
I cant find third crop mode anywhere, i know there was 3x3 (1x1 readout from sensor with smaller window) but there was other crop before that , even before raw video working on EOS M, where i can find that crop mode ? I preferred it because its closer(more zoomed in) than 3x3.
Id love it set button would allow us to go to that mode ,3x3 mode and uncropped mode.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7371
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1633 on: September 07, 2019, 07:49:56 PM »
If you select mcm rewired and turn ratios off it should get you there by pushing SET button.
The same can be done with h264 when selected from tap display menu.

2blackbar

  • Hero Member
  • *****
  • Posts: 507
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1634 on: September 07, 2019, 08:31:51 PM »
I see it,  got it mixed up and it was the other way around, bigger crop was closer to 1080p and other one was from 2.5k.
Still it would be interesting to switch between different cop modes with set but maybe not by default cause it has to go 10bit 2.5
Sorry for confusion.

ngemu

  • Freshman
  • **
  • Posts: 83
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1635 on: September 08, 2019, 09:19:30 AM »
I cant figure out why I'm getting pink frames still. I've uploaded pictures of all my settings, is something conflicting with one another?

https://photos.app.goo.gl/D62t9DypA9rGfdiEA

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7371
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1636 on: September 08, 2019, 09:33:26 AM »
New build:
https://www.magiclantern.fm/forum/index.php?topic=9741.msg208959#msg208959

- sticky push set to default when installing. Seems more stable than the default focus aid default option.

@ngemu
I would suggest to skip 5k anamorphic and record with 4k anamorphic rewired instead. They will achieve practically the same but (hopefully) corruption free. I really should rename 4k to 5k anamorphic rewired but low priority atm.
I never use the global draw options so if you still are getting pink frames try turning those options to off as well, but first try with them on as I want to see if 4k anamorphic still holds up with them on. Please report back.

ngemu

  • Freshman
  • **
  • Posts: 83
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1637 on: September 08, 2019, 10:40:13 AM »
 :) will do!

New build:
https://www.magiclantern.fm/forum/index.php?topic=9741.msg208959#msg208959

- sticky push set to default when installing. Seems more stable than the default focus aid default option.

@ngemu
I would suggest to skip 5k anamorphic and record with 4k anamorphic rewired instead. They will achieve practically the same but (hopefully) corruption free. I really should rename 4k to 5k anamorphic rewired but low priority atm.
I never use the global draw options so if you still are getting pink frames try turning those options to off as well, but first try with them on as I want to see if 4k anamorphic still holds up with them on. Please report back.

mix_vfx

  • New to the forum
  • *
  • Posts: 20
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1638 on: September 08, 2019, 01:03:39 PM »
Hi!

Just tested Sept 8th build briefly. All presets record corruption free out of the box. I even got 256 frames of 4K Ana in 14bit before it stopped. 10bit is Continuous.
5K Ana is also corruption free, but you are right to suggest using 4K Ana preset.

Sticky zoom works well, just one needs to press it long enough to stick : ) 200ms?

playback mostly works, but sometimes it stays on a black screen, while playing in the background, like mentioned earlier. Upon exiting playback with half shutter press, sometimes I get 1/3 preview, with bottom 2/3 of the LV remaining white. Texts on the bottom are rendered. Half Shutter press resolves it.

Thank you for your hard work once again.

ricardopt

  • Member
  • ***
  • Posts: 142
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1639 on: September 08, 2019, 02:03:42 PM »
...Just tested Sept 8th build briefly. All presets record corruption free out of the box...Upon exiting playback with half shutter press, sometimes I get 1/3 preview, with bottom 2/3 of the LV remaining white.... Half Shutter press resolves it.

Altough not a big issue, the same happens here, i find myself pressing several times halfshutter to get it right, i noticed that sometimes the preview gets static/frozen when i press record button but switching to photo mode and back to video fixes it.

Thanks for all the work you guys do.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7371
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1640 on: September 08, 2019, 07:04:12 PM »
Thanks for feedback. Halfshutter routines has changed but I need to think through some other ways here later on.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7371
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1641 on: September 08, 2019, 07:34:16 PM »
I put back a delay to the halfshutter push button. Might help some at least when leaving mlv_play...
New build up.

Anaconda_

  • New to the forum
  • *
  • Posts: 21
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1642 on: September 09, 2019, 09:58:51 AM »
I recently updated the build and seem to have lost the ability to turn off any overlays when switching to stills mode. Can someone point me in the right direction?

Essentially, I want to turn off the Cropmarks when taking photos.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7371
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1643 on: September 09, 2019, 10:14:57 AM »
Turn off global draw?

Anaconda_

  • New to the forum
  • *
  • Posts: 21
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1644 on: September 09, 2019, 10:28:52 AM »
Sure, but previously, switching to photo mode did that automatically, and back to video would put the cropmarks etc. back. There was a setting to make this happen, but now I can't find it.

EDIT: found it. in the Cropmarks submenu 'Show in photo mode: On/Off

EOS M user

  • Just arrived
  • *
  • Posts: 1
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1645 on: September 09, 2019, 11:57:49 PM »
Hey Danne, the build you uploaded today is lagging on our EOS M (build: crop_rec_4k_mlv_snd_raw_only_2019Sep09.EOSM202.zip).
Did clear all custom functions, uninstalled previous build, low level formatted the SD card (Sandisk Ultra 128GB 95mb/s).

Could others please confirm if the latest build is working as intented for them? We are forced to use a much older build due to interface lag as we are not sure what is causing it.
The lag has disappeared upon several restarts. Very strange.

Thank you very much for your work, wonderful what you had achieved with ML on this one!
Peter

jonasbø

  • Just arrived
  • *
  • Posts: 1
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1646 on: September 12, 2019, 06:48:41 PM »
I'm blown away by the possibilities you get with an EOS M right now and the results you can achieve with it.
For everyone interested: I was trying to use this little beast of a camera to shoot an entire wedding. Everything was still shot on an older build back in april this year and in a few shots I've found some corrupted frames, but overall it turned out great. 4.5k anamorphic mode was used in all shots. It's on YouTube: /watch?v=IkxYXnYvJlo
From my standpoint as a user of Magic Lantern, I really appreciate the hard work you guys put into the development. Maybe this can serve as an appreciation…

rinski

  • New to the forum
  • *
  • Posts: 46
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1647 on: September 12, 2019, 07:11:42 PM »
Buenas tardes, quisiera saber si el 5k anamorfico es continuo con 10 bits para la sd sandisk 95 mbs extreme pro, no he conseguido mas de 2 segundos de grabación con 1664x2225, con mas de 52 mbs de velocidad se para y con mucho errores.
Gracias.

rinski

  • New to the forum
  • *
  • Posts: 46
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1648 on: September 12, 2019, 07:12:09 PM »
Good afternoon, I would like to know if the anamorphic 5k is continuous with 10 bits for the sd sandisk 95 mbs extreme pro, I did not get more than 2 seconds of recording with 1664x2225, with more than 52 mbs of speed stops and a lot of errors.
Thank you.

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 2008
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1649 on: September 12, 2019, 08:35:24 PM »
No it isn't. I use it at 2.35:1, because then it gets continuous (at 1464x1870 (4K anamorphic rewire)).
5D3.113 | EOSM.202