Author Topic: Danne's crop_rec_4k experiments for EOS M  (Read 209573 times)

henricusmaria

  • Freshman
  • **
  • Posts: 70
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1550 on: August 28, 2019, 08:34:56 PM »
Thanks Danne and Jip-Hop!

That Gain/Aperture adjustment is sweet!

Edit: just tried the Gain/Aperture adustment, when I press down I come into the Canon iso menu. What am I doing wrong?
Also when enabling AF, autofocus doesn't work that great anymore in mcmrewire mode.

ngemu

  • Freshman
  • **
  • Posts: 83
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1551 on: August 29, 2019, 02:27:08 AM »
Bless you both!

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7362
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1552 on: August 29, 2019, 03:11:38 PM »
New upload:
https://www.magiclantern.fm/forum/index.php?topic=9741.msg208959#msg208959

- Fixed a bug around auto iso. It should also handle x10 zoom aid better now.

EDIT: Yet another small bugfix...

Jip-Hop

  • Freshman
  • **
  • Posts: 91
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1553 on: August 30, 2019, 08:00:05 AM »
Thanks Danne and Jip-Hop!

That Gain/Aperture adjustment is sweet!

Edit: just tried the Gain/Aperture adustment, when I press down I come into the Canon iso menu. What am I doing wrong?
Also when enabling AF, autofocus doesn't work that great anymore in mcmrewire mode.

Can you check if you have set the down button to ISO setting in Canon menu? I think that setting is in the yellow menu somewhere.

dnr

  • New to the forum
  • *
  • Posts: 3
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1554 on: August 30, 2019, 01:40:10 PM »
Sorry, if I'm too blind or too stupid to find it, but is there any way to use half-shutter to start/stop recording in Aug30, as in the previous builds?
I found "Rec trigger" in the raw video settings, but that seems to be only for start/pause within a clip.
I did turn off focus aid within the customized buttons, so I think it doesn't interfer with that.
The reason why I need that function is quite simple; my REC button doesn't work.

Luther

  • Senior
  • ****
  • Posts: 323
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1555 on: August 30, 2019, 03:06:30 PM »
That's some nice work Danne and Jip-Hop. Thanks. Can't wait to get a EOS M to play with.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7362
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1556 on: August 30, 2019, 03:20:26 PM »
Cool @Luther. And thanks others posting about testing and so on. All reports ar of value. Good and bads.

Uploaded a new build containing preset shortcuts. Goes like this:
Hold halfshutter(usually this gets you into x10 zoom) Now also tap display and it selects either to 4k anamorphic or 2.5k mode depending on what is set already. Release halfshutter button and it changes preset.
Next shortcut:
Hold halfshutter and also push SET(short push) Gets you into mcm rewired mode or higher fps mode depending on what is set already. Release halfshutter button and it changes preset.

Also centred 4k modes...

henricusmaria

  • Freshman
  • **
  • Posts: 70
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1557 on: August 30, 2019, 05:48:44 PM »
Can you check if you have set the down button to ISO setting in Canon menu? I think that setting is in the yellow menu somewhere.

Thanks, that’s working now!

rinski

  • New to the forum
  • *
  • Posts: 46
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1558 on: August 30, 2019, 07:25:36 PM »
Hello, could someone inform me how to overcome the 1836 rows of high in anamorphic 4k or 5k 10 bits 2.39 proportion, cut 16.9, I have the card estreme pro 95 mbs, in the previous versions alcazaba 1866 and I do not know how to approach the 2000 high as I saw in some video.
Downloading the file 1736x1916 and this file as it is installed in the camera? like the other 3 files of the ML firmware?
Thank you.

Translated with www.DeepL.com/Translator

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 2003
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1559 on: August 30, 2019, 09:30:55 PM »
Great work with the new Movie tab! First it is so different, but then it is so much easier than before! ;)
5D3.113 | EOSM.202

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7362
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1560 on: August 30, 2019, 09:38:28 PM »
You'll get used to it ;)

2blackbar

  • Hero Member
  • *****
  • Posts: 507
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1561 on: August 31, 2019, 12:20:15 AM »
I dont know about it, i get weird stuff happening, locking up, like half shutter magic zoom not working, then 3x crop not wantring to switch off, i feel like this new functionality will scare some people off, it scares me off and i just prefere to downgrade.
I dont know how others feel, i was in more control in previous builds and now im forced to use these new auto modes, i would prefere to have them somewhere as an option and not having to use them as default.2 fingers press doesnt work and i accidentally go to ML menu switching random things by accident like crazy, its convoluted too much , not really simplified for me, i know it was made to make the life simple but i wish it would not be forced but available somewhere if we want to use it occasionally.
 

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7362
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1562 on: August 31, 2019, 12:40:33 AM »
Just turn off what you don't want under customize buttons. Not that hard is it?
Also would help if you gave more datails of freezes etc. Vague descriptions based on feelings won't do.

2blackbar

  • Hero Member
  • *****
  • Posts: 507
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1563 on: August 31, 2019, 01:40:52 AM »
Ok, gave it a go again with newest build, just disabled that first menu so i have 2 fingers tap again, and everything works well.I can go into magic zoom and its not locking up.
I dont know why it was locking up on me so much previously.
So far its looking good and i see some menu items are moved to different locations, maybe its better this way, one location for changing bit modes  instead of two like before.This way is more polished.
Also kept that dropdown list but under info button, in case i need it cause its handy.Strange how little change can make you perceive something differently.
---
I really dig that new relocation of stuff and dropdown list under info button, finally i dont have to enable all modules and go through menus, i wish it would enable fps override with exact fps when i choose mcm rewire but not a big deal, just my personal preference cause footage looks more snappy with it and less rolling shutter is present.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7362
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1564 on: August 31, 2019, 01:58:18 AM »
Yes, I know what you mean. I tested an older build before and it felt like I missed that too ;).
I only recently noticed there was a two finger button push. Never knew it opened ml menu. I don´t know why it doesn´t work with one finger press relocated. But INFO button fixes it so that´s good.
The fps stuff might be possible to do something about but the few tests I did before was pretty problematic. Good part with this latest build is shutter speeds are now coherent through all of the presets.

2blackbar

  • Hero Member
  • *****
  • Posts: 507
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1565 on: August 31, 2019, 02:16:52 AM »
Ah about shutter, i see that this old issue with screen flashing in fps override if you go to shutter above 200 is still there, simple to reproduce i guess, just im mcm rewire enable fps override 23.976 go to shutter above 200, its 258 here and screen starts flashing.Not sure if a lof of pople film with such high shutter speeds.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7362
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1566 on: August 31, 2019, 02:37:48 AM »
I don't use fps override so don't have the issue. I'm surprised it works even since there are so many places in crop rec where timers are changed.

henricusmaria

  • Freshman
  • **
  • Posts: 70
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1567 on: August 31, 2019, 02:57:04 PM »
Autofocus is not working as smooth as in former builds (in mcmrewire). Would be great if that returned to normal.
The Iso/Aperture adjustment is a great addition!

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7362
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1568 on: August 31, 2019, 03:35:53 PM »
Tell me exact preset used in older build and what settings used etc. If you have the build working better check date and name.

henricusmaria

  • Freshman
  • **
  • Posts: 70
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1569 on: September 01, 2019, 04:06:18 AM »
The last build I have used where AF worked normal was the aug06 non jip-hop one. Basically AF worked in all builds up to this last one. AF in the aug06 JH build also worked fine when I deactivated the switch menu.
Settings I use is mv1080p mcmrewire (with x3 crop mode) 16:9 14 bit lossless.

Normally when using AF in mcmrewire you get a big focus box square. In the last build when focussing it switches to a different screen with a small focus box square. With the occasional error like this:


Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7362
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1570 on: September 01, 2019, 08:07:48 AM »
Well it works over here when deactivating focus aid which been the case ever since this function was introduced.

EDIT: Unrelated. Uploaded a version which won´t reset customize buttons when switching presets form startoff preset list. Means if you chnage one of the customized buttons the stay changed until reseting them again or running the default reset preset from the list.

henricusmaria

  • Freshman
  • **
  • Posts: 70
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1571 on: September 01, 2019, 11:25:45 AM »
I always deactivate the focus aid when I use my AF lenses. But in the aug31 build I can deactivate all I want but it automatically gets switched back to default mode when I exit the ml menu.

The new build fixes the problem. Thanks!

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3411
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1572 on: September 01, 2019, 06:32:49 PM »
Thanks @Danne for the quick fix and prompted a quick download. Because of your work ethic on this project I have bought yet another EOSM body for at a decent deal. $80 on OfferUp. Scored!

Four in total so far. In fact, I'm digging the new quick ISO adjustment feature big time! I'll try my best to get back into this forum while I'm at it. Signed on after seeing your recent PM re: MLV App. ;)
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7362
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1573 on: September 01, 2019, 06:33:40 PM »
Welcome back deafeye!

uEOSM

  • New to the forum
  • *
  • Posts: 5
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1574 on: September 01, 2019, 07:55:04 PM »
Hi guys. Share if anyone has firmware crop_rec_4k_mlv_snd_isogain_1x3_presets_2019Jun10.EOSM202
Can be earlier or later