Author Topic: Danne's crop_rec_4k experiments for EOS M  (Read 239634 times)

2blackbar

  • Hero Member
  • *****
  • Posts: 507
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1375 on: July 20, 2019, 10:42:06 PM »
3x halfshutter toggle doesnt work in this and previous one.But i get the message that photo is not possible in zoom mode when i press shutter button all the way.
With build from july 11 toggle 3x works fine.

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 2011
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1376 on: July 20, 2019, 10:48:56 PM »
x3zoom works with trashcan. x10zoom with halfshutter.
5D3.113 | EOSM.202

2blackbar

  • Hero Member
  • *****
  • Posts: 507
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1377 on: July 20, 2019, 10:57:16 PM »
thanks, i forgot it was changed
How i can map ISO selector to one of the buttons on camera, i had it as trashcan from canon menu, now i cant change iso that easily cause im locked out of it by 3x trashcan toggle, my -/+ button is unused.

ZEEK

  • Senior
  • ****
  • Posts: 329
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1378 on: July 21, 2019, 01:35:34 AM »
Examples please @marcelolippi.
@ZEEK Not quite following you here, x10 xoom works the same with all presets. Press halfshutter to activate it. Could you elaborate?

I just mean when you want real time preview in 2.5k, 4k or 5k modes through a half press shutter to view the correct framing, it will instead go into x10 zoom. Unless there is an alternayive key that can be set. No big deal here, though great stuff with the auto ISO.
EOS M

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7392
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1379 on: July 21, 2019, 01:57:57 AM »
Yeah, I guess one has to start off in framing preview mode when using x10 zoom in x5 modes. Or else no correct framing at all.

I put up a new build again. Refined previewing(autoiso)
Starting to dig autoiso quite a lot...

ricardopt

  • Member
  • ***
  • Posts: 142
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1380 on: July 21, 2019, 02:15:58 AM »
Hi everyone

Ive been unable to get rid of the pink frames using the 4.5k lua script, 16:9, 2.35 or 2.39 doesnt matter which resolution i choose, is it possible for anyone that had sucess at this resolution to share their settings, i purchased a 128gb sandisk extreme pro sdcard thinking the card i was using was at fault but same thing happens, i have kill global draw enabled, some kind of log shows up with codec error etc, in 1080 rewired theres no pink frames.



Thanks

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7392
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1381 on: July 21, 2019, 02:30:12 AM »
Run the lua script. Once it´s done swith to the 5k anamorphic preset instead. Now you should be in 2.39:1 but not in rewired mode. Don´t enable the Kill global draw option since you won´t have framing preview to work with.

ricardopt

  • Member
  • ***
  • Posts: 142
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1382 on: July 21, 2019, 02:50:51 AM »
Thanks, just done a quick test with 5 short recording, 4 were clean, 1 had kind of strobing pink frames, 2am here, will format and clean install ml in the morning.

thanks

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7392
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1383 on: July 21, 2019, 10:51:24 AM »
thanks, i forgot it was changed
How i can map ISO selector to one of the buttons on camera, i had it as trashcan from canon menu, now i cant change iso that easily cause im locked out of it by 3x trashcan toggle, my -/+ button is unused.
How are you accessing magic lantern menu if trash can button is assigned to iso?
I guess set button is a good alternative to trash can when it comes to x3 zoom.

rinski

  • New to the forum
  • *
  • Posts: 47
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1384 on: July 21, 2019, 01:04:05 PM »
Hello, I'm new I would like to know if you can install the firmware 2.0.2 if the machine when it comes with version 2.0.3 of canon to install the latest magic latern, thank you.

Stousen

  • New to the forum
  • *
  • Posts: 43
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1385 on: July 21, 2019, 01:10:00 PM »
New build, usual place:

- Autoiso now have a few friends


EDIT: uploaded new build again. Fixing automation conflict.

Super nice Danne, tack så jäkla much for your work. You're the man.

//Chris

2blackbar

  • Hero Member
  • *****
  • Posts: 507
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1386 on: July 21, 2019, 01:32:52 PM »
Im using 2 finger tap to enter ML but once i set everythin in ML menus i dont need to enter that often, so i just adjusted ISO with trashcan button because thats the only one i can map to iso selector in canon menu, set
 or +/- would be good for me, where i can change that ?
Id prefere not to change iso from within ML menu cause once i enter ML menu i have to go to video settings, then go down to enter iso and then adjust... too many steps, trashcan for changing iso was quite convenient. So i was wondering why theres no maximum iso setting in autoiso and there it is, it works fine but sometimes handy button to set iso manually helps.

berechiah

  • Freshman
  • **
  • Posts: 84
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1387 on: July 21, 2019, 02:51:35 PM »
.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7392
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1388 on: July 21, 2019, 04:32:41 PM »
thanks, i forgot it was changed
How i can map ISO selector to one of the buttons on camera, i had it as trashcan from canon menu, now i cant change iso that easily cause im locked out of it by 3x trashcan toggle, my -/+ button is unused.

Selectable button:


New build posted:
https://www.magiclantern.fm/forum/index.php?topic=9741.msg208959#msg208959

2blackbar

  • Hero Member
  • *****
  • Posts: 507
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1389 on: July 21, 2019, 04:41:42 PM »
Works great, just tested it ! Thanks a lot !

gravitatemediagroup

  • Member
  • ***
  • Posts: 247
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1390 on: July 21, 2019, 07:34:04 PM »
.

this isn't FB with notifications, so you'll have to check back from time to time ;) Just thought i'd let you know rather than you wait for info updates that never come.

hokinari

  • New to the forum
  • *
  • Posts: 4
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1391 on: July 22, 2019, 02:19:39 AM »
hi guys! I have some artifacts in all my footages, how to fix that??
There is no problems in live view when i grade it in MLV app, but when I render it's appear. screenshot of my settings and test footage are linked bellow
I shooted on eos m
mv1080p MCM rewire profile RAWvideo on
Bit Rate(CBR) up to 1.2x
memory card -  SDXC 64Gb Kingston Canvas React UHS-I U3 V30 A1 (100/80 Mb/s)
there is some footages - drive.google.com/open?id=1gPLcpOIqcCvMoTxocV2MjxyJip3bXaJF

henricusmaria

  • Freshman
  • **
  • Posts: 70
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1392 on: July 22, 2019, 08:27:54 AM »
@hokinari why do you have the bitrate at 1.2x?

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 2011
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1393 on: July 22, 2019, 09:57:30 AM »
@hokinari: could we get the MLV for analysis?
5D3.113 | EOSM.202

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7392
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1394 on: July 22, 2019, 11:49:34 AM »
New upload:

- Fast iso access through INFO(eosm)/SET(100d) button. Push it to quickly walk through iso starting from 100 to 3200


hokinari

  • New to the forum
  • *
  • Posts: 4
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1395 on: July 22, 2019, 05:15:43 PM »
@henricusmaria Cause I thing it gives me higher bitrate
Actually problem was solved by changing debayer mode LMMSE to Receipt configuration
@mask Ml file in folder directed from he link - drive.google.com/open?id=1gPLcpOIqcCvMoTxocV2MjxyJip3bXaJF

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 2011
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1396 on: July 22, 2019, 06:49:47 PM »
@henricusmaria Cause I thing it gives me higher bitrate
Actually problem was solved by changing debayer mode LMMSE to Receipt configuration
@mask Ml file in folder directed from he link - drive.google.com/open?id=1gPLcpOIqcCvMoTxocV2MjxyJip3bXaJF
Bitrate is for compressed (H.264) recording. Using RAW it has no effect.
Ah, you used LMMSE (your screenshot showed AMaZE)... that explains all: LMMSE & EOS M RAW file is a bad combination (whyever). It is a known bug, but I have no idea why it happens. If someone else has an idea, please let me know. It seems to come out of the LMMSE "library"/source code file.
5D3.113 | EOSM.202

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7392
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1397 on: July 24, 2019, 08:58:35 AM »
Uploaded a new version. Bugs was happening with iso climb preset so took it out for the time being. Recommended to redownload the latest.

EDIT: Workaround isoclimb hopefully working for eosm and 100d. 5D3, todo.

ngemu

  • Freshman
  • **
  • Posts: 83
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1398 on: July 25, 2019, 04:04:34 AM »
Very strange indeed. Maybe sensor is broken? Probably not. Could you do test with and without the viltrox adapter? Also try to find a way to safely reproduce the issue if possible. Thanks.

Hi Danne. I was able to reproduce the same vertical line using the efm 18-55mm kit lens. I originally had this while using a canon 35mm is lens with viltrox adapter.  It seems to only appear when I use the 2.5k mode.

With this example, the lines disappear using the '''pattern noise on'' feature but it also induces other artifacts into the footage. This did not work with some other videos I had with these vertical lines though.

Settings
fps - 23.976
crop mode - 2.5k 2520x1418
x3 crop toggle - on
set 25fps - on
raw - 1736x976
aspect ratio - 16:9
data format: 14-bit lossless

Screenshot
https://i.imgur.com/ednpgDP.jpg

MLV sample link
https://drive.google.com/file/d/1WM0aihrhb5Xx2Iq0aANcRrzDSPF1GEDb/view?usp=sharing

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7392
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1399 on: July 25, 2019, 07:37:49 AM »
Interesting. Is it happening on every recording with this set up? If so you could test to find what is causing this. Maybe the villtrox, fps or something else.