Author Topic: Danne's crop_rec_4k experiments for EOS M  (Read 239621 times)

baberide

  • Guest
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1875 on: October 30, 2019, 09:17:19 PM »
"I have disabled highlight tone priority, it has extended the ISO range down to 100, but every photo still comes out over exposed. Only with auto ISO does it look right."

I experience this with a few lenses when taking pictures, notably my Rollei HFT 50mm f/1.8 and SMC Takumar 200mm f/4. Using the exposure compensation to make the camera "underexpose" half a stop or so sorts this out. Other lenses don't have this problem at all.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7392
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1876 on: October 30, 2019, 10:11:52 PM »
There are some settings like you mention that will interfere with exposure using manual lenses etc. I'm sure you'll pass them all in no time.
Latest build is always in this post:
https://www.magiclantern.fm/forum/index.php?topic=9741.msg208959#msg208959

Have fun :)

ilia3101

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 990
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1877 on: October 30, 2019, 10:14:52 PM »
Thank you for the link😍

I hope the exposure preview will be correct once I use chipped m42 adapter + ef adapter (when that comes). I get accurate exposure when shooting stills in video mode, so I will use that for now.

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 2011
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1878 on: October 30, 2019, 10:21:39 PM »
Hm... never had much overexposed photos with the M. Did you use Av mode for your manual lenses? My PB-EOS adapter has no chip and it works wonderful.
5D3.113 | EOSM.202

ilia3101

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 990
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1879 on: October 30, 2019, 10:24:22 PM »
I used manual M mode and manual ISO, only auto ISO gave results that match display exposure, when using manual ISO the result is about two stops brighter than it showed on the screen. The adapter I am using right now is an M39-EFM - no chip at all.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7392
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1880 on: October 30, 2019, 10:32:49 PM »
Test enabling or disabling exposure stuff. There are two places I think. Exposure should match. Get a screen shot from masc camera settings ;)

ilia3101

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 990
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1881 on: October 30, 2019, 11:08:37 PM »
I will try and find all exposure settings I can. Menu is unfamiliar and a little bit intimidating. So far I only disabled highlight tone priority in custom function (what a weird place for the setting, and strange that it is enabled by defualt)

2blackbar

  • Hero Member
  • *****
  • Posts: 507
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1882 on: October 31, 2019, 01:01:20 PM »
I disabled all exposure related stuff in canon custom functions, video and photo modes have diffferent brightness even on manual and same settings, but when taking picture its good exposure (like liveview in videomode) but in photomode liveview is too dark, whjich is strange cause its full manual same iso as video mode and same shutter, same aperture, so in the end it does take picture correctly but liveview brightness is not correct when in photo mode.
Auto iso doesnt help , it actually makes things even more incorrect, liveview is still too dark in photo mode and autoiso.
taking picture when touching screen is not helpful at all, cant get into magic lantern menu with 2 fingers tap.
OK, managed to get into ML menu in photo mode, disabled ExpSim in expo panel  and then enabled ExpoOverride which is important and it fixed wrong screen brightness.IMo it should be disabled from get go and set like that.
ISO up/down buttons dont work for me in photo mode( they bring up typical shooting mode selection), too bad cause its very useful.If some people dont like it , it still would be great as an option, in ML menu photo mode ISO up/down is still enabled like in video mode but it doesnt work.

ilia3101

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 990
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1883 on: October 31, 2019, 04:36:37 PM »
I disabled all exposure related stuff in canon custom functions, video and photo modes have diffferent brightness even on manual and same settings, but when taking picture its good exposure (like liveview in videomode) but in photomode liveview is too dark, whjich is strange cause its full manual same iso as video mode and same shutter, same aperture, so in the end it does take picture correctly but liveview brightness is not correct when in photo mode.

Sounds just like the issue I am having!

But I don't have the issue when I tried my 19-35 electronic lens. Only with manual lenses.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7392
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1884 on: October 31, 2019, 08:33:34 PM »
That's what happens when switching to manual lenses. Try 2blackbar suggestion.

ilia3101

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 990
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1885 on: October 31, 2019, 09:16:46 PM »
Oh wow enabling expo override and disabling expsim does fix it! Magic Lantern fixes the EOS M's broken ness.

Thanks so much.

DudeSoCool

  • New to the forum
  • *
  • Posts: 2
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1886 on: October 31, 2019, 10:14:38 PM »
May I ask how I can take a picture in Manual Focus mode
with a manual lenses? The Canon EOS-M wont take a picture unless Its in auto-focus mode
with an auto-focus lenses. The Firmware 2.0.2 and 2.0.3 wont allow it but the previous
old firmwares will but they're difficult to find.

Anyone know of a fix?

lightspeed

  • Freshman
  • **
  • Posts: 62
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1887 on: November 01, 2019, 04:24:48 AM »
with 10 bit the signal is divided by 32 before compression. anyone know why that is the case?

DudeSoCool

  • New to the forum
  • *
  • Posts: 2
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1888 on: November 01, 2019, 09:49:32 PM »
CAN anyone show me a way to get Canon EOS-M to take a picture in manual mode on the firmare 2.0.2. or 2.0.3 despite the fact it only has autofocus and only takes a picture with autofocus and autofocus lenses?
IM using Manual Focus lenses and I want to take a pic!!!!

petelo

  • New to the forum
  • *
  • Posts: 5
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1889 on: November 02, 2019, 01:11:02 AM »
@Danne

I own 2 eos M and I am very happy with what you have done on magic lantern for them. I now own also an EOS 650D, do you think it is possible to have the same things in ML for the 650D, like touching the screen to directly access the setup for MCM rewire and other setup without dealing with to much setup in other ML tab. Thank you for your icredible talent.

Petelo

2blackbar

  • Hero Member
  • *****
  • Posts: 507
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1890 on: November 02, 2019, 12:03:06 PM »
DudeSC theres this dumbest useless canon setting in menu that blocks taking pics with manual lenses, its in canon menu just disable it.release shutter with manual.lens or soemthing like that , im away from cam dont remember but its enabled by default.

ZEEK

  • Senior
  • ****
  • Posts: 329
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1891 on: November 02, 2019, 01:12:53 PM »
Yep. It's in the "yellow wrench" settings under "Custom Function" - Enable "release without shutter" or something like that...  8)
EOS M

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8487
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1892 on: November 02, 2019, 01:29:21 PM »
C.Fn-7 Release shutter w/o lens
Manual page 287

marcelolippi

  • New to the forum
  • *
  • Posts: 42
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1893 on: November 04, 2019, 04:55:04 AM »
where can I find the canon menu to: enable AWB and to set audio levels?

turnlemons2lemonade

  • New to the forum
  • *
  • Posts: 17
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1894 on: November 04, 2019, 08:42:53 AM »
Jut press the menu twice to go in the Canon menu and you can find both.

ilia3101

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 990
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1895 on: November 05, 2019, 06:56:05 PM »
Congrats Ilia on the purchase!  8)
Thanks to Danne & the ML Team, 5K rewired is awesome! 10-bit is the best if you want continuous recording using that mode with Ratio "on" @1464x1836, 23.972fps [2.39:1 or other] or ratio off @1736x2178, 18fps, 2.39:1 or other]. You can select 14 bit but you won't get as much recording time unless you dial the resolution back. Its also nice to have a full frame dslr and mirroless camera, good combo! I know MSAC also has these two which is cool!

@Danne
With ratio set to OFF in 5K Rewired @1736x2178 I can get 23.97fps using fps override, the only issue though is that it freezes in the live view.  ::) :'(

With 5K rewired and ratio OFF I get 12fps. And when I try to fps override above 15fps, the image just stops existing and I get 2.6 kilobyte MLV files. How can you get 23.976 @ 1736x2178??? I literally cannot make it work much above 12 fps

Also how do you set ISO while in video mode?

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7392
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1896 on: November 05, 2019, 07:19:48 PM »
Iso through info screen but really. Use up or down press for fast iso access. Works even while recording. You can turn off this iso feature if you want to use ml iso or default.
24 fps with full readout sensor is not possible.

ilia3101

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 990
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1897 on: November 05, 2019, 08:54:17 PM »
Thank you Danne! I like the ISO with buttons method, much faster than normal version.

I figured out that I need to enable "set 25fps" - then I get 1736x2178 at 18fps - without enabling it I only got 12. The name of the option doesn't make much sense, doesn't seem to do anything related to 25 fps :D But 18 FPS is good enough for me.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7392
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1898 on: November 05, 2019, 09:24:21 PM »
Yes, got the question about 18fps a while ago but couldnĀ“t find a real logical way to add it so I just enabled this mode with ratios off ans set25fps. Good you found it :).

ZEEK

  • Senior
  • ****
  • Posts: 329
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1899 on: November 05, 2019, 09:28:00 PM »
Glad to hear it's working! 8) 5K Rewired Mode is really nice. I have to say 2.5K is really amazing also. The resolution and detail you get is really noticeable and especially when you upscale it a little, looks tremendous. I don't mind the crop factor. it behaves now like the Original BMPCC with the crop factor (around ~2.9x) and works well if you have wide-angle lenses. Thanks Guys! ;D
EOS M