Author Topic: Danne's crop_rec_4k experiments for EOS M  (Read 213192 times)

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7368
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1350 on: July 18, 2019, 08:09:38 PM »
Aight. No rush. Maybe the viltrox affects something.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7368
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1351 on: July 18, 2019, 11:57:28 PM »
New version:
https://www.magiclantern.fm/forum/index.php?topic=9741.msg208959#msg208959

- x10 focus aid working with autoiso set

What can I say. a1ex(ML) code includes so much functions to play around with...

ngemu

  • Freshman
  • **
  • Posts: 83
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1352 on: July 19, 2019, 08:30:11 AM »
Anyone seen this before? I am getting it randomly in 2.5k mode, both in day and night shots. Its a straight green / red line that runs vertically on the right side of the video. Its always at the same spot.

I am using a viltrox (non speedboosted) adapter with canon 35mm IS lens if that matters. mlvapp cant seem to get ride of it.

https://imgur.com/wjEVt4J

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7368
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1353 on: July 19, 2019, 09:21:36 AM »
Please upload a sample mlv with this issue. Could a number of things affecting. Which one of the 2.5k modes by the way?

ngemu

  • Freshman
  • **
  • Posts: 83
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1354 on: July 19, 2019, 10:59:41 AM »
Please upload a sample mlv with this issue. Could a number of things affecting. Which one of the 2.5k modes by the way?

2.5k 2520x1418

Thank you Danne

https://drive.google.com/file/d/1S6JWVK6XaaHHt2IE6inFN8aPKCWRamLy/view?usp=sharing

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7368
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1355 on: July 19, 2019, 12:08:18 PM »
Very strange indeed. Maybe sensor is broken? Probably not. Could you do test with and without the viltrox adapter? Also try to find a way to safely reproduce the issue if possible. Thanks.

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 2007
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1356 on: July 19, 2019, 12:52:27 PM »
I've never seen something like this before. But with "Pattern noise" in MLVApp the stripes go away. On the other side, Pattern Noise brings "funny" textures...
5D3.113 | EOSM.202

guerchi

  • New to the forum
  • *
  • Posts: 19
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1357 on: July 19, 2019, 06:46:23 PM »
Anyone seen this before? I am getting it randomly in 2.5k mode, both in day and night shots. Its a straight green / red line that runs vertically on the right side of the video. Its always at the same spot.
Yes, I also obtained similar (not the same) vertical lines in that mode, randomly in night shots. If the shot was long enough it tended to slowly disappear completely, I did not experience the problem again with Danne's latest versions, but I did not do many night shots lately in that mode either.

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 2007
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1358 on: July 19, 2019, 07:22:53 PM »
New version:
https://www.magiclantern.fm/forum/index.php?topic=9741.msg208959#msg208959

- x10 focus aid working with autoiso set

What can I say. a1ex(ML) code includes so much functions to play around with...
So good Danne! Thank you! AND: AutoISO now works also in 5K anamorphic! MaxISO @800 is also a great addition! So many great new stuff again and again! ;)
5D3.113 | EOSM.202

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7368
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1359 on: July 19, 2019, 08:29:30 PM »
Thanks man! One thing in autoiso is metadata reports not always what ml display shows. Maybe my build. Didyou notice this too?

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 2007
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1360 on: July 19, 2019, 08:39:28 PM »
With this maxIso thing it seems to work. Tried 2 clips, OFF->ISO3200 (shown in liveview and in clip) and ON->ISO800 (in both).
But if I remember right, I saw that in past - the liveview showed e.g. ISO800 and it was ISO640 or something. It seems it shows just the 100,200,400,800,1600,3200,6400 in liveview. Is it that what you mean?
5D3.113 | EOSM.202

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7368
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1361 on: July 19, 2019, 08:49:35 PM »
Gotta check some more. I tested when iso was at 800+ then at iso 200, both came out iso 800.

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 2007
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1362 on: July 19, 2019, 08:57:51 PM »
Okay... no, haven't see this so far.
5D3.113 | EOSM.202

gravitatemediagroup

  • Member
  • ***
  • Posts: 247
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1363 on: July 19, 2019, 10:20:57 PM »
2.5k 2520x1418

How are you achieving continuous recording in that resolution? I've never got more than a couple seconds before it stops.  The sample you posted is 1920x1080

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7368
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1364 on: July 19, 2019, 10:26:40 PM »
New version:
https://www.magiclantern.fm/forum/index.php?topic=9741.msg208959#msg208959

- Max iso preset. Restrict autoiso to iso 800 instead of cnot controlling iso skyrocketing to up to 6400


Bob Bell

  • Just arrived
  • *
  • Posts: 1
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1365 on: July 19, 2019, 10:50:00 PM »
I have several EOS DSLRs but bought a Canon EOS M3. I have found that it is useless for studio work. You cannot turn off exposure simulation. This means that with studio flash (where the lighting is by the studio flash and you set manual exposure mode) the viewfinder image is black. Exp sim turns off for a split second to give AF a chance but then the exposure simulation kicks in and you get a near black image - you cannot see to compose or shoot. A typical studio setting would be f/8.0 @ ISO 200 @ 1/200s  - excellent for studio flash but lousy for the EOS M3. Exposure sim switches off if you pop up the tiny on camera flash, but that's as stupid as buying a car and then pushing it. Canon acknowledges this problem but, despite their "Pro" claims for the EOS M3 is the only maker who has not provided an option to switch off exposure sim. Canon's great advice - buy an EOS R because that has it.
Does anyone know how to fix the problem or has a Magic Lantern app that can disable exposure simulation?

I think that Magic Lantern is not available for the EOS M3.

Any help that anyone can give will be appreciated. I bought the M3 to do high speed photography where high speed flash (1/40,000 s) is the main light source.

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8430
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1366 on: July 20, 2019, 12:15:40 AM »
https://builds.magiclantern.fm/ -> "Your camera is not listed?" -> Last item

ZEEK

  • Senior
  • ****
  • Posts: 329
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1367 on: July 20, 2019, 01:29:24 AM »
- Max iso preset. Restrict autoiso to iso 800


Brilliant work! I just installed the July 18 ml build last night. It's fantastic, especially with the x10 focus aid. I think the only issue for that is as mentioned previously, in non MCM Rewire modes where you need to half press the shutter to preview correct frame e.g. on 2.5k or 4k mode. Unless I've missed something..
The auto ISO tool max 800 is definitely great! :)
EOS M

marcelolippi

  • New to the forum
  • *
  • Posts: 42
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1368 on: July 20, 2019, 01:47:42 AM »
today I did some quick tests with the eos M (4.5k 10bit lossless) and the red helium 16 bit in 4 and 8k. Luminous scene, ettr ... the eos has made a good figure working with 6bit less and compressed, the thing that struck me negatively was the alias, practically I saw a scale for the 3x1, maybe something I didn't set well in the mlvapp?

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7368
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1369 on: July 20, 2019, 06:21:24 AM »
Examples please @marcelolippi.
@ZEEK Not quite following you here, x10 xoom works the same with all presets. Press halfshutter to activate it. Could you elaborate?

ricardopt

  • Member
  • ***
  • Posts: 142
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1370 on: July 20, 2019, 09:27:14 AM »
I think he's trying to say that on 2.5 and 4k the half press shutter is also used to preview the correct framing, how will it do both functions on half press?

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7368
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1371 on: July 20, 2019, 09:38:17 AM »
Did you test?
If you start off in framing preview x10 zoom will work nicely. If you start off in real time preview then you loose the framing preview but only when not recording. Once recording camera acts without x10 zoom.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7368
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1372 on: July 20, 2019, 12:15:39 PM »
New build, usual place:

- Autoiso now have a few friends


EDIT: uploaded new build again. Fixing automation conflict.

2blackbar

  • Hero Member
  • *****
  • Posts: 507
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1373 on: July 20, 2019, 03:43:25 PM »
This is great, i wanted it since the beginning of ML.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7368
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1374 on: July 20, 2019, 09:04:52 PM »