Author Topic: Danne's crop_rec_4k experiments for EOS M  (Read 210576 times)

sirminder

  • New to the forum
  • *
  • Posts: 9
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1300 on: July 13, 2019, 04:21:16 PM »
You are correct. Nowhere in your statement did you suggest that.

However, you hinted that a possible reason for the problem was that he formatted the card "inside a cam without ML".

That left me wondering if reformatting the card after installing ML was a little known secret or just good practice.

marcelolippi

  • New to the forum
  • *
  • Posts: 42
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1301 on: July 13, 2019, 04:45:30 PM »
I have another card I make comparisons with it, I formatted the bad one from the pc, then from the eos and finally loaded the build of 12 July, 11 July and 7 June. Nothing, with the other card works well, as always

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7365
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1302 on: July 13, 2019, 04:51:11 PM »
Well. Important now is to know if you got the card working again following Walters suggestion or not?

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8421
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1303 on: July 13, 2019, 07:24:32 PM »
That left me wondering if reformatting the card after installing ML was a little known secret or just good practice.

Looks like world record for long jump to conclusions is actually broken.

marcelolippi

  • New to the forum
  • *
  • Posts: 42
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1304 on: July 13, 2019, 08:48:04 PM »
the eos m with this card does not start anymore: first I thought about the camera, I remove the battery but nothing to do, it doesn't start. I remove the sd and format the sd in the card reader, in the meantime I start magic lantern with the other card: ML starts again. Load the defective sd reformatted on the eos and formated into eos. I remove the card and load the latest version of ML, eos m turns on, I can record from the canon menu, take photos, etc .: ML but no signs of life, the screen that would be arranged for it is empty, only the two horizontal lines of 16: 9. I have redone everything changing versions, with the other card it works, with this card nothing.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7365
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1305 on: July 13, 2019, 09:41:36 PM »
But did you reinstall by updating firmware with the included ml fir?

marcelolippi

  • New to the forum
  • *
  • Posts: 42
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1306 on: July 13, 2019, 09:46:29 PM »
yes, but not from the card that seems damaged, I installed the firmware with three different builds from the card that works

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8421
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1307 on: July 13, 2019, 09:56:49 PM »
To enable the card (=make it bootable again) you have to run install from that card or you have to use EOScard/MacBoot/makebootable.sh.

marcelolippi

  • New to the forum
  • *
  • Posts: 42
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1308 on: July 13, 2019, 11:21:12 PM »
Thanks...I have used magic lantern since 2012 but Alzheimer is progressing quickly... :) :)   :)

nydahl98

  • Just arrived
  • *
  • Posts: 1
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1309 on: July 14, 2019, 01:05:16 AM »
I have only had Nightly. 2018Jul03.eosm202

tested crop_rec_4k_mlv_snd_isogain_1x3_presets_2019Jul13.EOSM202
And there is missing some modules like ettr.
How do i include more modules?


gravitatemediagroup

  • Member
  • ***
  • Posts: 247
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1310 on: July 14, 2019, 01:11:57 AM »
For those that are new to ML or old timers, just a reminder there is a dedicated facebook group for MLV on EOS M with plenty of knowledgeable users that can help answer a majority of basic troubleshooting questions.  I'm only posting this reminder to let people know there are other ways to find an answer that doesn't involve clogging up the development discussion.  Of course, if it's a possible bug needing to be reported, the ML forum would be the right place.  If facebook isn't your thing, disregard this post. lol

https://www.facebook.com/groups/375018026655820/?ref=bookmarks   

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8421
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1311 on: July 14, 2019, 07:12:33 AM »
And there is a reddit and Petapixel and there are DPReview forums and Miranda forums andandand. Sounds legit to open a few more, they are all clogged.

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 2003
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1312 on: July 14, 2019, 01:11:22 PM »
Curious if it´s possible to pause autofocus somehow?
If that is impossible... how about the other way: are you able to read the state of the AF/MF switch of the lens, or if the lens has AF at all? So "if( !afActive | mfLens ) do x10zoom..." could be an option...
5D3.113 | EOSM.202

ZEEK

  • Senior
  • ****
  • Posts: 329
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1313 on: July 14, 2019, 01:36:37 PM »
Pause autofocus. When an EF-M lens or other AF Lens is attached, you can go into the second RED tab in the original canon menu of the Eos M and set AF+MF to MF Only which will get rid of AF for good.
EOS M

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7365
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1314 on: July 14, 2019, 01:46:58 PM »
Manual is working and also af is working with x10 focus aid when in photo mode. It starts to get tricky when in crop_rec with all registry changes going on. I´checking into a function which will work same as in photo mode. I already has it working in 5D3 I believe since I short circuit reg  patches while working with x10 focus aid so should work. Now add mcm rewired round truip to the mix for eosm and 100D and it´s not as simple getting it to work again ;).
There´s af property code checking which is implemented here and there but It seems crop_rec isn´t fast enough to see if af is running or not so might be a race condition...

2blackbar

  • Hero Member
  • *****
  • Posts: 507
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1315 on: July 14, 2019, 06:11:50 PM »
Is it at all possible to record 10x image ? OR its digital zoom from x3  and not really useful ?

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7365
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1316 on: July 14, 2019, 06:17:56 PM »
Stream is still x5 zoom, only preview window is changing so I think not.

gravitatemediagroup

  • Member
  • ***
  • Posts: 247
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1317 on: July 14, 2019, 06:42:07 PM »
And there is a reddit and Petapixel and there are DPReview forums and Miranda forums andandand. Sounds legit to open a few more, they are all clogged.

I use none of those forums.  PetaPixel is more or less click bait now days, I've never even heard of Miranda.  Can you upload videos to any of the above sites or would it require linking to YouTube or Vimeo? I'll also go out on a limb and say the response to a question on facebook is quicker than all of the above.  Like I said earlier, if facebook isn't your thing, disregard the post, unnecessary sarcasm has never solved a problem.  Forgive me for trying to leave this topic open to more advanced users and developers,  I personally don't like to scroll through 20 questions of somebody trying to load ML on an SD card when all I'm really looking for is the latest build's discussion and the changes pertaining to that build.  If I myself have a basic question, I would hate to ask it on here just to get some kind of sarcastic response...it solves nothing.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7365
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1318 on: July 14, 2019, 07:21:55 PM »
Could you make the group open?

2blackbar

  • Hero Member
  • *****
  • Posts: 507
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1319 on: July 14, 2019, 07:23:01 PM »
I made this from current builds, recorded video in x3 and x5 modes then placed on frame from uncropped video, overlayed with sensor chart on top
One is with crop modes non centered , how they actually are right now, and other one is with crop modes centered by me
From the chart you can figure out it will vignette with 16mm camera lenses in x5 mode but might work in x3 mode , also it will vignette with regular camcorder or 8mm camera lens on both x5xand x5 modes.
Is it somehow possible to crop x5 mode in camera to get non vignetting image from 16mm cam lenses or 8mm cam and still get hd resolution  or nobody done that before and its just better to crop in post ?


gravitatemediagroup

  • Member
  • ***
  • Posts: 247
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1320 on: July 14, 2019, 08:16:21 PM »
Could you make the group open?

Yes, but I'd prefer not to for a few different reasons.  Main reason is to keep spam/advertising bots from being a nuisance, along with real people trying to promote junk or scams.  Another reason is occasionally when a post is made within an open group, it will show up on non members timelines saying "_____ posted in the group MLV on EOS M".  I'm sure that's facebook's automatic way of trying to help the groups population grow, but then the next thing you know peoples grandmothers will be posting in the group asking how to fix her TV, or somebody's friend popping in just to be a troll to some degree.  I could come up with a couple other reasons, but those are the main ones.  One other reason would be if somebody is wanting feedback on a project they're working on, they may want to try and keep it private from public viewing until it's complete. 

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7365
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1321 on: July 14, 2019, 08:55:43 PM »
Could be open for reading but not posting if not a member.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7365
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1322 on: July 15, 2019, 06:30:48 PM »
New version:
https://www.magiclantern.fm/forum/index.php?topic=9741.msg208959#msg208959

Commit:
https://bitbucket.org/Dannephoto/magic-lantern/commits/c2df8771dfb4aac8a83bd1da33db38de21c099f4

- Remapped x3toggle button so now it works by pushing garbage can button shortly instead. Doing a long_press on garbage can button still enters magic lantern menu same as before



Now it would be nice to be able to do a long_press on INFO button to toggle x10 mode and normal usage of info button otherwise. This way we can leave halfshutter alone for focusing etc...

Question: Maybe this x3crop toggle with trash can button should be default permanent in these builds?

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 2003
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1323 on: July 15, 2019, 07:47:28 PM »
I like the idea's. I used the shutter key solution this weekend and accidentelly full pressed sometimes. This leaded 50% to frozen cam. This can't happen now.
5D3.113 | EOSM.202

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7365
Re: Danne's crop_rec_4k experiments for EOS M
« Reply #1324 on: July 15, 2019, 07:55:43 PM »
Yeah. It's way more intuitive this way. Tried defining long_press of thrash can for 5D3 in menu.c but won't work as with eosm.