Author Topic: Bad CF Card manipulation - Can't boot on any bootable CF Card  (Read 899 times)

tor

  • New to the forum
  • *
  • Posts: 2
Bad CF Card manipulation - Can't boot on any bootable CF Card
« on: December 07, 2020, 12:02:50 AM »
Hello,

I have a Canon 5d Mk II, firmware 2.1.2

My problem is quite the same as the one described here : https://www.magiclantern.fm/forum/index.php?topic=2726.0 - not the same procedure, but same symptoms

I had ML working pretty good on 1 CF Card for a few months (neat !)
I decided to install it on another CF Card. I did follow the procedure correctly - I think - as ML was working on both of Cards (double neat !)

Here's the fjlkdghdlk -

I decided to remove ML from these 2 cards (don't ask me why I wish I could just cancel it)
I format the 2 bootable CF Cards on my LAPTOP - Didn't know this could be an issue (!)

And now I'm stuck. My 5d won't work with any CF card. But If I turn it on without card, it work as a charm.

Here are the symptoms !
The Camera does turn ON - sometimes with a little loading, sometimes not
When the shutter is depressed it flashes "busy" on the top LCD until finally on the back LCD it comes up and says, "card not formatted, format with this camera".
When I go to the format feature in the camera menu, and try and format the card in the camera, it says that the card cannot be formatted, and to try a different card.
I've tried another card that does NOT have ML on it, and it does not work at all.

I tried to make the cards bootable again with EOScard, doesn't change anything. I tried a card with Canon firmware update on it, nothing (but the card can't be read, so i'll have to try with a "clean" CF card).

I'd like to know if the ROM0 & ROM1 back-uped files could help me with this one ? How to put them back ?

If anyone could help I'll really appreciate. I'm starting to think that I broke my camera but it seems odd to me that a little softwary thing could make the whole thing not working (including "clean" CF cards not working, plus the camera itself is clearly working, it's just a business of cards) -  but maybe I'm wrong and learning it the hard way.

Thanks.

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8254
Re: Bad CF Card manipulation - Can't boot on any bootable CF Card
« Reply #1 on: December 09, 2020, 11:47:29 PM »
First check for bent or missing pins in CF-card slot.