Author Topic: Canon 60D won't power on, no led activity  (Read 864 times)


  • Just arrived
  • *
  • Posts: 1
Canon 60D won't power on, no led activity
« on: January 12, 2020, 03:20:33 AM »
Hi, the camera has been unused for a few days and since yesterday when I tried to power it on it won't go on. Battery is fully charged and tested to be working on an 80D. ML has been installed for months now, never had an issue. If there was an error during ML usage it usually just meant reinserting the battery and the camera would continue to work like normal.

Now inserting the battery and closing the latch results in no response from the camera led. Turning the camera on shows no power on the top or back LCD and no sounds from the camera. The camera does not turn on at all.

I tried powering on without SD card, then without lens too. I tried taking out battery + lens + SD card, holding the shutter release button completely for 30 seconds, then trying to power on with a battery alone and then with a battery and lens - still nothing.

I tried pushing the battery door switch with a plastic pry tool and then turning the camera on - nothing. Did the same with SD card door - nothing again.

Just to repeat - the camera was working fine until 2 days ago and has been sitting in the camera bag since the last time it was on and working. In the meantime the only thing that has changed is that the battery has been charged.

Now, usually when ML card is installed and the SD card door is closed there is blinking. Now with the battery installed and me reinserting the SD card with ML on it - there is no blinking at all.

I tried the 4 steps from this thread:

I have also tried the "Portable display test" and "Led blink test" with no results - screen is black and there is no blicking on any led on the camera. (backed up the autoexec.bin from my ML SD card, then used the files for these tests one by one; also tried with a fresh SD card which I made bootable with EOScard and then replaced the file on that one).

So... I tried different lenses, different blank and bootable SD-cards, no sd card, different batteris (all original)... nothing. No signs of life in the camera. How could it just decide not to work like this all on it's own? Anything else I can try?


  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Canon 60D won't power on, no led activity
« Reply #1 on: January 17, 2020, 04:55:41 PM »
At software level, probably not. The camera is not powering on, most likely.

You could check the fuses and maybe also the UART pins, but other than that, I have no experience with this kind of debugging. Time to contact a service center, I'm afraid.