Author Topic: 1100D "half" unbricked  (Read 1294 times)

Lithops

  • Just arrived
  • *
  • Posts: 1
1100D "half" unbricked
« on: September 27, 2019, 09:00:17 AM »
Hi fellows!

ML crashed twice just a few days apart. After the second crash the camera just sat dead without coming to life; with card, without card, newly formatted card, with freshly charged battery, with this lense and that lense... you know, the works ;-)

Anyhow, I got it somewhat going after I deleted the ML config file and logs and rom dumps and any other that's non-essential from the card (saved them of course on computer in case for later), turned on the power and just let it be for a while. It took some time but the LED started flashing so something woke up. I let it run it's course and when it seemed to stop, turned the power off, removed the battery for a while and stuck it back in and tried again. This time it woke up a little bit faster and fumbling with the buttons I realized that pressing LiveView worked since the mirror clanked up and back down with it. After that I realized to look in the eyepiece and there sat all the info it gives from the shooting parameters. Pressed the shutter halfway and voila: lense focused. Snapped a picture and it came out fine when looked it on computer.

Problem is, the screen is now pitch black. Not even the background light comes on. And it boots only from the ML card I used prior. I mean "only" as in not even from a new formatted card. It doesn't even recognize any other cards I believe, since the LED doesn't blink when closing/opening the  battery/sd door with any other than the one with ML on it.

Otherwise all good; it boots in all dial modes (takes a little time though even with holding SET pressed during booting to try and bypass ML), takes pictures and saves them correctly to card. The only thing missing is the screen. And of course the booting with only one card issue.

The last crashlog says:

-----
ASSERT: FALSE
at Memory\Memory.c:188, task MetaCtg
lv:0 mode:0


Magic Lantern version : v2.3.NEXT.2013Sep12.1100D105
Mercurial changeset   : 87e54c7c2284 (unified) tip
Built on 2013-09-12 15:39:12 UTC by jenkins@magiclantern.fm.
Free Memory  : 304K + 201K
-----

So, where do I go from here?


a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: 1100D "half" unbricked
« Reply #1 on: September 27, 2019, 09:46:25 PM »
You could try the portable ROM dumper, but if the display hardware is damaged, it's not going to help.

If you connect an external monitor, I expect it to work that way.

The last crash is an out-of-memory error from Canon firmware while scanning the card for available pictures. This procedure is probably triggered at startup, after card contents was modified (unconfirmed hypothesis). You could check the date of the log file, to see if it was from the first crash or from the second one, but... gut feeling says it's unrelated.