Author Topic: Canon 7D - Black vertical lines on images/video/live view  (Read 2887 times)

jz729

  • New to the forum
  • *
  • Posts: 2
Canon 7D - Black vertical lines on images/video/live view
« on: August 28, 2019, 01:58:09 PM »
Hello all! My first time posting here. Sad that it had to be for this reason. I've searched around and couldn't find a solution to this exact issue. Someone mentioned having this problem in passing, but couldn't remember their solution. First off I've had my 7D Mk1 for about 10 months. I bought it used with only about 5k clicks on it. Right now the shutter count is 21k. I've been using ML on it for about 9 months with no problems whatsoever.

I was out shooting some RAW clips of wildlife in my area 2 days ago and after recording a few clips, these black vertical lines appear in live view. I decided to restart the camera, and the problem was solved. I didn't think much of it. The following day I went out to get some more raw video and discovered I had left the camera on overnight in my bag. Didn't think it would be a problem as I had it on auto power off after 2 minutes. But the battery was dead. Popped in a second battery and the dreaded black vertical lines are back, and they would not go away. These lines are evenly spaced throughout the entire image, with 7 pixels between them.

 Here is a list of things I have tried so far:
- Inserting different CF cards, one with ML another without
- Resetting ML settings
- Uninstalling ML
- Reinstalling ML
- Clearing all camera settings and custom functions
- Removing camera battery and clock battery, letting it sit overnight

None of these things have made a difference. Is there anything else I can try?
I'm not really sure where to upload these images to so I've just placed them on google drive. If there is a better place to host these images, please let me know.

This is an image taken as soon as the problem started occurring
https://drive.google.com/file/d/1ZVxmQ9Lgeb97xELYNJebMHwp2wnXIvlG/view?usp=sharing

And this is an image taken with the Silent pic mode from ML
https://drive.google.com/file/d/1veoeEeSfqaq01qVBD2W_TgAHIe9cyoJJ/view?usp=sharing


a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Canon 7D - Black vertical lines on images/video/live view
« Reply #1 on: September 01, 2019, 07:17:35 AM »
Hardware issue - one of the 8 readout channels is no longer working.

What we can do, at software level, is to interpolate these dead columns as bad pixels (easiest to do in post-processing, but also doable in the camera, to some extent). Unsure whether Canon's own bad pixel correction feature would work here (didn't try).

In any case, this workaround will introduce some aliasing (somewhat similar to Dual ISO), but at least you will be able to keep using the camera for a while. Whether that's going to be a matter of days, months, or years until it fails completely, I have no idea.

Sapporo

  • Freshman
  • **
  • Posts: 94
Re: Canon 7D - Black vertical lines on images/video/live view
« Reply #2 on: September 01, 2019, 01:45:25 PM »
Hardware issue - one of the 8 readout channels is no longer working.

What we can do, at software level, is to interpolate these dead columns as bad pixels (easiest to do in post-processing, but also doable in the camera, to some extent). Unsure whether Canon's own bad pixel correction feature would work here (didn't try).

In any case, this workaround will introduce some aliasing (somewhat similar to Dual ISO), but at least you will be able to keep using the camera for a while. Whether that's going to be a matter of days, months, or years until it fails completely, I have no idea.
Do you have more details how Canon's own bad pixel correction works? The only thing I know is the "lens cover on, manual sensor cleaning etc thingy", but nothing that explains how it works and why it doesn't always work.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Canon 7D - Black vertical lines on images/video/live view
« Reply #3 on: September 01, 2019, 01:53:34 PM »
Not much; it's a black box for me as well.

Ant123

  • Contributor
  • Member
  • *****
  • Posts: 181
Re: Canon 7D - Black vertical lines on images/video/live view
« Reply #4 on: September 01, 2019, 02:52:57 PM »
Probably there is a bad contact in cable connection between image sensor and mainboard.
(shown on picture #8 at center)

jz729

  • New to the forum
  • *
  • Posts: 2
Re: Canon 7D - Black vertical lines on images/video/live view
« Reply #5 on: September 02, 2019, 06:16:53 PM »
Thanks for the information. Can you recommend any programs or another technique to remove these bad columns in post? I don't mind the aliasing until I can get a new cam. I'll take a look at canon's own bad pixel correction in the mean time.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Canon 7D - Black vertical lines on images/video/live view
« Reply #6 on: September 27, 2019, 04:39:14 PM »
Such a program would have to be written from scratch; I'm not aware of a anything already made. As a starting point, one could use cr2hdr, which does something similar (it interpolates 2 missing lines from 4 good ones; you would need 1 column from up to 14 good ones).

kayman1021

  • New to the forum
  • *
  • Posts: 21
Re: Canon 7D - Black vertical lines on images/video/live view
« Reply #7 on: September 29, 2019, 10:29:16 PM »
I had some success with the .cr2 file. After dropping it into Adobe DNG converter, I've recieved a 16bit uncompressed .dng file.
After many tries, I've managed to open the data. Stangely the inner data width is 5360 opposed with 5202 that is reported by RawTherapee. The additional data is not black, but very dark rectangle on the left. RawTherapee somehow just crops it. Height is 3465.

I've overwritten the values with horizontal neighbour averages, and stuffed the data back into the dng. Black lines are gone, but there are visible artefacts, like above the eyes.

https://drive.google.com/file/d/1Wf6caNNeuPfo5uhd0Aak-s_PRiPGsAs5/view?usp=sharing




edits in italic
EOS 100D, Xiaomi A1

Sapporo

  • Freshman
  • **
  • Posts: 94
Re: Canon 7D - Black vertical lines on images/video/live view
« Reply #8 on: September 30, 2019, 10:08:10 AM »
I had some success with the .cr2 file. After dropping it into Adobe DNG converter, I've recieved a 16bit uncompressed .dng file.
After many tries, I've managed to open the data. Stangely the inner data width is 5360 opposed with 5202 that is reported by RawTherapee. The additional data is not black, but very dark rectangle on the left. RawTherapee somehow just crops it. Height is 3465.

I've overwritten the values with vertical neighbour averages, and stuffed the data back into the dng. Black lines are gone, but there are visible artefacts, like above the eye.

https://drive.google.com/file/d/1Wf6caNNeuPfo5uhd0Aak-s_PRiPGsAs5/view?usp=sharing
Almost gone when using VNG4 in RawTherapee.