Author Topic: vignetting in EOS 6D  (Read 223 times)

Xfoam

  • New to the forum
  • *
  • Posts: 3
vignetting in EOS 6D
« on: June 09, 2019, 10:34:54 PM »
hi, after installing ML on EOS 6D i found a very strong vignetting in video and the video centre is strongly overexposed, during making film the vignetting is visible at LCD, photos taken with ML just before or after making the film but with live view off as are OK, i'm talking about the same scene
what important when i was making video with this same lenses (Canon 28-135 f:3.5-5.6 IS) without ML, practically there were no vignetting or overexposing,

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 6700
Re: vignetting in EOS 6D
« Reply #1 on: June 11, 2019, 02:40:33 PM »
ML version info missing.
Record mode (MLV or H.264) information missing.
Resolution information missing.
Frame rate information missing.

Turn off Canon's ALO and HTP and retry.
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1463
  • 6d - Nightly build user
Re: vignetting in EOS 6D
« Reply #2 on: June 11, 2019, 04:43:13 PM »
Not sure, but my first guess would be that you have automatic lens correction enabled in Canon menu.

And as far as I know, automatic  lens correction isn’t applied on (Magic lantern) video...or ar least not on raw video.

Xfoam

  • New to the forum
  • *
  • Posts: 3
Re: vignetting in EOS 6D
« Reply #3 on: Yesterday at 04:07:10 PM »
thx, i'm doing some tries to correct the problem, switching off lenses correction in canon menu has not solved the problem, i'm trying to use vignetting menu in ML, however it looks that my knowledge about these settings is too weak, there are three positions Mid-range; Corner correction and Extreme corner correction, i'm trying to set them with no result, corners are dark, i know that i'm doing something wrong, as with automatic correction but without ML movie is ok

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 6700
Re: vignetting in EOS 6D
« Reply #4 on: Yesterday at 04:17:49 PM »
See first reply: We have no idea what you are doing. Help us to help you, please.
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12198
  • Maintenance mode
Re: vignetting in EOS 6D
« Reply #5 on: Yesterday at 05:24:20 PM »
He's trying to use the Movie->Vignetting function from ML menu, while recording H.264 video.

Troubleshooting: turn it off to get the same result as with Canon firmware.

General troubleshooting: look in the Modified settings menu (the Delta icon) and see what you have changed from ML defaults. If any of them looks related to your issue, turn it off. In your case, the Vignette option should appear there.

Usage: this option works for both vignette effects (default) or for vignette correction (lens-specific, requires fine-tuning). To correct vignette defects, point the camera to a blank wall and adjust the settings (by trial and error) until you get a flat line. If in doubt, set everything to 0 and tweak from there.

Xfoam

  • New to the forum
  • *
  • Posts: 3
Re: vignetting in EOS 6D
« Reply #6 on: Yesterday at 08:33:24 PM »
thanks all,
i'm very new in using ML, i used 50D and it has no audio so i rather did not use ML but now i have 6D and have started my adventure with ML,
anyway problem solved, probably i've found the fault, i am using ML as 'from the shelve' and i found that vignetting setting was -0.3, 0, 0, now i changed these -0.3  to 0 and set automatic lens correction in canon menu and movie looks ok, maybe a very small vignetting
I don't know why the setting in original ML was -0.3, these three numbers above are three positions in vignetting menu (mid-; corners, extremal)
maybe somebody will find my solution useful,
thanks all for assistance