Author Topic: EOS 60D does not start  (Read 2318 times)


  • New to the forum
  • *
  • Posts: 8
EOS 60D does not start
« on: March 19, 2019, 09:12:52 PM »

my EOS 60D isnt starting up. I tried with different Battery and without Card but nothing happens. Whenever I insert a card with ML the red LED is flashing (7 times a "double" flash).
I tried the diagnostic tools and the display test worked as well as the ROM dumper. The only strange thing is, that the ROM files were dumped to the root folder nad not to the ML/LOGS/...

But I can't get the camera working, no matter what I try.

Can anybody help me?

Best regards


  • Just arrived
  • *
  • Posts: 1
Re: EOS 60D does not start
« Reply #1 on: March 24, 2019, 10:38:38 PM »
Is something showing up on camera's screen? If not, then the issue might be the battery door. Look and make sure that the contacts are intact and that there are no signs of corrosion. Cheers.
Like a drum baby don't stop beating. I'll love you long after you're gone, gone, gone! Can't you see it's we who own the night? It's now time for us to party. It's our party we can do what we want. It's our party we can say...

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8611
Re: EOS 60D does not start
« Reply #2 on: March 24, 2019, 11:18:19 PM »
Portable display test is working and therefore battery door is working properly. See his other message in Camera Emergency Department: