[Not really an emergency]: EOS M2 fast blinking green LED at startup

Started by Walter Schulz, April 10, 2021, 04:46:11 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Walter Schulz

Purchased an M2 marked as defunct and it came as defunct! Surprise!

Press ON/OFF and after very short time green LED begins to blink fast. And doesn't stop (tested for several minutes). Pressing ON/OFF again will stop it.
Pressing Play button at startup does *not* startup camera. But opening battery compartment, pressing Play (and keeping it pressed) and closing compartment door will startup cam with blinking LED. Can be shutdown by pressing ON/OFF, too.
If procedure is repeated without battery pull cam will not startup.

I tried with/without card. I tried cards prepared for ML. With/without Portable Display Test autoexec.bin and with cards prepared for other cam types. No reaction so I assume cam's bootflag is not set.

I suppose there may be a slight chance to get some diagnostics by accessing cam's UART and that's all I can do. Right?


M50.110 [main cam] | G7X III [pocket cam] | 70D.112 [gathers dust] | M.202 [gathers dust] | waiting for M5II

Walter Schulz

Got mail from connector distributor: Delivery estimated in 3 weeks.
Web site says 10 weeks.

I have an micro-SD adapter able to provoke the same LED blinking with my EOS M. If inserted into 650D cam will just not start.
This adapter once got some rubber/leather glue attached to contact pads and hasn't got a proper cleaning.

Could it be? Just a mere contact problem? Sounds too easy!
... and probably is. Error exists without card inserted ... sigh!


Hello Walter,
did you have any updates about your EOS M2 ?
I actually have the same issue. It happend after the camera was dropped on the floor more than a year ago...
I was hoping to make the camera work again.

Dou you still have a functionnal ML build for the EOS M2 ?


I have a M10, which was permanently blinking at startup. The reason was a stuck shutter blade.