Author Topic: Danne's crop_rec_4k, 5DIII  (Read 128083 times)

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7188
Re: Danne's crop_rec_4k & ISO experiments
« Reply #875 on: February 07, 2021, 03:54:09 PM »
I had a look around yesterday in mlv_lite.c but it's not obvious what to look for when it comes to audio. There are some notes how audio starts. Since it seems related to card spanning I guess something will go wrong after a few takes sometimes so I would start by testing stuff in mlv_lite.c. Feel free todo so. Also ask Ilia3101 since he ported card spanning. He might have a clue.

AlanSmithee

  • New to the forum
  • *
  • Posts: 12
Re: Danne's crop_rec_4k & ISO experiments
« Reply #876 on: February 10, 2021, 01:54:36 PM »
Hi there,

(there's a slight chance that I am asking something that has been answered before, but sometimes I gets confusing when reading though years of conversation on the forum, and then to work out what has been updated and what hasn't. my apologies in advance)

Here's what I want to do:

1. shoot RAW video, with reliable and stable (enough) settings (therefore HD for me)
2. use LiveView for focusing (and check composition etc)
3. check the video after recording to see if the footage is useable

I am using ML version "crop_rec_4k_mlv_snd_isogain_1x3_presets_2021Feb07.5D3123" - 5d mk iii (installed on CF card atm, since i thought i would use the SD card for recording mainly)
I have a highspeed SanDisk Extreme Pro 256gb 170mb/s, and a SanDisk Extreme 60Mb/s CF card (several sizes)
I use the SD overclocking module

To keep the video recording stable and reliable, I am sticking to HD (FF or 1:1). To check the video after shooting, I would like to use the proxy h.264 video, instead of the slow MLV player.

And here's where I am having problems:

- As soon as I add the proxy h.264 setting, the videos (both, the proxy and the MLV) are largely overexposed. (jumping to 12800 or 6400 ISO, for whatever reason)
Exposure is fine, as soon as I switch off the proxy again.
this happens in all modes other than manual mode (AV,TV), no matter whether sound on or off, or 14bit or 12bit uncompressed

Does Proxy only work reliably in Manual mode?

- As soon as i add the proxy h.264 option, the MLV file will be recorded onto the CF card, despite the SD card being my preferred card selection. is there any way I could do this the other way round? MLV to SD card, .mov file to CF card? (main reason for this is I have more space and the faster card in SD). However, I might be mistaken about the write speed of my CF cards. maybe 60mb/s is perfectly fine?

Also, my battery seems to be drained relatively fast (from 100% to 90% in around 5-10 minutes). Is that related to ML?

thanks, ;-)

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7188
Re: Danne's crop_rec_4k & ISO experiments
« Reply #877 on: February 11, 2021, 03:58:03 AM »
Raw video is working in manual mode so I guess both mov and mlv will get affected as described if using auto modes. I didn't test this very much.

Recording hd on sd card maybe will work with sd overclock enabled but cf will probably be more reliable. Speed on sd will probably not be faster than around 55mb/s write speed. SD overclocking is highly experimental and not very reliable. i wouldn't build my card set up around sd cards if I wanted reliability.

Recording proxy on cf card is probably possible by rewriting code routines in mlv_lite.c so you can take a look in there if important.

AlanSmithee

  • New to the forum
  • *
  • Posts: 12
Re: Danne's crop_rec_4k & ISO experiments
« Reply #878 on: February 11, 2021, 10:08:23 AM »
Perfect, thanks for the clarification.
Using manual mode should be perfectly fine.

Good to know about the SD card, I will switch back to CF for main recording. (So far, in my little amount of testing, I have had very stable results with SD overclock, but after hours of filming it might be a different story ;-) )

Oh, there's one other thing that sometimes gets mentioned on the forum, but doesn't have very up-to-date information:
the use of an external camera monitor with ML.

I will buy myself external monitor (HDMI), but I have no knowledge about where the feed for the monitor comes from.
Will it cause additional 'workload' on the camera and have a negative impact on the raw recording? (Once I have the monitor, I will share my experiences, obviously)


[edit: I used a monitor and it works fine. no crazy latency nor unstable video recording]

civica

  • Just arrived
  • *
  • Posts: 1
Re: Danne's crop_rec_4k & ISO experiments
« Reply #879 on: February 12, 2021, 12:20:48 AM »
Hi!
I'm very new to this forum. I tried searching around but I didn't understand all of it.

I want to record 1080p 25fps without using also the sd card. What's the best stable preset to do it? Is it with Dual ISO?

Thanks a lot for the work Danne

saf34

  • New to the forum
  • *
  • Posts: 17
Re: Danne's crop_rec_4k & ISO experiments
« Reply #880 on: February 17, 2021, 11:11:45 PM »
Hi guys, just been reading through this topic for the first time after a long time on the stable branch.  Just a quick sanity-check for me I wanted to throw in re. monitoring (pprompted by @AlanSmithee's comment above).

In anamorphic mode, my HMDI out (on 1.2.3) is giving the unsqueezed live feed.  So this means with an external monitor with anamorphic desqueeze we can film RAW *and* monitor with a fully functional preview (i.e. not the black and white one shown on liveview)? 

wib

  • Member
  • ***
  • Posts: 114
Re: Danne's crop_rec_4k & ISO experiments
« Reply #881 on: February 18, 2021, 12:54:36 AM »
yeah but the hdmi is heavily cropped in 5k mod so you’re end up with a very narrow and horizontal field of view.
EOS 5D3 123 crop_rec_4k_mlv_snd_isogain_1x3_presets_2020Dec11.5D3123

saf34

  • New to the forum
  • *
  • Posts: 17
Re: Danne's crop_rec_4k & ISO experiments
« Reply #882 on: February 18, 2021, 01:07:00 AM »
Agh, yup, was too easy to be true... thanks.   Just thinking out loud: it's kind of useful as a 'magic focus'... almost... as it's not centered.  I'm not there yet with how the code works: is this the nature of the stream or could I tweak something to center it?

AllWashedOut

  • New to the forum
  • *
  • Posts: 3
Re: Danne's crop_rec_4k & ISO experiments
« Reply #883 on: March 02, 2021, 07:56:21 PM »
My experience with SD overclocking below. I am using a Sandisk Extreme 128gb Micro SD (XC I, V30, U3, A2) in an SD adapter sleeve and measured using the benchmark module in 1gb mode.

Original write speed: 21mbps
Original read speed: 21mbps

Overlocked write speed: 66mbps
Overclocked read speed: 72mbps

So the speed increase is very significant.

Unfortunately, it's not stable enough. When taking raw photos, I get an error beep maybe 1 out of 20 shots and have to toggle the power switch. That photo comes out corrupted, usually with half the image missing.

I notice that 160mhz is the only overlock option. Any possibility of lower options or is that a hardware impossibility?

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7188
Re: Danne's crop_rec_4k & ISO experiments
« Reply #884 on: March 02, 2021, 10:50:10 PM »
There are preferred cards proven more stable than others.

wib

  • Member
  • ***
  • Posts: 114
Re: Danne's crop_rec_4k & ISO experiments
« Reply #885 on: March 03, 2021, 01:31:16 AM »
not the best. better to stick to cf or a good sd, but not a micro sd in a sd adaptator
EOS 5D3 123 crop_rec_4k_mlv_snd_isogain_1x3_presets_2020Dec11.5D3123

evgennish

  • Just arrived
  • *
  • Posts: 1
Re: Danne's crop_rec_4k & ISO experiments
« Reply #886 on: March 03, 2021, 04:35:42 AM »
Hello!
Thank you Danne and all team who are still work with this build! Its something amazing!

My camera Canon 5d mark 3 and Canon 24-70 2.8 II, firmware 1.2.3, crop_rec_4k_mlv_snd_isogain_1x3_presets_2021Feb07.5D3123
I watch this topic a lot of time, can tell something and want to ask few questions

first, ability to connect with gimbals:
Ronin S
- Works well, start/stop rec gimbal button, focus and etc. in anamorphic 14bit lossless continuous

connection with gimbal MCC-microUSB(+adapter microUSB(female)-MiniUSB(male))

Way to connect:
1. Turn off camera
2. Connect camera and gimbal
3. Switch Camera to Photo Mode (the most important thing)
4. Turn on Gimbal
5. Turn on camera
6. Wait for SD patching (if you use this patch)
7. Switch to video
8. Continuous recording

Ronin SC2 or RSC2 or RSC 2
Connection is different and works not so good, connection with gimbal usbC-miniUSB
in anamorphic 14bit lossless, focus work, camera won't recording video, and go in error, needs restart (log on a screen)
in anamorphic 10bit uncompressed camera start/stop rec with gimbal button, focus work well, record 15-30 second and stop (this is the one way i found it work for the short takes)

Settings
- Preset anamorphic - 2.35:1 - 1808x2300px
- Movie tab bitdepth - OFF
- Raw video - Data Format - 10-bit
- Raw video - Kill grobal Draw - ON
- Raw video - Card Spinning - ON
It is doesn't matter how to turn on or turn off camera and in which mode(photo/video)

Maybe someone know how to start recording with RS2 or RSC2 continuous?
in 14bit lossless and connected to gimbal it has error using on camera rec button or gimbal rec

And one more question to Danne, Is it technically possible to simulate frame in LiveView not stretched? i try different settings it ML menu Display tab - Anamorphic, but it is not so good and not usable

Anyway thank you for the best life for this camera!

ChristianEOS

  • Freshman
  • **
  • Posts: 64
  • I love a meerkat Erdmännchen
Re: Danne's crop_rec_4k & ISO experiments
« Reply #887 on: March 03, 2021, 03:42:42 PM »
On Sunday I'm filming a music video. I hope I'm hitting the topic correct. Does anybody advice SD card spanning. I've got the best CF cards SanDisk Pro but sadly only 64GB so maybe I thought I would save changing the CF card All the time?
Christian Bruno James

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7188
Re: Danne's crop_rec_4k & ISO experiments
« Reply #888 on: March 03, 2021, 03:53:40 PM »
If not using sd uhs patching even very slow cards will do.
Card spanning not working with higher frame rate presets.

ChristianEOS

  • Freshman
  • **
  • Posts: 64
  • I love a meerkat Erdmännchen
Re: Danne's crop_rec_4k & ISO experiments
« Reply #889 on: March 03, 2021, 07:09:09 PM »

I prepared with turning off magic lantern overlays. I basically press the info button once and record in 5.7 k 24fps so you would see anamorphic distortion therefore if somebody else has the camera. Because I've got two 5d3s. So they can approximately see what is Sharp (with slightly sharper). I have got a good CF card and the SD ScanDisk extreme pro 95mbs and 170mb s. Would that work with card spanning wouldn't even use faster U HS. Just that I don't have to change the CF card the whole time?
I don't get paid for this but the last video was seen by over 30000 people. I tried to upload exactly the biggest file to YouTube but in with 5.7 k I only got 2k on YouTube. Then I tried with full resolution in 16 by 9 worked 4k. Would it be possible somehow upscaling it to 8k on YouTube? I remember when I had my first DV camcorder it made a difference if I uploaded in 720p there was a difference to 480p even though it was the same camera. Thx
Christian Bruno James

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7188
Re: Danne's crop_rec_4k & ISO experiments
« Reply #890 on: March 03, 2021, 07:21:53 PM »
Better if you test thoroughly on your own if you are testing bleeding edge features such as sd uhs, card spanning. If going for safety exclude card spanning or at least the sd uhs patch.

ChristianEOS

  • Freshman
  • **
  • Posts: 64
  • I love a meerkat Erdmännchen
Re: Danne's crop_rec_4k & ISO experiments
« Reply #891 on: March 03, 2021, 07:44:06 PM »
I tested 5.7k with card spanning. Global draw off. 14bit lossless.
That worked.

Just the view with any magic lantern (global draw) doesn't work. After 2 minutes stopped. Without it worked until 64gb full.
My only question is does it work more stable without card spanning? I thought there is only a difference with sd uhs 160 modul on. It worked otherwise flawlessly. What about the 8k on YouTube? For the fast editing I use Sony Vegas 17 and that has no rendering option in 8k. My colour correction with Adobe After Effects and exported in *. mov 422 in exactly the same resolution as I recorded it with magic lantern (5.7k). :) looks expensive/sharp.

 Am I am doing anything stupidly wrong?
Christian Bruno James

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7188
Re: Danne's crop_rec_4k & ISO experiments
« Reply #892 on: March 04, 2021, 08:26:15 AM »
A lot of set ups lacks data. Different presets might work better than others. If you do a 5.7k film shoot with card spanning enabled and it's stable it's good info to have.

ChristianEOS

  • Freshman
  • **
  • Posts: 64
  • I love a meerkat Erdmännchen
Re: Danne's crop_rec_4k & ISO experiments
« Reply #893 on: March 04, 2021, 03:31:33 PM »
Sry, Danne I also lack sometimes on my concentration ;) the imagine in 5.7k is  incredible full of detail. You must know how the sensor renders a frame. Even if you then on YouTube watch it in full HD. A complete new impression of the picture. But I guess teenagers want to film also in slow motion. So I will have to choose the 60 FPS. I hope nobody will notice?
 Maybe the most people have no 5K Monitor.
 I also tested 38 FPS with Sharpness 1. 60fps sharpness 0. Surprisingly with other magic lantern builds. I had to put the sharpness completely down and it looked much more unsharp. Anamorphic 2:39:1 FPS 60 looks quite similar to a normal sharpness without aliasing and miore. I think no magic lantern build works better. You should get something that :) thx 1000x
Christian Bruno James

Bender@arsch

  • Member
  • ***
  • Posts: 101
Re: Danne's crop_rec_4k & ISO experiments
« Reply #894 on: March 04, 2021, 04:53:23 PM »
Quote
What about the 8k on YouTube?
Why you want upscale this? In my tests I upload a 5.7K video and I can set to 5K in the web browser and if I click right click on statistics, you can read this is 5.7K ;)
In my opinion there is no reason for upscale a 5.7K Anamorphic image.

The only reason is with footage less than 4K, but not for quality of the footage, just only for Youtube - > YouTube HD quality is really bad.

wib

  • Member
  • ***
  • Posts: 114
Re: Danne's crop_rec_4k & ISO experiments
« Reply #895 on: March 05, 2021, 05:03:33 PM »
The only reason is with footage less than 4K, but not for quality of the footage, just only for Youtube - > YouTube HD quality is really bad.

Agreed !
EOS 5D3 123 crop_rec_4k_mlv_snd_isogain_1x3_presets_2020Dec11.5D3123

ChristianEOS

  • Freshman
  • **
  • Posts: 64
  • I love a meerkat Erdmännchen
Re: Danne's crop_rec_4k & ISO experiments
« Reply #896 on: March 05, 2021, 11:32:04 PM »
What about you watch videos on YouTube in 4K would you see the difference with magic lantern 5.7 k and 60 FPS 1080? I'm sure you wouldn't be able to see miore or aliasing.


 I filmed this with the 5D 2 and 30 FPS used twixtor. I just wonder filming  in 5.7k would it be worth the less FPS? The only deficit with the 5D III is no slow emotion. I bought a DOF adaptor for the Samsung Galaxy S10 that even records with 240fps. Mathieu Stern said, it wouldn't be good result for vintage lenses. What would be the cheapest slow emotion ?
Christian Bruno James

caylemweeks

  • Just arrived
  • *
  • Posts: 1
Re: Danne's crop_rec_4k & ISO experiments
« Reply #897 on: March 10, 2021, 12:32:36 PM »
Hey guys,

Just installed this build to my Canon 5D Mk 3 and it's working pretty well. I'm using the dual shooting mode with my SD and CF card and can do continuous 3.3K RAW in 10 bit, which is awesome.
HOWEVER.
In every single one of my clips, there is this weird pink aliasing (for want of a better word) on the highlights. Literally every single clip I record that is the slightest overexposed, the pink lines appears.
Even on text on a screen, it appears.
I've trolled through the forums and looked at countless posts, but to no avail. I'm using the latest 2021 Feb build, so I'm not out of date. I've got Global Draw turned off as well.
I haven't enabled any dual iso stuff, or anything to do with any custom overlays.
Help me Obi-Wan MagicLanternForums-obi, you're my only hope!

EDIT:
I've been using the EV function and have been exposing by about +1 EV to get proper exposure in the RAW files. Pink areas everywhere.

jzzzyang

  • New to the forum
  • *
  • Posts: 6
Re: Danne's crop_rec_4k & ISO experiments
« Reply #898 on: March 13, 2021, 04:29:02 AM »
Hi,caylemweeks
MLVApp-profiles-cyan highlight fix
Try this option.

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 1859
Re: Danne's crop_rec_4k & ISO experiments
« Reply #899 on: March 13, 2021, 10:04:28 AM »
@caylemweeks: sounds like you clipped the green channels. Try highlight reconstruction in parallel to RAW white level adjustments in MLVApp. In Resolve there is also a highlight reconstruction feature.
And for the future: use zebras and ETTR in camera and try to not overexpose!
5D3.113 | EOSM.202