Author Topic: Danne's crop_rec_4k & ISO experiments  (Read 98503 times)

ChristianEOS

  • Freshman
  • **
  • Posts: 61
  • I love a meerkat Erdmännchen
Re: Danne's crop_rec_4k & ISO experiments
« Reply #850 on: February 01, 2021, 07:48:13 PM »
Danne very funny ;) grey pictures also are for free:)
It is actually a stable version I think that somehow also with versions before I change sd160. When I start the camera new the whole magical Lantern reset it. That only happens with sd160 sometimes I write mlv files from CF to SD that works a little more stable without the sd160 if you know what I mean?
Christian Bruno James

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7137
Re: Danne's crop_rec_4k & ISO experiments
« Reply #851 on: February 01, 2021, 08:36:20 PM »
Yes. Sd_uhd itself can cause instabilities. It's questionable if it should be used or not but some cases showed to work. As long as you know this it can stay included in the build.

ChristianEOS

  • Freshman
  • **
  • Posts: 61
  • I love a meerkat Erdmännchen
Re: Danne's crop_rec_4k & ISO experiments
« Reply #852 on: February 03, 2021, 01:32:28 PM »
Thinking about how a public/ stable version might look like? I think the 5. 7 k is a cinematic difference. Since Zeek makes quiet an often seen impression of SD uhs 160 that would be also available?
Christian Bruno James

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7137
Re: Danne's crop_rec_4k & ISO experiments
« Reply #853 on: February 03, 2021, 01:46:16 PM »
Not sure if I follow you entirely here. Owning both an eos m and a 5DIII I don´t see much need of use of patching or even recording onto a sd card on the 5DIII. If you want more stable recording don´t enable sd uhs at all. On the eos m on the other hand, patching is needed imo.

ewinemiller

  • New to the forum
  • *
  • Posts: 45
Re: Danne's crop_rec_4k & ISO experiments
« Reply #854 on: February 04, 2021, 04:06:07 PM »
Lately I've been shooting in the 3.5k 1:1 centered x5 mode at 3456x1728 10bit. It's continuous with card spanning and SD overclock, but only a few seconds without either. There are certainly plenty of good modes without spanning or overclock, but it does open more options.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7137
Re: Danne's crop_rec_4k & ISO experiments
« Reply #855 on: February 04, 2021, 04:17:42 PM »
Good to know. Thanks for feedback.

rinski

  • New to the forum
  • *
  • Posts: 44
Re: Danne's crop_rec_4k & ISO experiments
« Reply #856 on: February 04, 2021, 07:58:35 PM »
Hello, could you explain what the parameters are, for the x5 mode centered 1: 1 from 3.5k to 3456x1728 10bit, I can't use it. Thank you.

ChristianEOS

  • Freshman
  • **
  • Posts: 61
  • I love a meerkat Erdmännchen
Re: Danne's crop_rec_4k & ISO experiments
« Reply #857 on: February 04, 2021, 08:06:04 PM »
"Not sure if I follow you entirely here. Owning both an eos m and a 5DIII I don´t see much need of use..." (me also)
Of course it isn't necessary. Recording in 60p you still can push it more to the limits. I will do as you wrote. I didn't want to disturb.
Christian Bruno James

wib

  • Member
  • ***
  • Posts: 103
Re: Danne's crop_rec_4k & ISO experiments
« Reply #858 on: February 05, 2021, 12:45:02 PM »
 I would like to add to this that sometimes there are mlv recorded in 3.5 with card spanning that end up without audio track. I don't know if it's related to card spanning or to sd_uhs with card spanning...
EOS 5D3 123 crop_rec_4k_mlv_snd_isogain_1x3_presets_2020Dec11.5D3123

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7137
Re: Danne's crop_rec_4k & ISO experiments
« Reply #859 on: February 05, 2021, 01:29:51 PM »
Could you upload one recording with missing audio? There are more than one way to develop footage that could solve this. Most likely audio is still there.

ewinemiller

  • New to the forum
  • *
  • Posts: 45
Re: Danne's crop_rec_4k & ISO experiments
« Reply #860 on: February 05, 2021, 02:06:57 PM »
Hello, could you explain what the parameters are, for the x5 mode centered 1: 1 from 3.5k to 3456x1728 10bit, I can't use it. Thank you.

I'm using a slightly tweaked build of Danne's work with just a few extra Ratio presets in the Movie menu, but the settings below should get you there with his build.

Presets  3.5k  1:1 centered x5
RAW Video
     Resolution  3456x1728
     Aspect ratio 2:1
     Data format 14-bit lossless
     Preview Framing
     Crop rec preview auto mode
     Card spanning on
Bit Depth 10 bit
Ratio Off
SD overclock 160mhz

and most importantly, you have to have the right SD card. After seeing success with other folks I got one of these and no problems. It's got to be the 170mb/s. I have one of the 95mb/s ones and no luck with it. Haven't seen the lost sound issue.

https://smile.amazon.com/gp/product/B07H9VX76D/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

Any fast writing compact flash seems fine. I use a variety of Komputer Bay 1000x or better cards.

Bender@arsch

  • Freshman
  • **
  • Posts: 98
Re: Danne's crop_rec_4k & ISO experiments
« Reply #861 on: February 05, 2021, 03:01:44 PM »
Could you upload one recording with missing audio? There are more than one way to develop footage that could solve this. Most likely audio is still there.

I have this problem sometimes too, here is an shortend example:

https://drive.google.com/folderview?id=1pLemHSb2UynLEkaIJuNA7eIHmKYzDrDJ

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7137
Re: Danne's crop_rec_4k & ISO experiments
« Reply #862 on: February 05, 2021, 03:54:37 PM »
No shortened file please. Obviously would affect audio length if shortened. This check needs complete files.

Bender@arsch

  • Freshman
  • **
  • Posts: 98
Re: Danne's crop_rec_4k & ISO experiments
« Reply #863 on: February 05, 2021, 04:06:08 PM »
OK, in 8min there is a 600mb clip online. Same Link

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7137
Re: Danne's crop_rec_4k & ISO experiments
« Reply #864 on: February 05, 2021, 05:01:06 PM »
Checking metadata:
Code: [Select]
File Header (MLVI)
    Size        : 0x00000034
    Ver         : v2.0
    GUID        : 17047428700475394385
    FPS         : 23.976000
    File        : 0 / 0
    Frames Video: 132
    Frames Audio: 0
    Class Video : 0x00000021
    Class Audio : 0x00000001

Frames Audio: 0 so I guess something would not allow wav file to be recorded. Is this reproducable? Only happening in 3.5k mode?

rinski

  • New to the forum
  • *
  • Posts: 44
Re: Danne's crop_rec_4k & ISO experiments
« Reply #865 on: February 05, 2021, 05:49:44 PM »
Algo 5k anamorphic eos m 7 minutes, Full anamorphic 5d3 19 minutes. Thanks you

wib

  • Member
  • ***
  • Posts: 103
Re: Danne's crop_rec_4k & ISO experiments
« Reply #866 on: February 05, 2021, 06:49:22 PM »
reproductible yes.

here is 3 records attempt (the link is 2Go; is it ok for your connection ?) https://we.tl/t-Cogz5FvXHN

  • 1st clip : there is sound.
  • 2nd : no sound. I checked also with mlrawviewer, the wav generated is empty.
  • 3rd clip : there is sound


The settings :

Presets  3.5k  1:1 centered x5
RAW Video
     Resolution  3584x1630
     Aspect ratio 2:20
     Data format 14-bit lossless
     Preview Framing
     Crop rec preview auto mode
     Kill Global Draw ON
     Card spanning on
Bit Depth 10 bit
Ratio Off
SD overclock 160mhz
EOS 5D3 123 crop_rec_4k_mlv_snd_isogain_1x3_presets_2020Dec11.5D3123

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7137
Re: Danne's crop_rec_4k & ISO experiments
« Reply #867 on: February 05, 2021, 07:17:15 PM »
Thanks. And what about when disabling card spanning? Try to find a way that is working maybe? Or do you know that it is card spanning?

Bender@arsch

  • Freshman
  • **
  • Posts: 98
Re: Danne's crop_rec_4k & ISO experiments
« Reply #868 on: February 06, 2021, 12:39:57 PM »
Checking metadata:
Code: [Select]
File Header (MLVI)
    Size        : 0x00000034
    Ver         : v2.0
    GUID        : 17047428700475394385
    FPS         : 23.976000
    File        : 0 / 0
    Frames Video: 132
    Frames Audio: 0
    Class Video : 0x00000021
    Class Audio : 0x00000001

Frames Audio: 0 so I guess something would not allow wav file to be recorded. Is this reproducable? Only happening in 3.5k mode?

Not really. In my Files i have no audio in 0% up to 33% of shoot sessions. And this is not only in 3.5K, in UHD 1x1 and 3.3K (16:9) is the same problem, but not so often i think. I delet some older clips, so i can't see older tests with Anamorphic. But in all records i use cardspanning + sd overclocking.
I think i need some systematic tests (camera on, record and stop, changing bitdepth, record and stop, changing bitdepth, refresh liveview, record and stop, focusing, record and stop, 10x zoom, record and stop and so...)

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7137
Re: Danne's crop_rec_4k & ISO experiments
« Reply #869 on: February 06, 2021, 01:21:17 PM »
Oki. From what you describe it seems related to card spanning. If possible do more tests without card spanning.

IDA_ML

  • Hero Member
  • *****
  • Posts: 911
Re: Danne's crop_rec_4k & ISO experiments
« Reply #870 on: February 06, 2021, 05:23:43 PM »
I would like to report a very strange behavior of the 5D3 with the latest Jan. 30-th 2021 build.  When I turn all presets off to default to the normal 1920x1080/24 fps mode, when I change the bit depth from 14 (off) to 12, 10, 9 and 8, the preview looks perfectly equal at all bit depths but with every bit depth reduction by one step in the above sequence, the recorded footage gets overexposed by one stop compared to the previous one.  I noticed that after filming at 12 bit and then decided to go down to 10 bit.  The 10-bit footage was overexposed by one stop compared to the 12 bit one, with all other settings unchanged.  This also happens with the anamorphic modes.

I have shot a bit depth sequence that illustrates this.  Here are single MLV frames from each clip:

https://we.tl/t-MfE2qkSiAQ

Is this normal?

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7137
Re: Danne's crop_rec_4k & ISO experiments
« Reply #871 on: February 06, 2021, 05:38:39 PM »
Use the bitdepth menu from raw video if you turn off crop rec. Set it to OFF in Movie tab.

Edit: You can also correct those files with white level slider in Mlv App.

IDA_ML

  • Hero Member
  • *****
  • Posts: 911
Re: Danne's crop_rec_4k & ISO experiments
« Reply #872 on: February 06, 2021, 09:13:13 PM »
Yes, correcting the white level of these strange (overexposed) looking files works quite well in MLVApp but this requires manual adjustment of every clip separately.  Moreover, if you try to do that in Resolve with MLVFS, fixing white level is almost impossible.  Why can't the correct white level at each bit depth be hard coded in the camera as this used to be in older builds?

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7137
Re: Danne's crop_rec_4k & ISO experiments
« Reply #873 on: February 06, 2021, 09:53:28 PM »
What build exactly?
Learning compiling and essential code will answer most questions and help me and others from drowning in repeatable questions.
I have very little time to refine stuff. Help needed.

IDA_ML

  • Hero Member
  • *****
  • Posts: 911
Re: Danne's crop_rec_4k & ISO experiments
« Reply #874 on: February 06, 2021, 10:53:08 PM »
Sorry for asking.  Thanks.