Author Topic: Danne's crop_rec_4k & ISO experiments  (Read 63161 times)

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6959
Re: Danne's crop_rec_4k & ISO experiments
« Reply #550 on: August 08, 2020, 10:15:23 PM »
Ok, cool. I'll have a look. Maybe tomorrow.

Volumetrik

  • New to the forum
  • *
  • Posts: 40
Re: Danne's crop_rec_4k & ISO experiments
« Reply #551 on: August 08, 2020, 11:42:15 PM »
I see that there's a lot going on here with the writespeed calculations.

You also asked what happens when I try to use SD overclocking. I am using a 95mbps Sandisk Extreme Pro 32gb SDHC card. I have a 128gb 170 coming in the mail on Monday.


I have that same card (32Gb SDHC 95MB/s). It's around 6 years old and I have the same issue. My 64Gb SDXC 170MB/s gives me no problems.

So it would seem that the SanDisk Extreme Pro SDXC 170MB/s cards work great with the SD_UHS patch, but not the SDHC (32gb or less) counterparts.

I just came back from shootings some clips and I was using 3520x1320 14-Bit lossless and 1920x2340 (5.7k) 14-Bit lossless all continuous with green seconds counter. The preview was going from black & white to color depending on the complexity of the scene. I was using ETTR methods where when I saw raw (green) zebras, I backed out 1/3 of a stop and then recorded.

I'm on the Jul15 firmware 1.1.3.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6959
Re: Danne's crop_rec_4k & ISO experiments
« Reply #552 on: August 09, 2020, 12:14:10 AM »
Seems like the 170Mb/s cards above 32gb are holding up best so far. If anyone is willing to test with a sandisk 300Mb/s card please let me know. I want to do a short test with 240Mhz setting enabled. All tests with 170Mb/s cards are indicating "almost' working but always fails after talking a photo or enabling raw video modes. Maybe the 300Mb/s card is what will work.

has_abandonment_issu

  • New to the forum
  • *
  • Posts: 28
Re: Danne's crop_rec_4k & ISO experiments
« Reply #553 on: August 09, 2020, 12:19:44 AM »
Thanks Volumetrik I am pretty excited to get a 128gb and test it out. I'll update when it arrives.


Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6959
Re: Danne's crop_rec_4k & ISO experiments
« Reply #555 on: August 09, 2020, 02:14:01 PM »
Here is a version with all three registers included, 160/192/240 Mhz:
https://bitbucket.org/Dannephoto/magic-lantern_dannephoto_git/downloads/sd_uhs.mo

Above version will work with my latest builds from july 15th.

No reason to use this module more than for brief testing. With brief tests I mean enable bench.mo and run the 1 minute benchmark test. Test scenario.
 
With only the SD card in the camera. No CF card inserted in camera that is! Do following:

1 - Select for instance sd overclock 240Mhz, restart camera in photo mode.
2 - Run benchmark test and check the numbers. If working the first time numbers should be around 105Mb/s read speed and I think around 90 write speed.
3 - After running benchmark test take a photo then run the benchmark tests again. Usually write speed works like before but read speed will take off to around 5000Mb/s. Once that happens you might as well turn off the camera and consider the 240Mb/s patch not working.

If you for some reason don´t want to run benchmark routines above, a simple useful test would be to simply apply the patch, then enable a movie preset and start recording. Do multiple recordings to see If it works without early stops.

Do not format card in camera with sd patch applied. If formatting see to it that sd uhs patch is set to OFF.

What cards havn´t been tested? Well. 32gb sandisk 95mb/s seems not to work with 160Mhz. Will it work with 240Mhz?
We still havn´t tested the 300mb/s sandisk cards either 32gb or above. Mainly tests should be if you have any of these cards.
Don´t hesitate to ask questions and be careful. There are risks:
https://www.magiclantern.fm/forum/index.php?topic=25210.msg229534#msg229534
 

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 7607
Re: Danne's crop_rec_4k & ISO experiments
« Reply #556 on: August 09, 2020, 02:17:32 PM »
Would be a first here: UHS-II card in overclocked UHS-I compatibility mode.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6959
Re: Danne's crop_rec_4k & ISO experiments
« Reply #557 on: August 09, 2020, 02:21:18 PM »
Would be a first here: UHS-II card in overclocked UHS-I compatibility mode.
You´,ve been successful? But not on a 5DIII right? What card exactly?

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 7607
Re: Danne's crop_rec_4k & ISO experiments
« Reply #558 on: August 09, 2020, 02:32:43 PM »
No, just wanted to express it would be a first here = ML community. Don't know if SD overclocking with UHS-II in UHS-I mode was ever tested somewhere else.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6959
Re: Danne's crop_rec_4k & ISO experiments
« Reply #559 on: August 09, 2020, 02:42:36 PM »
Yes, aware of this. Probably not gonna work but might be a slight possibility.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6959
Re: Danne's crop_rec_4k & ISO experiments
« Reply #560 on: August 09, 2020, 08:06:05 PM »
I set kill global draw and I tested as well with standard settings. I change ratio because of the error, so no difference. I tested 2.39:1 at 10bit - at the last resolution (2848) it works, but with 3072 not. The same without SD overclocking and the same without audio and the same without fine tuning. This all is only happens in 3K mode with Cardspanning.
I can´t reproduce this issue. Recorded longer taes with sd overclock on 24 fps 3072 resolution 10bit. Works ok here.

Bender@arsch

  • Freshman
  • **
  • Posts: 79
Re: Danne's crop_rec_4k & ISO experiments
« Reply #561 on: August 09, 2020, 09:23:44 PM »
Interestingly.
How long you have recorded? Mostly it happenes in the first 45sec. Sometimes it is depending on what you film (how fast it happens).

I used a SanDisk Extreme Pro 170MB/s 128GB and a Komputerbay Prof. 128GB 1066x.

GullRaDriel

  • New to the forum
  • *
  • Posts: 41
Re: Danne's crop_rec_4k & ISO experiments
« Reply #562 on: August 09, 2020, 11:19:19 PM »
I'm currently testing with a Lexar Professional SD3XCII 10 128GB x1000 with a theoric write speed of 150MB/s . When I'll test I'll also do it with the CF, it will be a Lexar Pro UDMA7 1066x with a theoric write speed of 160MB/s.

Wait and see.

Edited: fixed wrong assumption

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 7607
Re: Danne's crop_rec_4k & ISO experiments
« Reply #563 on: August 09, 2020, 11:32:57 PM »
Not sure which card you are using. Lexar lists a "Lexar Professional 1000x SDHC/SDCX UHS-II" card with 150 MByte/s labeled but for read speed only. Cameramemoryspeed tested the 128 GB variety and it had a maximum speed (without overclocking) below 96 MByte/s.
There are at least two varieties of Lexar 1066x. One with premium write speeds (quite close to theoretical write performance) and another one not that fast.
I strongly recommend testing them with a decent cardreader.

GullRaDriel

  • New to the forum
  • *
  • Posts: 41
Re: Danne's crop_rec_4k & ISO experiments
« Reply #564 on: August 09, 2020, 11:53:41 PM »
Well. The numbers seem to give you a point: reading speed is increasing way more than writing.

Here are the results, as following: mode,1st Write/1st Read/2ndWrite/2ndSpeed

sd module off: 20.5 / 21.8   / 18.8 / 21.8
160 MHz:        50.3 / 70.1   / 65.6 / 70.1    ===> if only WRITE speed is what counts, that mode is the best as it's overcranked to the minimum and it gives the same average write speed results
192 MHz:        64.4 / 83.0   / 49.8 / 83.1
244 MHz:        63.5 / 101.7 / 50.7 / 101.8   ===> Best READ mode

CF+SD Write: SD / CF => total
OFF       : 14.7 / 113.5 => 128.2
160 MHz: 43.9 / 93.1   => 137
192 MHz: 42.3 / 94.3   => 136.6
240 MHz: 54.7 / 89.5   => 144.2



I'll try to make some shot / raw videos in different mode tomorrow. It's anyway a BIG difference of minimum x2 in terms of write speed, just using the 160MHz.

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 7607
Re: Danne's crop_rec_4k & ISO experiments
« Reply #565 on: August 09, 2020, 11:55:39 PM »
Please run benchmarks with cardreader connected to your computer first. Both cards.

GullRaDriel

  • New to the forum
  • *
  • Posts: 41
Re: Danne's crop_rec_4k & ISO experiments
« Reply #566 on: August 10, 2020, 12:05:01 AM »
I don't think I have a decent card reader, as I can record quicker than reading / writing the CF on the computer. It may not be bad (the adapter) with the SDHC, will try tomorow.

Volumetrik

  • New to the forum
  • *
  • Posts: 40
Re: Danne's crop_rec_4k & ISO experiments
« Reply #567 on: August 10, 2020, 03:48:09 AM »
I'm currently testing with a Lexar Professional SD3XCII 10 128GB x1000 with a theoric write speed of 150MB/s . When I'll test I'll also do it with the CF, it will be a Lexar Pro UDMA7 1066x with a theoric write speed of 160MB/s.

Wait and see.

I think you may be referring to a discontinued model of that card. It just so happens that I have a 64GB version of said card.

Can you confirm that you're talking about this one ?


If so, I have tested it multiple times with card reader benchmarks and in camera with & without SD_UHS. My conclusion was that I found it very unstable performance wise. Sometimes I could get 118MB/s (SD_UHS 160Mhz + Spanning) writing for minutes at a time on the 5D3, other times my SD UHS-II card reader benchmarks were sub-standard, like 40MB/s and dropping.

Bad performance, to the point where I was seriously doubting the card's legitimacy. I bought it second hand with the 128GB 1066x 170MB/s Lexar card which runs flawlessly, so can't be sure.

For the reasons stated above, I don't use that card and I don't recommended for our use case.

GullRaDriel

  • New to the forum
  • *
  • Posts: 41
Re: Danne's crop_rec_4k & ISO experiments
« Reply #568 on: August 10, 2020, 11:23:26 AM »
My cards:


Obviously I was tired last evening, but at least I did some benchmarks on the mkIII ^^

What can I use to benchmark the cards on a computer ? Tested them with SpeedOut :

The SD is reporting an average of 87 MB Read / 77 MB Write
The CF is reporting an average of 133 MB Read / 130 MB Write

GullRaDriel

  • New to the forum
  • *
  • Posts: 41
Re: Danne's crop_rec_4k & ISO experiments
« Reply #569 on: August 10, 2020, 01:06:35 PM »
Okay, I did some test with the 166MHz Mode.

It's recording continuous 3072x1320,12-bits lossless (preview is cropped, but with framing it's usable to aim/focalise). I've ran a 1 minute long recording, kept green all the time. BTW I'm also recording sounds. I moved the camera a lot to make some sudden image change (and thus trigger some more activities), changed exposition during recording. Additional settings: card spanning on, preferred card CF, global draw off when recording. If it's counting, all my cards are formatted to exFat with default settings (did not played with cluster size).

ALL WORKED LIKE A CHARM. It was not the case before. It was working, but only for a couple dozen of seconds and with yellow indicators at best. What I can say is that the 166 MHz mode made my cards usable for raw recording.
I'm pretty aware that these are not the best fit cards for ML& MKIII, but the last versions of Danne's ML and modules made them pretty usable for the cases I'm aiming.

No problems while shooting. I'm going to play a bit with the patch on @ 166 and I'll try with the others after.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6959
Re: Danne's crop_rec_4k & ISO experiments
« Reply #570 on: August 10, 2020, 01:19:55 PM »
160Mhz is the only patch working solid so far with at least 170mb/s and probably 64gb 95mb/s cards. Mostly heard about sandisk cards but your lexar card works too?

If testing other patches easiest to test with only sd in the slot.

GullRaDriel

  • New to the forum
  • *
  • Posts: 41
Re: Danne's crop_rec_4k & ISO experiments
« Reply #571 on: August 10, 2020, 01:33:36 PM »
I can confirm that the 166 MHz patch is working with my Lexar card. It's at least doubling the default speed. Tested continuous 3K rec one more time and it's working for more than a minute without a glitch. It's staying green except each couple of 15 secs, where it's flashing to orange for a second before coming back to green (maybe a buffer/cache issue, it's not affecting my record)

@Danne a few post ago I posted my values, tested with only SD in:
OFF        :        20.5 / 21.8  / 18.8 / 21.8
160 MHz:        50.3 / 70.1   / 65.6 / 70.1    ===> if only WRITE speed is what counts, that mode is the best as it's overclocked to the minimum and it gives the same average write speed results
192 MHz:        64.4 / 83.0   / 49.8 / 83.1
244 MHz:        63.5 / 101.7 / 50.7 / 101.8   ===> Best READ mode

With my cards I was not that far from the wanted bandwidth for continuous 3K. Doubling the SD write speed did it.


Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6959
Re: Danne's crop_rec_4k & ISO experiments
« Reply #572 on: August 10, 2020, 01:41:31 PM »
Ok, could you test 240Mhz in photo mode. Run benchmark test, then take a photo, then run benchmark test once again. What readings are you getting from the second test? I want to know if your card will give consistent results or somehow breaks or not.
What´s your max write speed for your card? Seems around 70mb/s?

GullRaDriel

  • New to the forum
  • *
  • Posts: 41
Re: Danne's crop_rec_4k & ISO experiments
« Reply #573 on: August 10, 2020, 02:01:34 PM »
71.5 / 101.9 / 64.5/ 101.0  (no picture in background, card was cleaned)
Took 3 shots, RAW, and then ran again:
54.5 / 101.9 / 65.5 / 101.8 (one of the pictures I shot was in the background)

Edit: @240 MHz

Edit2: Ran a couple other shots, and a video, and one more benchmark (did not restart the camera since first test)  65.4 / 101.8 / 66.7 / 101.0

Edit3: the average write speed during the tests was 64.6
 
Edit4: The 240 MHz option seems to work on my setup.I'll try to stay on that mode for a while and report. ==> RAW recording not working in that mode for longer than a few seconds, (first try was just a start stop video) got raw error and camera in state where I need to pull of the battery.

Edit5: Going back to 160 Mhz immediately makes everything working back.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6959
Re: Danne's crop_rec_4k & ISO experiments
« Reply #574 on: August 10, 2020, 02:19:40 PM »
Are you running the tests in photo mode? Yeah, this means your card is probably working stable only in 160mb/s mode.
Just for the fun of it. Here´s a patch which works faster but not stable on my card. Maybe you are luckier:
https://bitbucket.org/Dannephoto/magic-lantern_jip_hop_git/downloads/sd_uhs.mo