Author Topic: Danne's crop_rec_4k & ISO experiments  (Read 63194 times)

sm105

  • New to the forum
  • *
  • Posts: 28
Re: Danne's crop_rec_4k & ISO experiments
« Reply #525 on: August 05, 2020, 08:42:34 PM »
Can rack focus be used with raw video? I can set the endpoints and preview the focus change in liveview, but I'm not sure how to activate it after starting to record.

GullRaDriel

  • New to the forum
  • *
  • Posts: 41
Re: Danne's crop_rec_4k & ISO experiments
« Reply #526 on: August 05, 2020, 09:43:36 PM »
Well, ok.
And when you say "Havn't found a way to disable patching yet" does it means that even with the moduel disabled the patching is still here ?

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6959
Re: Danne's crop_rec_4k & ISO experiments
« Reply #527 on: August 05, 2020, 09:54:02 PM »
No, it´s only patching when enabled in the menu. The solution could be to disable the sd_uhs menu when performing the reformat thingy(if sd patch is on) and probably not so hard to do but I havn´t been able to yet. Need more time.

has_abandonment_issu

  • New to the forum
  • *
  • Posts: 28
Re: Danne's crop_rec_4k & ISO experiments
« Reply #528 on: August 07, 2020, 10:58:13 PM »
Hi there! I wanted to say thank you for all the work on this build. It's been such a huge upgrade.

I found a weird quirk using the card spanning module. I'm using the July 15 3113 build. Not using sd overclocking as it's not working for me.

The 5x crop preset has an extra 5mbps without global draw using card spanning vs UHD or anamorphic. In those modes it tops out at 111mbps (91 cf - 20 sd) but in 5x 3.5k, the CF card climbs to 94-95, for a total of 115mbps! I think that mode is using fewer hardware resources or something and that translates into more recording bandwidth. I don't know if the way these modes behave is already well known, but it seemed worth mentioning. I am noticing differing (but consistent) speeds using different presets, with or without global draw.

I'm using a Pixelflash 1107x 64gb card and a Sandisk Extreme Pro 95mbps 32gb.

Kill Global Draw set to ON.

Edit: also it looks to me like the recording rate estimation is using 14bit raw recording in it's calculation, even though the files are in 12bit, giving a larger estimate than actual. Is this true? It seems like my recording times reflect what I would expect to get with 12bit.

Bender@arsch

  • Freshman
  • **
  • Posts: 79
Re: Danne's crop_rec_4k & ISO experiments
« Reply #529 on: August 08, 2020, 08:28:07 AM »
Quote
I am noticing differing (but consistent) speeds using different presets...
https://www.magiclantern.fm/forum/index.php?topic=12862.msg228848#msg228848

Global draw needs extra resources, so it slow down the maximum writespeed.
maximum speed with Cardspanning and overclocking for now is BTW. 131MB/s (Nobody knows why). - > without global draw

Quote
Edit: also it looks to me like the recording rate estimation is using 14bit raw recording in it's calculation, even though the files are in 12bit, giving a larger estimate than actual. Is this true?
Yes, it shows 14bit lossless - > set in drop down menu. This is because the settings for 12,10bit... Is just a tweaking from 14bit lossless. You can check the white and blacklevel in MLVapp.

What happens if you using SD overclocking?

Volumetrik

  • New to the forum
  • *
  • Posts: 40
Re: Danne's crop_rec_4k & ISO experiments
« Reply #530 on: August 08, 2020, 03:07:01 PM »
When I use Global draw & RAW Zebras in combination with card spanning + SD overclocking, I get around 112-115 MB/s while recording.

I set my resolution to get me 110 MB/s and I'm usually covered for continuous recording in pretty much all scenarios.

Extreme Pro 64gb 170MB/s + Lexar 128gb 1066X CF card.

Grognard

  • New to the forum
  • *
  • Posts: 28
Re: Danne's crop_rec_4k & ISO experiments
« Reply #531 on: August 08, 2020, 03:36:32 PM »

Global draw needs extra resources, so it slow down the maximum writespeed.
maximum speed with Cardspanning and overclocking for now is BTW. 131MB/s (Nobody knows why).

True for UHD mode but you can reach higher writespeed in 4K half FPS or 5'7k full liveview (170 MB/S -100 CF +70 SD).

Bender@arsch

  • Freshman
  • **
  • Posts: 79
Re: Danne's crop_rec_4k & ISO experiments
« Reply #532 on: August 08, 2020, 05:42:36 PM »
@Grognard

Not really , the showing writespeed is incorrect in other modes. See this test:

https://www.magiclantern.fm/forum/index.php?topic=12862.msg228848#msg228848

has_abandonment_issu

  • New to the forum
  • *
  • Posts: 28
Re: Danne's crop_rec_4k & ISO experiments
« Reply #533 on: August 08, 2020, 06:23:15 PM »
@Grognard

Not really , the showing writespeed is incorrect in other modes. See this test:

https://www.magiclantern.fm/forum/index.php?topic=12862.msg228848#msg228848

I see that there's a lot going on here with the writespeed calculations.

You also asked what happens when I try to use SD overclocking. I am using a 95mbps Sandisk Extreme Pro 32gb SDHC card. I have a 128gb 170 coming in the mail on Monday.

When I use the overclocking, I turn it on in the settings, turn off the camera, turn back on, wait for the prompt to say it's been patched. Then when I try to record, I have gotten both "card full," and "recorded has stopped" errors. No frames recorded. I have tested it spanned with my CF card (pixelflash 1107x 64gb) and on it's own. No luck. I have also tried both 3123 and 3113 builds to see if that made a difference. Nothing. I also tried formatting multiple different ways (exfat, fat32), but I don't actually know anything about formatting cards so that was just at random and it didn't do anything.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6959
Re: Danne's crop_rec_4k & ISO experiments
« Reply #534 on: August 08, 2020, 06:40:36 PM »
I was expecting the card 95mbps Sandisk Extreme Pro 32gb to work with latest sd uhs patch.
Could you tell me what ml version you are using? Full name or link to exact build?

Bender@arsch

  • Freshman
  • **
  • Posts: 79
Re: Danne's crop_rec_4k & ISO experiments
« Reply #535 on: August 08, 2020, 06:43:12 PM »
@has_abandonment_issu

This is a knowing issue. Try low level format in Camera (SD card) and have fun ;)

has_abandonment_issu

  • New to the forum
  • *
  • Posts: 28
Re: Danne's crop_rec_4k & ISO experiments
« Reply #536 on: August 08, 2020, 06:57:57 PM »
I was expecting the card 95mbps Sandisk Extreme Pro 32gb to work with latest sd uhs patch.
Could you tell me what ml version you are using? Full name or link to exact build?

Hi Danne! I have been having so much fun testing this build and exploring the new creative options. You and everyone should be really proud of how much you've put into it.

I have tested these two builds:

crop_rec_4k_mlv_snd_isogain_1x3_presets_2020Jul15.5D3113
crop_rec_4k_mlv_snd_isogain_1x3_presets_2020Jul15.5D3123

I did most of my testing on 3113, before briefly changing to 3123 and getting the same error. It looks to me like I'm having a similar issue as IDA_ML.

I just did it again to see exactly what was happening. Here's how it goes, I apologize if this is an annoying amount of detail, but I know you guys are troubleshooting so I'll try to describe everything:

- turn on camera, wait for it to load.
-turn on overclock module
-turn off camera
-receive patching notification
-patching done!
-go to live view, press record
-"recording has stopped automagically" "flushing buffers" "nothing recorded to card"
-turn off camera
-light stays on significantly longer than usual, about 6 seconds
-turn camera on
-"magic lantern was not shut off cleanly, skipping module loading"
-turn camera off
-light normal
-turn camera on
-receive patching notification
-patching done!
-go to ml menu and turn off patching
-turn off camera
-notification light stays on too long again
-turn on camera
-"magic lantern was not shut off cleanly"

and at that point I'm stuck in a loop and have to format the card.

This error has been consistent.

Edit:
@has_abandonment_issu

This is a knowing issue. Try low level format in Camera (SD card) and have fun ;)

I will try this right now.

has_abandonment_issu

  • New to the forum
  • *
  • Posts: 28
Re: Danne's crop_rec_4k & ISO experiments
« Reply #537 on: August 08, 2020, 07:20:10 PM »
Same error after low level format. First I tried formatting the card with magic lantern still installed. Then reinstalled magic lantern and tested it. Same error. Then I formatted the card on the computer, then low level formatted it again in the camera. Same error.

This time I tried again but without the CF card.

The error read "card full," followed by "audio failed to stop recording: state 3"  or something like that. So I disabled sound recording. Returned "card full," with no other error.

Then I went into the magic lantern menu and navigated through the various tabs to see if Magic Lantern can show what it thinks the available memory on the card is, and while simply scrolling (no change to any settings) I got an error that said "please send coredump.dat to the devs" or something along those lines.


Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6959
Re: Danne's crop_rec_4k & ISO experiments
« Reply #538 on: August 08, 2020, 07:41:41 PM »
I am not sure what is going on here and don't have my camera here but if it's not working giving card full etc it's better to stay off the patch on this particular card. I expect this patch to either work fully or not at all, no in betweena.
Not sure what coredump is caused for in this case but just stay off patch on that card.
Please remember. It is bleeding edge. I tried to prevent serious errors but nothing is finished.

has_abandonment_issu

  • New to the forum
  • *
  • Posts: 28
Re: Danne's crop_rec_4k & ISO experiments
« Reply #539 on: August 08, 2020, 07:44:09 PM »
This seems like it could be relevant.

https://i.imgur.com/nS2MvTZ.jpg

I can link pictures of the rest of the red ones if this is anything.

I am not sure what is going on here and don't have my camera here but if it's not working giving card full etc it's better to stay off the patch on this particular card. I expect this patch to either work fully or not at all, no in betweena.
Not sure what coredump is caused for in this case but just stay off patch on that card.
Please remember. It is bleeding edge. I tried to prevent serious errors but nothing is finished.

I purchased this card with free amazon 1-day shipping to keep me busy until my 128 170mbps sandisk arrives Monday. It was $13. So I don't mind destroying the card if it helps debugging. So long as there's no risk to the camera itself.

Bender@arsch

  • Freshman
  • **
  • Posts: 79
Re: Danne's crop_rec_4k & ISO experiments
« Reply #540 on: August 08, 2020, 07:55:09 PM »
@has_abandonment_issu

Which Mode do you use, resolution, bit...

because I have some trouble with 3K mode:
Interestingly I found out, that this mode + Cardspanning + overclocking only works with 14bit lossless continuously. If I set the same settings (AR 16:9, 2848x1602 at 14bit lossless works continously on all condition, without global draw) and change it to 10 or 12 bit - > compression error bla bla bla, everytime.

@Danne
Any Idea?

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6959
Re: Danne's crop_rec_4k & ISO experiments
« Reply #541 on: August 08, 2020, 07:59:48 PM »
10 or 12bit from what menu? Under raw video menu not recommended.

Bender@arsch

  • Freshman
  • **
  • Posts: 79
Re: Danne's crop_rec_4k & ISO experiments
« Reply #542 on: August 08, 2020, 08:08:10 PM »
Not in dropbdown menu. I mean the 10  or 12bit lossless (14bit lossless tweaking). Do you need a small video with this error?

70MM13

  • Senior
  • ****
  • Posts: 484
Re: Danne's crop_rec_4k & ISO experiments
« Reply #543 on: August 08, 2020, 08:09:57 PM »
hi everyone,
i'm having a lot of fun with the 5.7k mode, in fact i love it!
i'm wondering if there's a way to increase the vertical resolution to capture 2.35:1 without reducing the horizontal resolution?
with spanning and overclock there is plenty of headroom but i just can't find a way to get that little bit more vertical capture...
thanks!

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6959
Re: Danne's crop_rec_4k & ISO experiments
« Reply #544 on: August 08, 2020, 08:16:53 PM »
Not in dropbdown menu. I mean the 10  or 12bit lossless (14bit lossless tweaking). Do you need a small video with this error?
Not sure where you select from. The bitdepth options from Crop mode sub menu should work.

Bender@arsch

  • Freshman
  • **
  • Posts: 79
Re: Danne's crop_rec_4k & ISO experiments
« Reply #545 on: August 08, 2020, 08:23:55 PM »
Movie, bitdepth, 8bit, 9bit, 10bit, 12bit- > only with 3K mode I have the errors.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6959
Re: Danne's crop_rec_4k & ISO experiments
« Reply #546 on: August 08, 2020, 08:29:28 PM »
Ah, yes, Movie tab. Tell me exact name of presets giving errors and I'll try to reproduce later.

Bender@arsch

  • Freshman
  • **
  • Posts: 79
Re: Danne's crop_rec_4k & ISO experiments
« Reply #547 on: August 08, 2020, 09:18:32 PM »
Here is a short video and the error file from the 3K mode test:

https://drive.google.com/drive/folders/1ABS7sbXXXDIjMHNzeFNeAr9lBh2Lj_3z?usp=sharing

I get this error only if i use 10 or 12 bit lossless, not with 14bit lossless. The resolution is not important, i use this resolution for 14bit lossless (filezise analyse says 125 up to 130MB/s -> correct writespeed). So this is the limit for continuosly record at 14bit lossless and AR 16:9.

The error comes sometimes immediately and sometimes after 30sec.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6959
Re: Danne's crop_rec_4k & ISO experiments
« Reply #548 on: August 08, 2020, 09:37:44 PM »
I know about this error. It´s always triggered from the same place in mlv_lite.
Usually I don´t add any extras to global draw but stick to minimun per installation. I also don´t change ratios from under RAW video menu but stick to Movie tab ratios but that´s maybe the case already. Lastly I didn´t test 16:9 extensively. Is it working better with 2.39:1? Is it working without sd patch added? Without using shutter fine tuning?
Thanks for the vid.

Bender@arsch

  • Freshman
  • **
  • Posts: 79
Re: Danne's crop_rec_4k & ISO experiments
« Reply #549 on: August 08, 2020, 10:01:54 PM »
I set kill global draw and I tested as well with standard settings. I change ratio because of the error, so no difference. I tested 2.39:1 at 10bit - at the last resolution (2848) it works, but with 3072 not. The same without SD overclocking and the same without audio and the same without fine tuning. This all is only happens in 3K mode with Cardspanning.