Author Topic: Danne's crop_rec_4k & ISO experiments  (Read 57501 times)

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6928
Re: Danne's crop_rec_4k & ISO experiments
« Reply #125 on: October 19, 2019, 01:31:52 AM »
I don´t know if you have x10 focus aid enabled. Try disabling that if it´s the case.

ozcancelik

  • Freshman
  • **
  • Posts: 90
Re: Danne's crop_rec_4k & ISO experiments
« Reply #126 on: October 19, 2019, 09:32:25 AM »
I don´t know if you have x10 focus aid enabled. Try disabling that if it´s the case.
Tried both on and off. Nothing changed. But for now i use zoom button 2 times then focusing. Not best solution and very slow, but works.[emoji3]

May I ask, do you use 123 or 113?

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6928
Re: Danne's crop_rec_4k & ISO experiments
« Reply #127 on: October 19, 2019, 10:23:29 AM »
Screen recordings preferred that shows your issues. Too much guesswork.

ozcancelik

  • Freshman
  • **
  • Posts: 90
Re: Danne's crop_rec_4k & ISO experiments
« Reply #128 on: October 19, 2019, 06:08:27 PM »
Screen recordings preferred that shows your issues. Too much guesswork.
There is a video that i record. I hope it helps.
https://drive.google.com/open?id=1t4SrL51Cvcn_pFS0AusOpHd_CL3QuE15

Also my settings:


I guess I'm missing something to do. :)
Thank you very much for your interest.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6928
Re: Danne's crop_rec_4k & ISO experiments
« Reply #129 on: October 19, 2019, 07:42:44 PM »
All is working over here. Just tested. Did you set Preview to framing? You find this under RAW video menu settings.

ozcancelik

  • Freshman
  • **
  • Posts: 90
Re: Danne's crop_rec_4k & ISO experiments
« Reply #130 on: October 19, 2019, 08:59:59 PM »
All is working over here. Just tested. Did you set Preview to framing? You find this under RAW video menu settings.

Yes its Framing.


Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6928
Re: Danne's crop_rec_4k & ISO experiments
« Reply #131 on: October 19, 2019, 09:08:52 PM »
Hard to say what is going on but keep testing different settings. Maybe you find the answer eventually. I'm on 1.1.3 by the way.

ozcancelik

  • Freshman
  • **
  • Posts: 90
Re: Danne's crop_rec_4k & ISO experiments
« Reply #132 on: October 20, 2019, 02:39:59 PM »
Hard to say what is going on but keep testing different settings. Maybe you find the answer eventually. I'm on 1.1.3 by the way.

I guess i found the problem. It’s about adtg_ui module. I disabled the module and everything works expected.

Does this module use any code with your crop_rec? I tested and looks fine. Just want to know.

Thanks again Danne!

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6928
Re: Danne's crop_rec_4k & ISO experiments
« Reply #133 on: October 20, 2019, 05:32:57 PM »
Ah, yes. It will interfere with framing. Good catch. I should remove this module as it´s only needed for when looking for registry nad development.

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3397
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
Re: Danne's crop_rec_4k & ISO experiments
« Reply #134 on: October 20, 2019, 06:01:00 PM »
Ah, yes. It will interfere with framing. Good catch. I should remove this module as it´s only needed for when looking for registry nad development.
Or just leave it disable when installing. Enable when needed for troubleshoot and tests.
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

gravitatemediagroup

  • Member
  • ***
  • Posts: 242
Re: Danne's crop_rec_4k & ISO experiments
« Reply #135 on: October 26, 2019, 04:46:47 AM »
nothing warms my heart more than seeing progression here

timbytheriver

  • Senior
  • ****
  • Posts: 446
Re: Danne's crop_rec_4k & ISO experiments
« Reply #136 on: October 26, 2019, 06:28:25 PM »
@Danne

Thanks for new build 'crop_rec_4k_mlv_snd_isogain_1x3_presets_2019Oct15.5D3113.zip'

If I use with iso_regs.mo ON I get strange behaviour of liveview: e.g. in Anamorphic 1360x2300, the liveview image changes its centre point and becomes squished up. Turning iso_regs OFF and restart resets the liveview to normal behaviour.

Is iso_regs not designed to work with crop_rec.mo now?

5D3 1.1.3
5D2 2.1.2

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6928
Re: Danne's crop_rec_4k & ISO experiments
« Reply #137 on: October 26, 2019, 06:33:40 PM »
Both adtg_gui and, also seemingly, iso_reg module, will affect outcome in some way. Have no idea why so feel free to take a look if you have the time.

timbytheriver

  • Senior
  • ****
  • Posts: 446
Re: Danne's crop_rec_4k & ISO experiments
« Reply #138 on: October 26, 2019, 06:46:22 PM »
@Danne Righto. Thanks. Maybe something's changed, as previous versions seemed to play nicely with iso_regs.
5D3 1.1.3
5D2 2.1.2

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6928
Re: Danne's crop_rec_4k & ISO experiments
« Reply #139 on: October 26, 2019, 07:29:09 PM »
If so, try to narrow down the build where it starts to break.

timbytheriver

  • Senior
  • ****
  • Posts: 446
Re: Danne's crop_rec_4k & ISO experiments
« Reply #140 on: October 27, 2019, 01:30:04 PM »
@Danne

Reverted to an older build to try and trace errors with iso_regs. Have only got a backup of crop_rec_4k_mlv_snd_isogain_1x3_presets_2019Apr02.5D3113.zip which on my camera is buggy with compression errors. Errors go when I update to most recent – but then whenever iso_regs is enabled the crop_rec previews are all messed up.

Trying to find more recent builds from July19 (which were working well on my camera) on your downloads but can't find them. Have you taken them down? 

5D3 1.1.3
5D2 2.1.2

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6928
Re: Danne's crop_rec_4k & ISO experiments
« Reply #141 on: October 27, 2019, 02:13:24 PM »
I can't keep every build. I'd prefer users to take time to compile on their own so I guess if this issue is important enough to fix you simply learn to compile. No priority over here. Need to focus on other things. Good luck.

timbytheriver

  • Senior
  • ****
  • Posts: 446
Re: Danne's crop_rec_4k & ISO experiments
« Reply #142 on: October 27, 2019, 02:23:29 PM »
Ok. I hear you. Thanks!
5D3 1.1.3
5D2 2.1.2

timbytheriver

  • Senior
  • ****
  • Posts: 446
Re: Danne's crop_rec_4k & ISO experiments
« Reply #143 on: October 28, 2019, 11:50:07 AM »
@Danne I'm going to try to have a go and jump into ML dev.  :o I've installed via your compiler.app as per here https://www.magiclantern.fm/forum/index.php?topic=21882.0

The example given at 7) is for 17 EOSM.202

Could you give me some pointers how I'd change this to recompile your earlier Jul22 4K_crop_rec build for 5D3113 ?

Thanks!

PS I have managed to compile today's build, but am stuck on how to find an earlier build!
5D3 1.1.3
5D2 2.1.2

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6928
Re: Danne's crop_rec_4k & ISO experiments
« Reply #144 on: October 28, 2019, 12:50:53 PM »
Good. I didn't include jumping around in source tree in any easy way with compiler.app so it needs to be done in terminal. You can also work from atlassian source tree gui. In there you can see commits and doubleclick back in time.
Sorry, not a lot of time lately...

timbytheriver

  • Senior
  • ****
  • Posts: 446
Re: Danne's crop_rec_4k & ISO experiments
« Reply #145 on: October 28, 2019, 01:02:49 PM »
You can also work from atlassian source tree gui. In there you can see commits and doubleclick back in time…
Thanks!

Lots of stuff I don't understand there! I know you're time-poor at moment so could anyone else point out how I work in the source tree gui to compile a specific build?

Thanks

***UPDATE***
I've searched back to find the commit for Jul22 and have managed to download a zip of this by doing https://bitbucket.org/Dannephoto/magic-lantern/get/f0e391b.zip

Now I have this folder, I need to compile it into the final zip… How do I do this?
5D3 1.1.3
5D2 2.1.2

Dmytro_ua

  • Member
  • ***
  • Posts: 202
  • Kyiv, Ukraine
Re: Danne's crop_rec_4k & ISO experiments
« Reply #146 on: October 28, 2019, 02:15:02 PM »
I've got Danne's  "crop_rec_4k_mlv_snd_isogain_1x3_presets_2019Jul20.5D3113" build. If you need it I can upload it somewhere.
5d3 1.1.3 exp | Canon 16-35 4.0L | Canon 50 1.4 | Canon 100mm 2.8 macro
Ronin-S

timbytheriver

  • Senior
  • ****
  • Posts: 446
Re: Danne's crop_rec_4k & ISO experiments
« Reply #147 on: October 28, 2019, 03:04:53 PM »


@DeadEyeJedi I have got my install working to the same level as seen in this video now. What I'd like to know is how to compile a build from an earlier commit date in Danne's repo. Do you or anyone else know how?  :o

Cheers all!
5D3 1.1.3
5D2 2.1.2

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6928
Re: Danne's crop_rec_4k & ISO experiments
« Reply #148 on: October 28, 2019, 06:09:03 PM »
If you downloaded and got into the correct branch you can still compile from compiler.app after you select a new historical commit. I advice to use Source tree:

timbytheriver

  • Senior
  • ****
  • Posts: 446
Re: Danne's crop_rec_4k & ISO experiments
« Reply #149 on: October 28, 2019, 07:16:38 PM »
@Danne

Thanks. I have sourcetree installed now.

I'm doing: Open > Remote > Clone a repository > https://bitbucket.org/Dannephoto/magic-lantern > Destination: /Users/me/magic-lantern

From here I don't know how to select the historical commit or compile. Any pointers?

Thanks.
5D3 1.1.3
5D2 2.1.2