Author Topic: [HARDWARE] 70d does not want to turn on - raised mirror  (Read 1132 times)

yokashin

  • New to the forum
  • *
  • Posts: 12
[HARDWARE] 70d does not want to turn on - raised mirror
« on: June 23, 2018, 08:45:52 AM »
Good morning,

Does anyone have any idea to run my 70d?
I was at the concert yesterday.
I took pictures and recorded videos for 5 minutes.
Suddenly, the camera hangs after you finish recording the movie.
The video file has been saved correctly.

I have an SD card magiclantern-Nightly.2018Feb17.70D112.
I recorded the movies normally from the Canon menu.

The camera will not turn on.
No messages on the screen.
I tried to remove the SD card and battery.
The LED blinks once only when inserting the batteries.

After removing the lens I found that I have a raised mirror and a curtained shutter - no matrix is visible.

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 6740
Re: 70d does not want to turn on - raised mirror
« Reply #1 on: June 23, 2018, 07:05:43 PM »
Backup card's ROM0.BIN and ROM1.BIN. Don't skip this step!
Backup/rename card's autoexec.bin and replace it by Portable display test autoexec.bin.
Then remove battery, insert card, insert battery. Report results.
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!

ArcziPL

  • Contributor
  • Member
  • *****
  • Posts: 130
Re: 70d does not want to turn on - raised mirror
« Reply #2 on: June 23, 2018, 07:19:35 PM »
Does the top LCD show anything, when you turn the camera on?
70D.112 | M50.102 | M.202

yokashin

  • New to the forum
  • *
  • Posts: 12
Re: 70d does not want to turn on - raised mirror
« Reply #3 on: June 24, 2018, 09:50:56 AM »
Thank you for the response.

After putting the betery into the camera, which is turned off, I can not see anything on both displays. Turning on the camera does not change anything.
If I put the battery in the camera that is turned on, information appears on the small screen that was visible before the fault.




Turning the camera off does not disable this screen.




View of the raised mirror.





Nothing is displayed on the main screen.

yokashin

  • New to the forum
  • *
  • Posts: 12
Re: 70d does not want to turn on - raised mirror
« Reply #4 on: June 24, 2018, 10:24:01 AM »
Running the camera with the modified autoexec.bin only causes a momentary flashing of the screen.
The screen starts only when the batteries are inserted into the camera with the switch in the ON position.


Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 6740
Re: 70d does not want to turn on - raised mirror
« Reply #5 on: June 24, 2018, 10:40:22 AM »
It's up to a1ex for a final verdict but it looks like you have a serious hardware problem.
This diagnostic autoexec.bin uses very basic functions only (bypassing most of Canon's stuff) and should simply not work this way.

MOD: Please move thread to Camera Emergency Department.
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12224
  • Maintenance mode
Re: 70d does not want to turn on - raised mirror
« Reply #6 on: June 24, 2018, 11:00:22 AM »
Right, pretty sure it's a hardware issue.

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1466
  • 6d - Nightly build user
Re: 70d does not want to turn on - raised mirror
« Reply #7 on: June 24, 2018, 11:18:17 AM »
Not an expert myself on this.
But it could be that the mirror is stuck.
If this was my own camera, I would definately try if I could lower the mirror with some light finger push...
With the emphasize on light push, don’t force it, just check if it is something small that’s keeping the mirror up(as far as I know, mirror always falls down when battery is pulled. So most logiccaly something is blocking the mirror on it’s way down.

But like I said, no expert, just something I would try if it was my cam.

yokashin

  • New to the forum
  • *
  • Posts: 12
Re: 70d does not want to turn on - raised mirror
« Reply #8 on: July 20, 2018, 03:26:27 PM »
The camera has been put into service.
Initial diagnosis - err 20 - short circuit in the mirrorbox.
The cost of exchange for a new one - 200 Euro.

---------

The camera has been repaired.
Repair was performed in the power section.
The cost of repair was 100 euros.

Thanks for your help.

newhousepro

  • New to the forum
  • *
  • Posts: 1
Re: 70d does not want to turn on
« Reply #9 on: July 27, 2018, 03:26:59 PM »
I installed ML on my 70D 3 days ago and when I was testing one of the RAW modules it turned off, now the only sign that it still works is that the focusing on the lens responds when in manual. No red led when memory card inserted. I tried formatting card and replacing all files with the files I had used initially but that did not work. Please help. Thank you.

ASSERT: !IS_ERROR( TryPostEvent( this->hTaskClass, this, EV_VD_INTERRUPT_EVF, NULL, 0 ) )
ct ./Evf/EvfStatg.c:428, **INT-6Ah**:14100
lv:1 mode:3

PowerMgr stack: 28bfa0 [16b340-16af40]
0x0044C478 @ 44c4f4:28bfa0

Magic Lantern version : Nightly.2018Feb17.70D112
Mercurial changeset   : 8e53e66c7f7c+ (70D_merge_fw112) tip
Built on 2018-02-17 01:58:04 UTC by jenkins@nightly.
Free Memory  : 182K + 2493K

ASSERT: HivshdParameter[1].Engine_Address == HIV_H_SWS_ENB
at ./Path/Lv_x1/Lv_x1.c:257, Evf:ff523d58
lv:1 mode:3

Evf stack: 1a3f00 [1a40b0-1a30b0]
0xUNKNOWN  @ ef80:1a40a8
0xUNKNOWN  @ 3db8c:1a4080
0x0003D884 @ ff0d44e0:1a4068
0xUNKNOWN  @ 3d8b4:1a4058
0xUNKNOWN  @ 479520:1a4030
0xUNKNOWN  @ 3d93c:1a4010
0x0003F960 @ 155a0:1a3fa8
0x0001FF8C @ 3f9e8:1a3f98
0xUNKNOWN  @ 20030:1a3f88
0x00001900 @ ff523d54:1a3f38
0x0044C478 @ 44c4f4:1a3f00

Magic Lantern version : Nightly.2018Feb17.70D112
Mercurial changeset   : 8e53e66c7f7c+ (70D_merge_fw112) tip
Built on 2018-02-17 01:58:04 UTC by jenkins@nightly.
Free Memory  : 178K + 2498K

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 6740
Re: 70d does not want to turn on - raised mirror
« Reply #10 on: July 31, 2018, 08:12:03 AM »
Do you have your ROM files backed up?

Just to please me:
Remove battery, remove card.
Insert battery but do not insert card.
Results?
Any different results with card inserted?

If cam not working (and only if):
By formatting card you removed card's boot ability. Use EOScard (Windows) or Macboot (macOS) to restore that option. (If using EOScard: Remove all files and directories from card after.)
Copy portable display test autoexec.bin to card https://www.magiclantern.fm/forum/index.php?topic=2296.0
Remove battery, insert card, insert battery.
Report results.
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!