Author Topic: Is there any "new" method to prevent T5i to stop liveview after 30 minutes ?  (Read 8166 times)

Dihelson

  • New to the forum
  • *
  • Posts: 33

Hello, fellows,

After many months, more than a year away from the forum, I came back to know if there´s yet any advancement, or any idea on how to prevent Canon T5i to stop liveview automatically after 30 minutes. I use these cameras for live broadcasts, using the  HDMI output, but having to turn on the cameras every 30 minutes is like a fellow once said "Ain´t that a kick in the head"...So, any tips on how preventing it from doing so in 2017 ?

Thanks in advance.

Canon 5D Mark II, 700D, Panasonic Fz200 | Canon 24-70mm f2.8L | 17-40mm f4.0L | 70-200mm f2.8L IS II | 50mm f1.8 | Blackmagic, Avermedia 4K cards

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3748
I use these cameras for live broadcasts, using the  HDMI output...

A while back there was a similar issue with someone using an EOSM as a wildlife trap camera. I wrote a simple lua script that kept the camera alive. One issue with what you are doing is that it might show a glitch when the lua script triggers a shutter half-press event.

5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12390
  • Quarantined
Look in powersave.c under "Canon's powersave timer". These functions are currently used for raw video, silent pictures and a few other long-running things (such as benchmarks or Lua scripts).

This gives the easiest workaround: with the lua_fix or crop_rec_4k build, start a Lua script that does nothing, e.g.
Code: [Select]
-- Powersave workaround
while true do
   msleep(1000)
end

TODO: add this feature to ML menu (easy coding task).

AeroSimGaming

  • New to the forum
  • *
  • Posts: 4
Hey guys!

I was about to spam a post and this is the exact issue I have.  Currently I am using the T5i as a live stream camera for working on airplanes.  Problem is exactly the 30min power off, so I have to drag myself away from the aircraft, reset the camera then go back.  Its pretty hard to get any work done!

Should I go ahead and create this lua script here by A1ex?  Or will this be apart of a nightly build in the near future?

I have not used any of the lua scripting before on the camera so I am a complete noob there and dont want to do anything wrong! The other question is there any difference between the "do nothing" lua script and the "half shutter press" script?  Or do they just achieve the same thing?

Thanks!

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12390
  • Quarantined
Try and report. The powersave change is recent, so back in 2016, half-shutter was needed to reset the timer (which is hidden somewhere in Canon code, and regular button "presses" from software did not touch it).

I did not test it against the 30-minute LiveView timeout; only against the 1-minute auto power off.

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 7233
Looks like it's working for 650D. Works with USB connect in EOS Utility, too. Haven't tested HDMI option yet.
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!

AeroSimGaming

  • New to the forum
  • *
  • Posts: 4
Try and report.

Hey A1ex has there been any development with this for the T5?

I remember reading that you were looking at adding this to a build in the thread.  I tried doing the lua script but I could not figure out how to write it, or where to put the copy paste of someone elses work.  I just dont understand the lua thing or how to add it to the Magic Lantern build!

Thanks for the help!

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12390
  • Quarantined
TODO: add this feature to ML menu (easy coding task).

Done.

AeroSimGaming

  • New to the forum
  • *
  • Posts: 4
Done.

Hey A1ex

Sorry to bother you again, was this implemented into a lua or into the core of MagicLantern?

Just trying to find in the menu system where the selection is placed!

Thanks

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12390
  • Quarantined
Only in the lua_fix experimental builds for now.

This changeset.

AeroSimGaming

  • New to the forum
  • *
  • Posts: 4
Only in the lua_fix experimental builds for now.

This changeset.

Hey A1ex, I tested that build and it works great!  I had the camera outputting 1080P HDMI for 8 hours straight.  No shut downs or anything, the other systems worked fine.  Global draw off etc.

So basically got the full clean HDMI output from the 700D/T5i for 8 hours.  I didnt test any of the other functions, photos etc.  But for this function it was fantastic and no faults to report.

So thank you for the work and keeping it moving, I now have a functioning camera!

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12390
  • Quarantined
Nice, thanks for confirming. I've only tested it for a few minutes, with Canon's Auto Power Off, but expected it to work with the 30-minute timer as well, based on previous reports from other code using the same technique.

Dihelson

  • New to the forum
  • *
  • Posts: 33
Hey A1ex, I tested that build and it works great!  I had the camera outputting 1080P HDMI for 8 hours straight.  No shut downs or anything, the other systems worked fine.  Global draw off etc.

So basically got the full clean HDMI output from the 700D/T5i for 8 hours.  I didnt test any of the other functions, photos etc.  But for this function it was fantastic and no faults to report.

So thank you for the work and keeping it moving, I now have a functioning camera!

Hello, friends. I think it worths replying to the topic, because it´s a continuation of the starting question I did.

AeroSimGaming, I read that you somehow installed the "nightly build" or the Lua script on your T5i and solved the problem with it automatically turning off live view after 30 minutes. I also use my several T5i to film long events, and as an excellent "webcam" for broadcast through OBS, but since it turns off live view after 30 minutes, it becomes impactical. I searched for many years a solution to this problem, since Magic Lantern ( That I know ) couldn´t find where the sticky half shutter function on this camera, so, when I saw that A1ex posted here on my topic thay he made a script, I became very interested. The problem is that I know NOTHING about Lua scripts, or how to use them, but at this time, may be this script could have been incorporated on a nightly build, but what ? I still use an old Magic Lantern version, and I fear testing not stable versions on my cameras, but since you tested and it worked fine, could you please tell me all the steps to overcome this problem ?

Thanks in advance !

Dihelson Mendonça
Canon 5D Mark II, 700D, Panasonic Fz200 | Canon 24-70mm f2.8L | 17-40mm f4.0L | 70-200mm f2.8L IS II | 50mm f1.8 | Blackmagic, Avermedia 4K cards

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 7233
Top of page -> Downloads -> Download (dropdown menu) -> Experiments -> Lookup lua_fix build for your cam and copy it to your card.
Then access Prefs tab -> Powersave in Liveview -> 30-minutes timer Disable
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!

Dihelson

  • New to the forum
  • *
  • Posts: 33
Top of page -> Downloads -> Download (dropdown menu) -> Experiments -> Lookup lua_fix build for your cam and copy it to your card.
Then access Prefs tab -> Powersave in Liveview -> 30-minutes timer Disable

Thank you Walter. I located the file and downloaded. But my T5i already has a version of ML installed. Should I uninstall it first, or can I format the card on camera and put the new files as if there was no ML before ? Thanks for pointing me to the right place.
Canon 5D Mark II, 700D, Panasonic Fz200 | Canon 24-70mm f2.8L | 17-40mm f4.0L | 70-200mm f2.8L IS II | 50mm f1.8 | Blackmagic, Avermedia 4K cards

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 7233
Rename ML folder to ML.nb and autoexec.bin to autoexec.bin.nb. Copy extracted experimental build files to card. Overwrite ML-Setup.fir or not, it doesn't matter at all.
Insert card and power on cam.
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!

Dihelson

  • New to the forum
  • *
  • Posts: 33
Rename ML folder to ML.nb and autoexec.bin to autoexec.bin.nb. Copy extracted experimental build files to card. Overwrite ML-Setup.fir or not, it doesn't matter at all.
Insert card and power on cam.

Thank you, Walter. I already solved, and made a FAQ about it in order to help other people.

Here´s the link:

https://www.magiclantern.fm/forum/index.php?topic=23520.0
Canon 5D Mark II, 700D, Panasonic Fz200 | Canon 24-70mm f2.8L | 17-40mm f4.0L | 70-200mm f2.8L IS II | 50mm f1.8 | Blackmagic, Avermedia 4K cards

davemill

  • Just arrived
  • *
  • Posts: 1
Newbie question: has this feature been rolled into the "regular" release or is it still experimental? Still trying to grasp the power of ML . Thank you.

patrickpy

  • Just arrived
  • *
  • Posts: 1
Newbie question: has this feature been rolled into the "regular" release or is it still experimental? Still trying to grasp the power of ML . Thank you.

Looks like it is still in the experimental Lua branch :)

Just testing it, seems to be working fine :)