Author Topic: [??? user gave up] 550d err 70 and 80  (Read 1089 times)


  • New to the forum
  • *
  • Posts: 2
[??? user gave up] 550d err 70 and 80
« on: October 31, 2017, 04:39:24 AM »
I hope I'm allowed to post this here. I just got a 550d a few days ago before that i had an e-410 for a few years, obviously my 550d is second hand.

I read over what was available for ML when i got it and decided that i probably wouldnt need it and keeping track of memory cards and ML on them ect. would be too complicated for my wife who would be using it allot so i decided against installing.

Then Yesterday i was filming outside and put my camera down on a chair a few hours later my camera was in the sun. when i went back inside i took it inside then a few minutes later turned it on again and took a few pictures. I got err 80 after 6 or so pictures and flashing red light wouldnt go off. pulling the battery let me take a few more photos then i got it again.

so i updated my firmware to 1.10 then i got an err 70 message trying to take a picture, i read as much as i could find about both errors last night and my conclusion is that probably the camera got too hot in the sun and then taking pictures with it stressed it to breaking point, though im hoping still that it hasnt.

during my reading i saw several ML users post crash reports so I decided to downgrade to 1.0.9 and install ML which ive done, took allot of pictures but each time camera just gave busy message and/or red light flashing but no crash saved, this morning same thing but got an err 80 message still no crash report, then finally i enabled the silent pictures module tried to take a photo and got a crash report. so basically im hoping that my crash report will be able to tell me something.

also ive tried with both my lens and made sure the contact points are all clean and dry, and reset canon menu settings several times (i may have become overly desperate haha), ive also tried with several memory cards.

Any further debugging or help would be very appreciated.

Crash Report says:

at ShootMemory.c:1337, task RscMgr
lv:0 mode:9

RscMgr stack: 115fd0 [116138-115138]
0xUNKNOWN @ ff0771dc:116130
0xUNKNOWN @ ff1d8a98:116108
0xFF1D84F4 @ ff027b6c:1160d0
0xUNKNOWN @ ff1d8524:1160c0
0xUNKNOWN @ ff1d85ac:1160a0
0xFF0B7064 @ ff0bdc44:116000
0x00C60468 @ c604e4:115fd0

Magic Lantern version : Nightly.2017Oct04.550d109
Mercurial changeset   : 30db46575511
Built on 2017-10-04 00:22:25 UTC by jenkins@nightly
Free Memory : 164k + 1948K

also it only has a problem when i try to use liveview (or put on video mode) or try to take a picture. all menu and settings are accessible.

another crash just now everything is the same except line 3 is mode:15
and Free Memory : 205K + 1880K


  • Administrator
  • Hero Member
  • *****
  • Posts: 12222
  • Maintenance mode
Re: 550d err 70 and 80
« Reply #1 on: October 31, 2017, 05:45:35 PM »
To be clear:

- You've got ERR80 before installing ML, right? I assume there were no ERR70 messages at this stage, correct?
- You have then upgraded to 1.1.0 and this brought ERR70 when trying to take a picture, correct?
- You have then downgraded to 1.0.9; the behavior did not improve (ERR70 still present); correct?
- You have then installed ML and got the crash log.

One way to get detailed logs (all messages from Canon code, and a few more from us) is with the startup-log build.

I can also try to troubleshoot it in QEMU. I'm not yet able to emulate LiveView, but the still photo capture backend works, to some extent (it doesn't save a CR2, it only emulates the raw image capture, until getting uncompressed 14-bit data). Please PM me the ROM files you have backed up during installation.

Generally, ERR70 is something triggered on the main CPU, while ERR80 comes frome the MPU (just FYI).


  • New to the forum
  • *
  • Posts: 2
Re: 550d err 70 and 80
« Reply #2 on: November 02, 2017, 05:03:24 PM »
thanks i just assumed they were related or the same as the original errors logged by ml said the same thing for both my err 70 and 80s, anyway ive run the the 20 sec logger and have come back with head error messages similiar to a post youve replied to previously, so its a hardware error then. so thanks again for the support, ill probably be replacing it with a 50d now after reading through the posts about that camera and it will definately have ml on it now as ill be using it for film.

i would still pm the rom files but i assume my cameras dead now?