Author Topic: [HW] Canon 5D Mark III bricks shortly after "ML not cleanly shut down" warning  (Read 1636 times)


  • New to the forum
  • *
  • Posts: 18
Ladies and Gentlemen of the Magic Lantern forums, today, my Canon 5DM3 appears to be bricked.

I have a feeling that this is hardware issue, but I didn’t want to rule out anything with software before shipping this off to Canon for costly repairs, so I’ll share the tale and perhaps someone out there has had a similar issue and can shed some light onto what went wrong and how to fix it.

How I got here:

Before the camera went completely dark, I was doing some tests to resolve an issue where the ML audio meters were showing some kind of weird audio distortion that was appearing when either the HDMI cable was connected from the Canon 5MD3 to the external EVF (IDX powered via regulated dummy battery), or when my the mini stereo cable was connected to the Canon 5DM3 via a Tascam 70DR, the on board digital recorder (IDX powered via regulated D-Tap Multi Tap with USB port).  The ML Audio meters were handy for seeing this problem. See below:

best image hosting free

I had previously done an audio test on this camera after uninstalling ML and the audio issue was still present, so I was confident ML was not the problem.

All the devices on my rig are powered via regulated D-Tap Batteries via the appropriate cables and never gave me any trouble.  Everything seems to be getting it's appropriate voltage (Zacuto Gratical EVF, Tascam 70DR, Canon 5DM3).

However when each device was switched to it's own independent power source like a Canon Battery or AC power via a plug and usb cable, the audio issue would stop. See below:

I ruled out ML being part of the problem after these tests and that it had something to do with the Tascam 70DR and it's power source.

Well, during my trouble shooting tests, I would forget myself and just quickly turn the Canon 5DM3 on and off at my leisure, changing cables, popping off shots to review later, though I didn’t think this would cause any problem.

Right before it bricked:

At one point, after restarting the Canon 5DM3, I could see on the display an error message from ML, something about it not being shut off cleanly and the it would skip loading certain files.  (I should have paid closer attention, I can't recall what it said exactly.)

Things seemed to be running fine during my tests, but then I saw an ERROR flag on the LCD display on the top of the 5DM3 camera body. 

I panicked and immediately cut the camera off.  The last time I saw something like this, I had connected an unregulated dummy tap to an unregulated D-Tap and was worried that I had fried the camera, but I didn’t.  It was long ago and I’d never made that error again, so this was a reflex action on my part.  The camera in fact had the correct dummy block in it, connected to the regulated side of my IDX V mount plate.

After that, I gave it a moment, flicked the power switch on the 5DM3 back to the "ON" position, and now I have no activity on the 5DM3, zero.

No activity on the display.

No activity on the Red flashing work light.

No activity on the LCD display. 

No mechanical noises at all.

The fixes I've tried:

So far I’ve tried the standard recommended fixes from the forums, such as removing the lens, battery, card, and then replace.

I’ve tried using freshly formatted cards, SD & CF.

I’ve tried all three of the autoexec.bin testers, Display, LED*, and ROM Dump.
*(Desperate. Though not meant for 5DM3, tried it anyway.)

I’ve tried formatted cards with the latest nightly build.

I've tried formatted cards processed through MacBoot.

Unfortunately, no success. 

After inserting the blank cards and switching on and off many times, I've re-checked the cards on my MacBook and I can see that there are no file directories available, that Canon’s cameras usually write to blank cards when inserted for the first time.

So as far as I can tell there is no electrical activity anywhere on this camera.

At this point, I think that this is just a hardware issue, but if anyone out there has had a similar experience, please share your thoughts or direction.

I’d hate to think it was something that I created buy abusing the on off switch while using ML, but I don’t think so.  ML is a pretty tough bit of code in my opinion and I don’t think it’s the root of the problem.

But I could be wrong, which is why I’m here.

The ML Firmware I was using is from the 08/18/17 nightly build, 2:13am.

Canon 5DM3 firmware 1.2.3

Thanks folks! Please share your thoughts!

Best to you all.  :D

MJ Walls


  • Administrator
  • Hero Member
  • *****
  • Posts: 12224
  • Maintenance mode
The first thing ML does when loading is turning on the LED.

Also, this autoexec, when placed on a bootable card, with the battery removed and placed it back, should start even with card door open and/or the power switch turned off (but it does require the battery door to be closed).

If the above did not give any sign of life, it's likely a hardware issue. Both of them will run from bootloader.

The error message you've got appears after taking the battery out without turning off the camera first (exception: the crop_rec_4k builds will allow that). Unlikely to cause issues - did that thousands of times. In this case, Canon code shuts down cleanly (but it's a rushed shutdown), and ML does not even notice the event. I'm not sure whether it properly closes files open for writing or not, so if you open the battery door in the middle of a write operation, you may end up with filesystem corruption or incomplete file.


  • New to the forum
  • *
  • Posts: 18
Good morning a1ex, thanks for the reply!

I think you are right, it's likely a hardware issue.  I gave the camera a brief round of fixes this morning with no success. 

I'll give the autoexec a go, and then start planning for hardware repairs.

The error flag on the LCD screen I'm pretty sure just showed up randomly, and no batteries were taken out at the time.  I just powered it down immediately for fear there was some power overload.  But now I think it was just a last electronic gasp before the hardware went South.

My research indicates it's probably the DC Power PCB board (hopefully)  Not an expensive part, but if  not, then the it's the Main Logic Board. 

Well thank you again A1ex (and the team) for the reply and the great software!  Keep up the great work!  I'll update the thread once I know more.

Best ~ MJ