Author Topic: 600D Audio TEST release - 2.3 based  (Read 172438 times)

Mister Paul

  • New to the forum
  • *
  • Posts: 46
Re: 600D Audio TEST release - 2.3 based
« Reply #225 on: September 17, 2012, 11:23:55 AM »
Sorry guys for my question as I can help your development only with PayPal…

I was going to buy a 600D but as there is no audio monitoring during recording I'd go back to 550D but your post gave me hope...
So... when do you think that a quite stable version could be released?
 ::)

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 600D Audio TEST release - 2.3 based
« Reply #226 on: September 17, 2012, 04:18:58 PM »
Probably will be merged for next version. A1ex is doing 5dIII stuff. Audio works pretty well. Miyake's bin is almost vanilla 2.3 + audio. If you have a 600D still you can try it.

klangdrang

  • New to the forum
  • *
  • Posts: 7
Re: 600D Audio TEST release - 2.3 based
« Reply #227 on: September 18, 2012, 05:56:25 PM »
Today I came back from a 4 weeks filming session for a documentary.I used the normal 2.3ML without the features you added because I had to be sure that everything works. In this time I had one day to test 0.5 Alpha release of ML for 600d with audio enabled and I really liked it.
Now after having my 4 weeks praxis test I really like to have one feature: controling the mic gain while recording. This feature is essential especially for documentaries. I can't set up my camera befor recording. Everything has to be set while filming. So what's about changing the gain with the wheel while pressing Q? Would be a great feature for the ML-600d-audio version.

miyake

  • Developer
  • Senior
  • *****
  • Posts: 396
Re: 600D Audio TEST release - 2.3 based
« Reply #228 on: September 18, 2012, 06:04:18 PM »
Now DISP shortcut key is controlling only analog gain. So you want to change mic boost like analog gain shortcut , right?
And it's enough?

I think , current shorcut key is controlling monitoring volume too. If I change shortcut vertical line to mic gain controlling, it's a enough for you?
Or , replace horizontal (analog gain) to mic gain control. Is it enough?

However, a lot of user using, sound functions. It's need a more considerations.

klangdrang

  • New to the forum
  • *
  • Posts: 7
Re: 600D Audio TEST release - 2.3 based
« Reply #229 on: September 18, 2012, 06:34:44 PM »
Oh I did not know that its possible to contol audio with the DISP-button. So This will work only with audio control by ML? Like I said, I used the "normal" 2.3 ML firmware with my 600d and there is no audio-support for 600d. I thought of controlling the canon manual audio control with magic lantern. but now I think I don't need it any more. (sorry: hard to describe, I am not a native english speaker)

miyake

  • Developer
  • Senior
  • *****
  • Posts: 396
Re: 600D Audio TEST release - 2.3 based
« Reply #230 on: September 18, 2012, 06:38:47 PM »
Never mid, I'm not native too.
Anyway, Try our 600D audio 0.11 version. And If you find bug or had a some advice to us, feel free to comment to this forum.

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 600D Audio TEST release - 2.3 based
« Reply #231 on: September 18, 2012, 07:08:17 PM »
I thought you could change everything on the fly from the menus.

miyake

  • Developer
  • Senior
  • *****
  • Posts: 396
Re: 600D Audio TEST release - 2.3 based
« Reply #232 on: September 20, 2012, 03:32:05 AM »
Merged all of our 600D audio codes to unified development tree!!!
Those codes are leave from our hand. Thankyou very much all testers. It's our developers/testers achievement.
But if you found some more problems, I can support you and if I found/solve bugs, I can push bug fix code to Alex.
Next release or improvement .bin will release from core team. 

juantrueno

  • New to the forum
  • *
  • Posts: 27
  • Mercenario AudioVisual
Re: 600D Audio TEST release - 2.3 based
« Reply #233 on: September 21, 2012, 01:23:24 AM »
Thanks @Miyake, @1%, and all developers for your effort! Working audio on 600D is amazing!
Thanks Thanks Thanks!
Canon 600D. Canon 18-135mm f 4/5.6 / 50mm f 1.8 / Yashica (Análogos) 28mm f 2.8 / 50mm f 1.4 / 135mm f 2.8
Vimeo.com/juantrueno youtube.com/juakinyan @JuanTrueno

jonnyschanny

  • New to the forum
  • *
  • Posts: 8
Re: 600D Audio TEST release - 2.3 based
« Reply #234 on: September 23, 2012, 07:28:48 AM »
Thanks a lot for all your work team!!!

sam dig

  • New to the forum
  • *
  • Posts: 5
Re: 600D Audio TEST release - 2.3 based
« Reply #235 on: September 24, 2012, 02:21:48 PM »
Hi, great news and thanks.
Is this functionality now merged into the main 2.3 download - if not any idea when, and what is the best way to download it currently?




nanomad

  • Administrator
  • Hero Member
  • *****
  • Posts: 2918
  • All your websites are belong to us
Re: 600D Audio TEST release - 2.3 based
« Reply #236 on: September 24, 2012, 05:39:24 PM »
The 2.3 is frozen. The functionality is included in the source repository so you'll have to compile it yourself
EOS 1100D | EOS 650 (No, I didn't forget the D) | Ye Olde Canon EF Lenses ('87): 50 f/1.8 - 28 f/2.8 - 70-210 f/4 | EF-S 18-55 f/3.5-5.6 | Metz 36 AF-5

lexa_one

  • New to the forum
  • *
  • Posts: 3
Re: 600D Audio TEST release - 2.3 based
« Reply #237 on: September 24, 2012, 06:32:58 PM »
Thanks a lot for this realy good work  ;D

Is it possible to  just have a 600D audio 0.12 version without the "test" message?
I really don't know how do it myself  :-\
Sorry for my English ^_^

Anton2707

  • Member
  • ***
  • Posts: 104
Re: 600D Audio TEST release - 2.3 based
« Reply #238 on: September 24, 2012, 09:31:47 PM »
Good work! Thank! Join request the release of version 0.12 of the test without a message about test.

scrax

  • Contributor
  • Hero Member
  • *****
  • Posts: 1543
  • Code monkey
Re: 600D Audio TEST release - 2.3 based
« Reply #239 on: September 24, 2012, 10:45:12 PM »
Test version are NOT released without the Test advice to avoid confusion with official release.
Only if you compile it by yourself you can edit makefile.user to remove it

I'm using ML2.3 for photography with:
EOS 600DML | EOS 400Dplus | EOS 5D MLbeta5- EF 100mm f/2.8 USM Macro  - EF-S 17-85mm f4-5.6 IS USM - EF 70-200mm f/4 L USM - 580EXII - OsX, PS, LR, RawTherapee, LightZone -no video experience-

Mister Paul

  • New to the forum
  • *
  • Posts: 46
Re: 600D Audio TEST release - 2.3 based
« Reply #240 on: September 24, 2012, 11:36:10 PM »
Hi,

first of all thank you very much for your great work. It's so helpful.

I tried it on my new 600D. Sorry but I can't compare as I don't have any 550D or other DSLR. And I am new to Magic Lantern too…

I have 2 points to mention:

1° As expected I get audio monitoring in my headphones during recording, but I don't get any sound in them during playback:
only the Canon speakers are playing the audio tracks even if my headphones are plugged (and recognized by ML)
Not sure if I have misunderstood something (I suppose!) or if that's a bug…

2° I am not sure to have best settings in ML for recording/monitoring for my Rode VideoMic Pro (output impedance = 200 Ohms)

- My Rode settings: +20db increased signal level + High Pass Filter on
- Magic Lantern settings:
Analog Volumes: 0db
Digital Gain: 0db
Output volume: 0db

In fact my settings are only controlled by using the button DISP. shortcut for analog gain (horizontal) to set "Input vol" at +15db or +24db
I see better modulation at 24db but I get some more hiss too (in my headphones but not recorded)…
Also I supposed that these settings should be seen after on menu "Analog Volumes" but it's still set to 0db

Do you think am I wrong in my way of managing the settings or I could get better results with another approach?

Thanks for your help
 ;)

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 600D Audio TEST release - 2.3 based
« Reply #241 on: September 24, 2012, 11:56:50 PM »
Playback isn't set up to work through headphones.

Quote
I see better modulation at 24db but I get some more hiss too (in my headphones but not recorded)

In my case the hiss seems recorded but I do think monitoring is off from recorded audio. I think that's a problem with the IC though. Thanks for testing.

lexa_one

  • New to the forum
  • *
  • Posts: 3
Re: 600D Audio TEST release - 2.3 based
« Reply #242 on: September 25, 2012, 01:37:16 AM »
Quote
Test version are NOT released without the Test advice to avoid confusion with official release.

Ok, Ok no problems to wait the official 2.4   8)
Sorry for my English ^_^

Mister Paul

  • New to the forum
  • *
  • Posts: 46
Re: 600D Audio TEST release - 2.3 based
« Reply #243 on: September 25, 2012, 10:51:31 AM »
Thanks.

But just to ask more precisely, do you think that it's better to adjust recording levels:
  - using DISP shortcut (step by 9db - jumps from 15 to 24db...)
  - "Analog Volumes" from ML Audio menu (step by 5db)
I suppose we interfere on the very same parameter (analog gain) with both, no?
 

Quote
Playback isn't set up to work through headphones.
Would be great to control taken shots!
;)

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 600D Audio TEST release - 2.3 based
« Reply #244 on: September 27, 2012, 05:41:59 AM »
Can't really play back the movies in camera, would be nice just for wav playback since I have them recording separately. Its like internal w/external channel swapping, nice but effort < result.

MAZ87

  • New to the forum
  • *
  • Posts: 2
Re: 600D Audio TEST release - 2.3 based
« Reply #245 on: September 28, 2012, 07:43:03 PM »
could it be that the download link isn't working.

i wanted to test the audio test version.

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 600D Audio TEST release - 2.3 based
« Reply #246 on: September 28, 2012, 07:52:58 PM »
Yea, its gone.

Until next ML release.

https://bitbucket.org/OtherOnePercent/tragic-lantern/downloads

But need to have card formatted to exfat.

MAZ87

  • New to the forum
  • *
  • Posts: 2
Re: 600D Audio TEST release - 2.3 based
« Reply #247 on: September 28, 2012, 08:06:27 PM »
sorry but i don't know which file i have to download for the last audio test release 0.11 or 0.12 ?

is there a official release date for next ml version?


thx maz

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 600D Audio TEST release - 2.3 based
« Reply #248 on: September 28, 2012, 08:19:28 PM »
The test releases are gone. You can either compile ML from source or use my binary. Sorry. :(

Mister Paul

  • New to the forum
  • *
  • Posts: 46
Re: 600D Audio TEST release - 2.3 based
« Reply #249 on: September 29, 2012, 06:47:59 PM »
I just found something weird... I don't know if that's related specially to the 600D Audio release or if it would have been the same with others Canon devices:
I was recording a movie with external mic + earphones: OK.
I took a photo during video shooting: OK.
But when video came back after the photo:
- 1° the sound was saturated (levels up in red),
- 2° No more audio monitoring (but the movie was still recording),
- 3° I had to shut down the Canon (On/Off or releasing battery) to be able to use ML or Canon menu again.

Effectively when I read the .mov after the sound level jumps high (saturation)