Author Topic: MLV App 1.13 - All in one MLV Video Post Processing App [Windows, Mac and Linux]  (Read 790390 times)

theBilalFakhouri

  • Developer
  • Hero Member
  • *****
  • Posts: 741
Small bug: MLVApp is crashing while using "HDR blending" option when "Export audio" is ON, this crash affects 1.12 and 1.13 versions, 1.11 version works fine . . disabling audio export solves the crash issue in the affected versions of MLVApp.

Tested on Windows, Apple ProRes 422 HQ codec, both MLVApp 64-bit and 32-bit are affected.
700D 1.1.5 | no more ISOless LV err 8 / SDR104 @ 240 MHz - Constant! | Fixed Scrambled LiveView in Higher resolution | Real-Time correct framing in the Way

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 1868
Thanks for reporting. Do you have a small MLV for reproducing that? No idea what's the difference between 1.11 and 1.12 - nothing changed for HDR blending. Just ffmpeg itself changed, but it always exports without audio anyway. Audio is added after video export. You could try 1.12/1.13 with the old ffmpeg.exe. (The latest codecs can't work this way.)
5D3.113 | EOSM.202

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7195
Maybe something easy like spacing in the mlv file causing the issue? Anyway. More info needed.

Icaab

  • New to the forum
  • *
  • Posts: 35
Hello. I came across a bug: No file appears when you export in any format. Export successfully ( Inscription - Export is ready), but I can’t find the output file (latest version mlvapp).


masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 1868
Hello. I came across a bug: No file appears when you export in any format. Export successfully ( Inscription - Export is ready), but I can’t find the output file (latest version mlvapp).
My bet: you deleted ffmpeg from MLVApp path. Otherwise more information needed.
5D3.113 | EOSM.202

bouncyball

  • Contributor
  • Hero Member
  • *****
  • Posts: 825
or... if on windows, you closed the terminal window before exporting finished.

Icaab

  • New to the forum
  • *
  • Posts: 35
My bet: you deleted ffmpeg from MLVApp path. Otherwise more information needed.
I did not close anything at the time of export and ffmpeg is present.

Took again mlvapp v13 and replaced the following files: ffmpeg , libraw.dll , MLVApp , pixel_maps , raw2mlv .
To no avail.

theBilalFakhouri

  • Developer
  • Hero Member
  • *****
  • Posts: 741
I suggest to download MLVApp 1.13 again, extract it in new empty folder, import your MLV clips and try exporting, does it work (do you have your exported clips)?

If not, what's your export settings? do you have a CMD running while exporting?
700D 1.1.5 | no more ISOless LV err 8 / SDR104 @ 240 MHz - Constant! | Fixed Scrambled LiveView in Higher resolution | Real-Time correct framing in the Way

Icaab

  • New to the forum
  • *
  • Posts: 35
I suggest to download MLVApp 1.13 again, extract it in new empty folder, import your MLV clips and try exporting, does it work (do you have your exported clips)?

If not, what's your export settings? do you have a CMD running while exporting?
I apologize: it turns out in my path the folder with the program contained a cyrillic. After the renaming everything worked as if nothing had happened.
Thank you :)

vastunghia

  • New to the forum
  • *
  • Posts: 17
  • 70D'er (and now 5D3'er!)
Re: MLV App 1.13 - All in one MLV Video Post Processing App [Windows, Mac and Linux]
« Reply #4735 on: September 06, 2021, 03:02:51 PM »
Hi,

I'm trying my first hand at Dual ISO MLV, and apparently the few short clips I took are not rendered correctly in MLV App.

I experience this weird behavior:
  • Upon import of MLV file, "Dual ISO" setting is Off so I see alternating ISO rows -- many of which have a strong magenta dominant (guess everything normal up to here?)
  • If I set "Dual ISO" to On, I obtain a messed up image that overall seems more dominated by cyan, with apparently 100% cyan areas spread all over the shadows
  • If I ask MLV App to playback the file, rendering now displays correctly, i.e. with natural colors
  • Even if I stop playback, the still frame looks ok
  • The same does not hold true if I switch "Dual ISO" to Preview: in this case too, playback is fine, but as soon as I stop it the still being displayed is corrupted (cyan all over the place)
  • Whatever export format I choose (ProRES or cDNG), it comes out wrong (once again, cyan mess).
I'm shooting with Danne's latest build for 5DM3, using the 3.3K 1:1 x5 preset (@14 bit).

First question: is this a common behavior / bug / (most likely) common mistake on my side? Or am I alone in this?

Thanks a lot for the help.

Sergio

theBilalFakhouri

  • Developer
  • Hero Member
  • *****
  • Posts: 741
Re: MLV App 1.13 - All in one MLV Video Post Processing App [Windows, Mac and Linux]
« Reply #4736 on: September 06, 2021, 04:28:54 PM »
@vastunghia

Turn OFF "Vertical Stripes" from "RAW Correction" tab and you should be fine, I noticed the same problem here, "Vertical Stripes" doesn't work properly in Dual ISO clips and it's ON by default for 5D3 clips.
700D 1.1.5 | no more ISOless LV err 8 / SDR104 @ 240 MHz - Constant! | Fixed Scrambled LiveView in Higher resolution | Real-Time correct framing in the Way

vastunghia

  • New to the forum
  • *
  • Posts: 17
  • 70D'er (and now 5D3'er!)
Re: MLV App 1.13 - All in one MLV Video Post Processing App [Windows, Mac and Linux]
« Reply #4737 on: September 06, 2021, 04:57:08 PM »
Thank you @theBilalFakhouri you made my day, I would never sort it out by myself!

S

Merlin ミーアキャット

  • New to the forum
  • *
  • Posts: 4
  • I love to improve Canon DSLR
Re: MLV App 1.13 - All in one MLV Video Post Processing App [Windows, Mac and Linux]
« Reply #4738 on: September 07, 2021, 08:32:26 AM »
Does that mean vertical stripes should be turned off? I thought in lower ISO situations it is better on?
Canon EOS 5D Mark III
Tamron SP VC USD DI 24-70mm 2.8f

Dmytro_ua

  • Member
  • ***
  • Posts: 228
  • Kyiv, Ukraine
Re: MLV App 1.13 - All in one MLV Video Post Processing App [Windows, Mac and Linux]
« Reply #4739 on: September 07, 2021, 02:35:32 PM »
Does MLV App work natively with new Silicon M1 or with Rosetta 2?
5d3 1.1.3 exp | Canon 16-35 4.0L | Canon 50 1.4 | Canon 100mm 2.8 macro
Ronin-S

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 1868
Re: MLV App 1.13 - All in one MLV Video Post Processing App [Windows, Mac and Linux]
« Reply #4740 on: September 17, 2021, 07:38:23 PM »
Does MLV App work natively with new Silicon M1 or with Rosetta 2?
Works with Rosetta2... but as I tested, very fast.
5D3.113 | EOSM.202

theBilalFakhouri

  • Developer
  • Hero Member
  • *****
  • Posts: 741
Re: MLV App 1.13 - All in one MLV Video Post Processing App [Windows, Mac and Linux]
« Reply #4741 on: September 17, 2021, 08:14:55 PM »
Does that mean vertical stripes should be turned off? I thought in lower ISO situations it is better on?

You should turn it off just when using Dual ISO otherwise Dual ISO clips won't be processed correctly, using vertical stripes in normal clips is fine.
700D 1.1.5 | no more ISOless LV err 8 / SDR104 @ 240 MHz - Constant! | Fixed Scrambled LiveView in Higher resolution | Real-Time correct framing in the Way

elenhil

  • New to the forum
  • *
  • Posts: 32
Re: MLV App 1.13 - All in one MLV Video Post Processing App [Windows, Mac and Linux]
« Reply #4742 on: September 21, 2021, 10:10:20 PM »
Any ideas why trying to enable vid.stab invariably produces a 0-sized file? I do try to exit is as a H.264 ffmpeg, as per instructions.

P.S. I mistyped '265' the first time.

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 1868
Re: MLV App 1.13 - All in one MLV Video Post Processing App [Windows, Mac and Linux]
« Reply #4743 on: September 21, 2021, 10:18:26 PM »
Any ideas why trying to enable vid.stab invariably produces a 0-sized file? I do try to exit is as a H.265 ffmpeg, as per instructions.
The instructions and the vid.stab-enable-checkbox tell, vid.stab only works for H.264. So when choosing anything else you should get a non stibilized video, but never a 0-size file.
5D3.113 | EOSM.202

dragonsfire1981

  • New to the forum
  • *
  • Posts: 12
Re: MLV App 1.13 - All in one MLV Video Post Processing App [Windows, Mac and Linux]
« Reply #4744 on: September 22, 2021, 01:06:22 AM »
I'm having this exact same problem with no files whatsoever appearing in my folders after exporting from MLV App to H264.

And before you ask, I have no folder in cyrillic or any other funny letters or symbols, and all the original installation files are present and correct in the MLV app folder, it just won't save the exported files at all. What's going on?

EDIT: I solved it after I figured out Avast antivirus was blocking the applications. I added exceptions to the MLV folder and all MLV .exe files. Woohoo!

My bet: you deleted ffmpeg from MLVApp path. Otherwise more information needed.

elenhil

  • New to the forum
  • *
  • Posts: 32
Re: MLV App 1.13 - All in one MLV Video Post Processing App [Windows, Mac and Linux]
« Reply #4745 on: September 22, 2021, 09:32:20 AM »
The instructions and the vid.stab-enable-checkbox tell, vid.stab only works for H.264. So when choosing anything else you should get a non stibilized video, but never a 0-size file.
Oops, a typo. I meant H.264, or course!

elenhil

  • New to the forum
  • *
  • Posts: 32
Re: MLV App 1.13 - All in one MLV Video Post Processing App [Windows, Mac and Linux]
« Reply #4746 on: September 22, 2021, 09:41:10 AM »
I'm having this exact same problem with no files whatsoever appearing in my folders after exporting from MLV App to H264.

And before you ask, I have no folder in cyrillic or any other funny letters or symbols, and all the original installation files are present and correct in the MLV app folder, it just won't save the exported files at all. What's going on?

EDIT: I solved it after I figured out Avast antivirus was blocking the applications. I added exceptions to the MLV folder and all MLV .exe files. Woohoo!
My problem was 0-size files, not no files whatsoever (which I did use to get with cyrillic paths), so it's not the same problem. Plus, I disabled my AV and the problem didn't go away.

And, just so we're clear, regular encoding without enabling vid.stab works OK.

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 1868
Re: MLV App 1.13 - All in one MLV Video Post Processing App [Windows, Mac and Linux]
« Reply #4747 on: September 22, 2021, 06:23:48 PM »
@elenhil: More information needed. Can't reproduce here - all works as expected for me.
5D3.113 | EOSM.202

elenhil

  • New to the forum
  • *
  • Posts: 32
Re: MLV App 1.13 - All in one MLV Video Post Processing App [Windows, Mac and Linux]
« Reply #4748 on: September 22, 2021, 06:32:49 PM »
@elenhil: More information needed. Can't reproduce here - all works as expected for me.
OK, what do I do? Is there a debug option for a complete readout of all the info you need?

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 1868
Re: MLV App 1.13 - All in one MLV Video Post Processing App [Windows, Mac and Linux]
« Reply #4749 on: September 22, 2021, 08:28:47 PM »
Start describing your system (OS+version, app version,...), all your settings (cam+App(receipt and export)), maybe upload the MLV file.
5D3.113 | EOSM.202