Canon T5i (700D) Firmware 1.1.5

Started by Javier.Munoz, June 26, 2017, 08:34:42 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hi, I bought a 700D (T5i). it comes with firmware 1.1.5 and the main builds of ML just exist to firmware 1.1.4

The option is download a port in progress to 1.1.5  :) but... there are many options ::)
┬┐which of the versions of the 1.1.5 is better?

Would it be an option to downgrade firmware from 1.1.5 to 1.1.4?  :o

I have searched 1.1.4 but I have not found it.
Does anyone have it?

:D   thanks!

Walter Schulz

Link to Canon firmware 1.1.4 included in Nightly Build download page for 700D.


Quote from: Javier.Munoz on June 26, 2017, 08:34:42 PM

Yes, that one from my bitbucket download area should work. Looking for testers--616 downloads and no issues reported.

If there is any demand I can make a new build with the latest unified changes.

You can also downgrade your camera firmware if you want to use the nightly and/or experimental builds.


hi, the only problem of ml with 1.1.5 and 700d is with eyefi card, sometime the dslr dont turn on and i need to remove the battery
but this is a minor problem, i would know if there are new builds of this version of ml


@rob73 - Don't know what would be causing the eyefi problem--you sure it is only happening with 1.1.5?

Posted an updated build in my bitbucket downloads page.

Incorporated the fix for the Autoexposure module and all the latest unified changes.


the problem is with 1.1.4 too
thank you for the upload


Plesse give detailed info about your Eye-Fi card.


eyefi mobi pro 32gb, sometimes the dslr dont turn on


Hi... is the current build of the T5i Firmware 1.1.5 safe to use now? I mainly use ML for video. Is it stable? MANY THANKS!


Quote from: Dmonroe on August 02, 2017, 07:51:49 AM
safe to use now?

It should be about as "safe" as a regular nightly build. There have been close to 1,000 downloads between the time I posted the first test build to now and the only problems reported are not specific to 1.1.5. However, if you want to play around with some other features like 10/12bit raw or the latest lua fixes, downgrade to 1.1.4 and head for the experiments page.



Well, I've tried to install latest ML for 700d 1.1.5. (magiclantern-Nightly.2017Jul02.700D115) and after required restart the camera did not start at all.
Same camera and cards used to work fine with FW 1.1.4.

Walter Schulz

Remove battery, remove card.
Insert battery, do not insert card.
Startup cam. Report results.


@DuduPonte -- Have you tried Walter's suggests yet? What you are experiencing is rather common and not something that is specific to the 1.1.5 firmware. When changing Canon firmware I've gotten into the habit of clearing out all of my custom settings, both the Canon and ML settings.


I hoped to play with a 700D for a week or two (wanted to give this a try, and maybe fix a few quirks), but looks like it's not going to happen this year. If the port works just as good as the 1.1.4, and dfort is also ready to update the new stubs from crop_rec_4k, I'd say let's merge it.


Quote from: a1ex on September 10, 2017, 08:38:34 PM
I hoped to play with a 700D for a week or two...

I'd be glad to send you my 700D to play for as long as you want.

Revisited the 700D.115 pull request, updated with the latest unified changes and confirmed that it is working great. However, I tried merging the crop_rec_4k branch and none of the good stuff works. No crop_rec, lossless compression, etc. It even freezes up without any modules active. Ugh!


Oops--not working so great. Turns out that I had a bad stub. Somehow the is_taskid_valid stub changed and it wreaked havoc with Full resolution  silent picture. Uploaded a new test build.

Still having problems after merging crop_rec_4k. Need some time to look into it.

at mlv_lite.c:753 (measure_compression_ratio), task shoot_task
lv:1 mode:3

shoot_task stack: 1c5cf8 [1c5e20-1c3e20]
0x000CCF58 @ ac67c:1c5dc0
0xUNKNOWN  @ ccfb0:1c5da8
0x00AB5540 @ ab8dfc:1c5d38
0x0007F620 @ ab5738:1c5d28
0x0007EF68 @ 7f680:1c5cf8

Magic Lantern version : Nightly.2017Sep11.700D115
Mercurial changeset   : 45b5dd1a852e+93e177a2b6e9+ (crop_rec_4k_700D_115) tip
Built on 2017-09-12 04:42:03 UTC by rosiefort@RosieFoComputer.
Free Memory  : 126K + 2523K


So the problem turned out to be more a matter of not making sure all the modules were updated from 700D.114 to 700D.115. I got this working as well as the current 1.1.4 builds which means that unified is pretty much stable and the experimental branches need some more work but it doesn't have anything to do with the Canon firmware update. I'll do some more testing to see if battery drain and other reported issues are reproducible.

One scary moment came when the camera crashed when recording 9-bit lossless and did a core dump.

[100] raw_rec_task: NULL PTR (80c3e100,e1a00000)
pc=    c288 lr=    c288 stack=1ac1d8+0x1000
e1a00000 e59ff014 e59ff014 e59ff014
e59ff014 e1a00000 e59ff010 e59ff010

Magic Lantern version : Nightly.2017Sep13.700D115
Mercurial changeset   : 65aede073360+ (crop_rec_4k_700D_115)
Built on 2017-09-13 18:24:04 UTC by rosiefort@RosieFoComputer.
Free Memory  : 126K + 2505K


Spent the day doing stress tests and found no differences in performance or issues between the 700D.115 and 700D.114. CPU usage is the same so there shouldn't be any added battery drain. I also got it working with the crop_rec_4k branch and it behaves the same--hint, notice that there isn't a build for the 700D.114 in the Experiments download page?

So without further ado, here's a 700D.115 pull request for the crop_rec_4k branch:

Note my prior post about crashing with lossless compressed mlv_lite recording but if you like living on the bleeding edge... I recorded a 5 minute clip using 12bit lossless and all was fine until I started waving the camera around like crazy. Yeah, it crashed but the clip was saved and no frames were lost--it even continued recording after the crash!

One more issue worth noting is that it won't save lossless compressed full resolution silent pictures.

I should emphasis that these issues also apply to 700D.114.

Walter Schulz

Just saw 700D.115 got merged into unified and nightly build has been built about 100 minutes ago, links updated, etc. Congrats and thanks for your work, dfort (and of course to a1ex, too)!

andy kh

5D Mark III - 70D