FIXED: T3i upgraded to Firmware 102 (for ML 2.3.5 install) WILL NOT BOOT

Started by upthinklab, August 10, 2012, 07:36:14 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


After installing the Canon firmware 102 (per ML directions) to allow the install of ML v2.3.5, the camera will no longer boot with a SD card installed. If I remove the card, it will boot just fine and I can confirm the 102 firmware is properly installed. However, whenever a SD card is inserted, it will not boot and flashes the red light. Removing the battery resets, but the problem continues. I have tried with 5 different SD cards, so the SD doesn't seem to be the problem.

Has anyone else experienced this? I was excited to try the new v2.3.5 for the Perseid show this weekend, but now it feels like my T3i is bricked.



Update: The problem was that the SD card was not properly reformatted (i.e. using Disk Utility). Upon a proper format using OSX, everything is working again. What a relief. ;-)

Apologies if I scared anyone.


It's always good that you let us (others) know you solved problem and how.  Thanks.
T3i and Kiss X4 (550d (T2i)) Tamron 18-200mm, Sigma 28-70mm f2.8 (need firmware upgrade) Olympus 50mm f1.8  Olympus 28mm f2.8 and Olympus 24mm f2.8
Fancier 370 tripod and LCD hinged loupe. DIY Slider and crane.


To me that seems not a Volume problem, instead looks like your card was made bootable but without an autoexec.bin on it to boot, formatting it solved the problem because your card was not any more bootable.

I don't know, where you found ML 2.3.5?

In future (and alsop in general) is really better to format card on camera to avoid problems.
I've never ever used DiskUtility to format EOS card (a part for having them ExFAT for g3gg0's test,).
I'm using ML2.3 for photography with:
EOS 600DML | EOS 400Dplus | EOS 5D MLbeta5- EF 100mm f/2.8 USM Macro  - EF-S 17-85mm f4-5.6 IS USM - EF 70-200mm f/4 L USM - 580EXII - OsX, PS, LR, RawTherapee, LightZone -no video experience-