Joystick gets stuck when in live view

Started by duckied, June 24, 2017, 05:28:42 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


First of all, I do apologize if this question was already asked but I can't find it in the q&a or forum search.

I recently installed ML on my 5d mk2. Everything seems to be working fine, but whenever I'm in live view and using the joystick to pan around, it would get stuck and will continue moving till it hits the edge. I figured maybe it was a setting but I tried playing around with it with no luck. I thought maybe my joystick was broken, but when I load up a non ML card the problems goes away. I even tried a different card with the newest nightly build today with no luck. Is it suppose to work like that? Is there a way to disable this?

Any help would greatly appreciated



Video of the issue? Does the joystick misbehave in other cases, such as when navigating the ML menu?

Can other 5D2 users confirm?


Same thing happens in my 5D2 since day 1 with ML. It just happens to me in LiveView when I use the joystick to move the focus square. It gets stuck, the focus square keeps moving until the end of the frame and then, after a couple of clicks in the opposite direction or waiting a couple of seconds, works normally again.

It happened with all ML versions I run in the 5D2.


Does the issue happen with the oldest build from here?
Does the issue happen with the old v2.3?

Does it help if you turn off Global Draw?

Does it help if you set focus box speed to normal?

If the first answer is "no", please try newer builds to narrow it down.

If the first answer is "yes" and the second answer is "no", please run "hg bisect" to find the first bad changeset.


After going crazy trying to figure this problem out last night, I was able to pinpoint the cause of this problem. There's a bug (if not made intentional) with Bulb ND Utilities module. It was causing the auto focus box to keep on panning till it hits the edge and the problem persist even after going back to the menu. I will report this problem to the ND Utilities thread.

Hopefully this helps out anyone else that runs into this problem.


No problems here , just check on my 5d2 in 1:1 liveview (movie mode) even in 3x crop I can move the window around with Joy stick
and centers itself when pushed straight down , does not move after I release the joystick. Did you maybe have digital dolly enabled ?

Edit: What are your camera setting ? build date?