Author Topic: Global Draw disabled when recording, no cropmarks, no zebra, no focus peak  (Read 2369 times)


  • Just arrived
  • *
  • Posts: 1
I've searched high and low on this forum to try and find the right UI setting to get this to work.

I've recently installed ML on my T5i and here's my issue.

I have focus peak on, zebra on (show while filming), and cropmarks on. Global Draw is ON, all modes.

When I hit the record button, everything disappears. I tried pressing the info button several times (nothing). While recording i've gone into the ML menu and focus peak+zebra+cropmarks is greyed out and the orange text on the bottom says "Global Draw is disabled, check your settings" 

So I do... and while still recording, I scroll over to global draw in the overlay menu and it's ON,all modes.

is this a glitch?

Am I doing something wrong?

When I tried to find a solution in the forums people kept saying " go to global draw and read the help text". Where is that? no one links to it. It's not in the magic lantern file I downloaded and it's not on my camera.

I hope someone can help with this. I'm only 3 hours into using the firmware and am feeling a bit disappointed.

Hoping someone can help