Firmware Update/Downdate?

Started by dfort, February 11, 2017, 02:58:02 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


How to do a Canon firmware downgrade
(works for upgrade too)
Except for 5D3 1.3.6 Only Canon has been able to downgrade one 1.3.6 is installed though not all service centers are willing to do it.
(Note that I have started a port for 5D3.136 but could not get it running--yet.)

There seems to be a lot of FUD (Fear Uncertainty and Doubt) about changing the firmware on your camera, especially for uninitiated Magic Lantern users who are pointed to a website in Hungary run a guy who goes by the name of Pelican to get older firmware versions. Nothing against Hungary (I'm half-Hungarian) or Pelicans (I live at the beach) but a little anxiety is understandable.

Once you realize that it is extremely unlikely that someone created a FIR file that will cause your camera to send banking information to international cyber terrorists, download the file onto an SD card.

Firmware updates are generally posted in some sort of compressed format often along with the instructions on how to run the firmware update. If you are on a Mac and can only find a Windows version, don't panic. The *.FIR file runs on the camera so it doesn't matter which computer platform you are using. Of course you might download something that looks like this on your Mac:

Again, don't panic. This is a self extracting Windows archive and you can use Stuffit Expander which is in the Applications/Utilities folder of every Mac to expand the archive file.

I've got several cameras and like to play around with different versions of Magic Lantern so I put all of my FIR files on a single card. Make sure that the card doesn't have the boot flag enabled because if your camera also has the boot flag enabled it will just hang when you start up the camera unless you also add a ML autoexec.bin file and then it won't work on multiple platforms. In other words, this will be your dedicated firmware card.

Those CCF14* firmware files are for the 700D/T5i, yeah I know it isn't obvious. And just in case you're thinking it, no the 5D3 firmware won't install on the EOSM. Only the valid choices will show up.

Now when you run the firmware update from the Canon menu using this card, remembering to have the camera in Manual and Still Picture mode, it will run the firmware update process--even if you are doing a firmware downdate. (Is there such a word?) The firmware update will not run if you don't have enough juice left in the battery and some external power adapters supply barely enough voltage to run the camera so it might not work. Best be safe and top off your battery first.

End of tutorial.


Firmware versions in the x.3.x series (currently only affecting 5D3) won't let you downgrade to a prior series. In other words, you can go from 1.3.4 to 1.3.3 but if there is a 1.2.3 or a 1.1.3 firmware on your card you'll get this message:

It is not quite that easy with some of the latest Canon firmware updates. There are warnings about not being able to downgrade and rumors that you need some older 2.x version of Canon EOS Utility to do the downgrade but I found that is not really the case. If you happen to have one of those irrevocable firmware versions on your camera you can use whatever version of EOS Utility you have. Make sure to put a copy of the FIR file on your computer because you'll have to point to it with EOS Utility. Also make sure your camera is in Manual and Still Picture mode or EOS Utility will refuse to do the firmware update.

HA! Just noticed that "WTF Captions" item. Who says Canon engineers don't have a sense of humor?

Ok--back to doing this. You need to have a card in your camera so let's use that dedicated SD card with all the various versions. Here we go:

Hey, what just happened? EOS Utility just transferred the firmware update from your computer onto the card in your camera and you can now disconnect the USB cable. The rest is exactly the same as before. In fact if you have multiple firmware versions on your card you can now have a second chance to decide which version you want to install.

Interestingly the firmware update will not change the status of the camera boot flag so you won't have to re-install ML. If you are curious what a new firmware version looks like, use the Portable ROM dumper and run the ROM1.BIN file through a disassembler and...I'm getting off topic here, porting a firmware update to ML is another tutorial.


Whilst the opposite of 'upgrade' is 'downgrade' I think the opposite of 'update' would be 'rollback' or would it be 'outdate'. :P


Here's an idea that is way beyond my reach but maybe possible--

How about making the 5D3.134 ML-SETUP.FIR able to live on the same card as the Canon FIR files and set it up so that the ML FIR loads first, checks to see if there are Canon FIR files on the card and give you the option to either install ML or perform a firmware update (or downdate/downgrade/rollback/outdate). Of course if it leaves the boot flag on the camera set after the update you'll get a message that the camera doesn't look like a 5D.134 but maybe the camera boot flag could be turned off before running the Canon file?

The only real reason that EOS Utility is necessary is to initiate the process. If the 5D30113.FIR and/or 5D30123.FIR is already on the card there's no need to copy it over USB.

Don't know if any of this is possible but it seems that maybe it is.

(This also assumes that the 5D3.134 ML port will someday be working.)

Walter Schulz

Thanks for pointing out EOS Utility v3.x is doing the job, too. (I asked about 2 years ago ...)

- "How to" for Mac users baffled by download file names indicating those files are for Windows only.
- The tutorial is useable for all cams but AFAIK only 5D3 users with firmware 1.3.3 or higher are forced to use EOS Utility. Other cams will do fine with in-cam downgrade.

If card for firmware update is formated inside cam with Q-key pressed "Format card, remove ML [Q]" card will get non-bootable and there will be no problem with cam's bootflag.
Same for formatting the card using a cardreader.


So looks like I'll update to M 2.0.3 after all :)


Good points Walter. I took your suggestions and made some changes to the original post.

I suppose that most users won't be going up/down all that often except for maybe those wanting to go between 5D3.113 and 5D3.123 to get the HDMI output feature of 123 or the better performance and fewer bugs of 113. I'm messing around with trying to get a version working for 5D3.134 for those users who takes Canon's advice to always use their latest firmware and feel a little nervous rolling back in order to try out ML.

Speaking of the latest:

Quote from: Licaon_Kter on February 12, 2017, 06:29:25 PM
So looks like I'll update to M 2.0.3 after all :)

It is a very minor update and I haven't found any new bugs, though the old bugs are still there. Approve the pull request, give it a thumbs up, smiley face, whatever to show that it is working for you. Shameless plug, I've also got a ML firmware update for the 700D. A minor firmware update isn't really very difficult to do--I can't code myself out of a paper bag and was able to do it.


hello, canon 5d mark 3 i am using.
software version 1.3.5, canon utulity program can not load the software. options not active


Everyones so hasty to post link  , However, Im a 5D3 user of ML for a few years. mistakenly updated to 1.3.5, and after numerous attempts, im also unable to downgrade to 113 or 123.
I think there might be other pertinent steps not being covered, or some such issue. Some of us are still having issues. my version of eos utility will not repair either.
Any more suggestions

Walter Schulz
If you have problems with your EOS Utiility version it will make sense to
- mention Utility version number
- describe the problem in detail
- and the steps you have taken to make it work
Without these informations we are unable to reproduce your problem and only guessing what might have gone wrong.

I suggest to swicht cam to photo (stills) mode and mode dial M. Retry and give feedback


I'm considering purchasing 5D mkIII and installing ML. Did anyone successfully roll back firmware v1.3.5 to v1.2.3? Should I stay away from 5DmkIII running on FW 1.3.5?


Yes, I successfully rolled back from 1.3.5 to 1.2.3 and to and from several other versions. Make sure to reset your Canon settings to factory defaults after changing the firmware. It might not be necessary but it did seem to help when I was running some tests a while back.


Quote from: dfort on November 18, 2018, 06:34:54 AM
Yes, I successfully rolled back from 1.3.5 to 1.2.3 and to and from several other versions...
Excellent! Thanks a lot for confirmation.


The top post is missing pictures.
once you go raw you never go back


You are right.

Sorry about that, must be some privacy setting of mine.
once you go raw you never go back


Speaking of permissions--looks like some posts are being flagged as SPAM so I missed some cries for help from a user who wanted to downgrade from 5D3.135. Basically, you need to do this via Canon EOS Utility. If the option isn't available the camera might be in Movie mode or some other mode where it doesn't allow the firmware updater to run. Put the camera in still photo, manual mode.

[email protected]

I am somewhat baffled. I own a 550D and having been running ML under firmware 109 successfully for years.  Foolishly I up dated to version 110 only to find that I am now blocked from going back, downgrading. and can not run Ml any more using 109, I am even unable to run ML on an old card correctly set up.

Can some one please tell me if it is possible to downgrade and how to do it.  I am not a computer buff/geek but can follow simple instructions.
Tim Email [email protected]

Walter Schulz

Use a spare card, format in cardreader, format in cam after and use it to downgrade.
5D3 is the only ML enabled cam affected by issue described by dfort.


If you put both the 1.0.9 and 1.1.0 Canon firmware updaters on the same card you should be able to easily update/downdate your 550D. Note that you can get the 550D.109 Canon firmware updater from either Pelican's archive or if you are nervous about getting this from a website in Hungary I also archived several updates on my Bitbucket downloads page -- though full disclosure, I'm half-Hungarian. Look for the file named "550D Canon Firmware for"

Feel free to also test drive my 550D.110 port, also on the downloads page and report your findings on the pull request.



i did a smart thing. I installed version 1.3.6 and now i can even downdate anything if i try with the Utility there is no reaktion on the Camera/Screen. can someone help me ?

I think they dont wont me to downgrade anymore!!  :'( :'( :'( :'(

Walter Schulz

Remove battery, remove card.
Format card using cardreader. Format again in cam.
Insert battery and cam. Connect USB and startup EOS Utility according to instruction given above.
Retry downgrade and report back.

See a1ex' reply below.


Quote from: Infinitymotion on September 26, 2019, 01:30:25 AM

i did a smart thing. I installed version 1.3.6 and now i can even downdate anything if i try with the Utility there is no reaktion on the Camera/Screen. can someone help me ?

I think they dont wont me to downgrade anymore!!  :'( :'( :'( :'(

Same problem here. I tried everything with no luck.
EOS T2i & EOS 5D Mark III
Lens Canon EF-S 18-55 f/3,5-5,6; Canon EF 50 f/1,8; Cosina 28-210 f/3,5-5,6; Canon EF 75-300 f/4-5,6; Canon EF-S 10-22 f/3,5-4,5; Samyang 14 f/2,8; Tamron SP 24-70 f/2,8; Canon EF 100-400 f/4.5-5.6L II

Walter Schulz

If both your cams won't work with EOSUtility at all feel free to contact Canon support.
See a1ex' reply.


Quote from: raghavadhithya on September 28, 2019, 05:43:46 PM
upon clicking next, the camera shows blank screen, and on the computer it shows "Press SET button to continue installing the firmware"

Quote from: srsa on September 28, 2019, 08:09:47 PM
I believe that's a feature of the latest (1.3.6) firmware. It was introduced in response to this recently published "Missing authorization vulnerability". I would imagine most of the camera's buttons are blocked when an USB connection is active. Don't know whether removing the cable would allow dismissing that dialog, or cause some sort of problem.

Quote from: a1ex on September 28, 2019, 09:58:41 PM
Confirmed. The firmware update can no longer be started from EOS Utility (tested with 2.14.1, but not expecting any surprises with newer versions). I can create a tool that would allow downgrading, but this would require effectively porting ML to 1.3.6 (i.e. time-consuming, but doable, and not necessarily by me).

If dfort is still around, or anyone else is willing to find the stubs and other constants for 1.3.6, I can find some time in the coming weeks in order to provide a firmware downgrading tool.

FWIW, my 5D3 is now running 1.3.6, with boot flag enabled, but without ML. Portable ROM dumper worked out of the box. My main camera (well, 2-3 pictures per month or less) is currently the 5D2, so I don't have any direct motivation to sit down and upgrade ML to latest firmware; sorry about that.


I'm still around, though with too many projects going at the same time. I almost had 1.3.4 working properly on the 5D3 then 1.3.5 came along and I ran into some issues. Now it looks like 1.3.6 is a one way update. Not sure I want to go there but I'd be glad to help out with some stub hunting.