Author Topic: Canon 7D not working after crash [Bricked?]  (Read 1293 times)

leeg5168

  • Just arrived
  • *
  • Posts: 1
Canon 7D not working after crash [Bricked?]
« on: November 28, 2016, 09:36:00 PM »
Hi everyone, I'm having a bit of trouble with my 7D:

Yesterday I was shooting some video with ML and part way through one of the recordings the camera locked up and a crash message was displayed on screen saying that a crash log had been written to the CF card (which it had). I removed the battery as the camera would not power off using the switch, waited a couple of minutes and then re-inserted the battery but it would not power back up. I assumed the battery was dead so I tried two more fully charged batteries but still no signs of life. I took the battery out and left the 7D over night then tried again this morning to no avail.

I have browsed the forums this afternoon and tried out other peoples suggestions (removing card, lens, clock battery, booting in other modes etc), and also tried the autoexec.bin diagnostic tools (screen, LED blink) on a fresh CF card but there are still no signs of life. The only flicker of hope I have at the moment is the front LED sometimes flashes for a brief moment when inserting the battery.

I have pasted the log file below from the card if theres anything in it that could help.

Code: [Select]
ASSERT: FALSE
at SoundDevice\SoundDevice_CODEC.c:1149, task ASIF
lv:1 mode:3


Magic Lantern version : Nightly.2016Oct09.7D203
Mercurial changeset   : 15fce5b49b23 (unified) tip
Built on 2016-10-09 10:24:35 UTC by [email protected]
Free Memory  : 261K + 2711K

Any advice would be much appreciated.

Thanks in advance,
Gary