Author Topic: Battery Grip + 5d3 1.1.3 + ML Problems  (Read 2467 times)


  • New to the forum
  • *
  • Posts: 5
Battery Grip + 5d3 1.1.3 + ML Problems
« on: August 28, 2016, 05:47:19 PM »
Hi all,

I have been encountering an issue while using my ML-equipped 5Dmk3 with a battery grip.

When I first began using the grip, I believe I was using either the January 14 or the April 1, 2016 build of ML. No problems.

When I installed the "experimental" 3x RAW crop firmware from Apr 2, the battery grip stopped working. The camera would not turn on. No indicator light of a battery being installed (red flash in lower right corner) I just figured the grip was broken until I got the idea that the firmware build may the problem. I rolled back to the last working version I had (see above) and the grip worked again!

The grip adds weight obviously so I have had it off for the last few shoots. I last updated to the July 9 build, and today when I tried to use the grip again, the camera would not power on!

I rolled back again, one firmware - nothing - and kept rolling back until I got to the January 14, 2016 build again. Not working. So I said to hell with the grip, re-updated to July 9 (fresh install, ML went through a mini-boot to install settings etc., had to re-do my modified settings) and went back to single battery use. Everything was fine.
Then I thought I would try the grip again. It worked! As soon as I removed it though, and tried to put it back on to make sure it would work, the camera would not power on again.

It's almost as if I need to reset ML and its settings to get the grip to work. It's very frustrating. Has anyone else had this problem? Is it a bug in ML?