Author Topic: 600D, Error 70 Brick.  (Read 1825 times)

Zifk

  • New to the forum
  • *
  • Posts: 1
600D, Error 70 Brick.
« on: August 14, 2016, 09:14:14 PM »
Hi, I'm currently on a trip, and after a few days of shooting in rather damp conditions, my 600D will not get passed the Error 70 screen. I've tried all the basic fixes, like booting without the SD card, changing lenses/battery, booting in every mode, but nothing is working.

It still passes the display test, and I can get an error log and rom dump:

Code: [Select]
ASSERT: FALSE
at DevelopCombination.c:108, task RscMgr
lv:0 mode:0
Magic Lantern version : Nightly.2016Jul09.600D102
Mercurial changeset   : 831978df7df9 (unified) tip
Built on 2016-07-09 01:00:03 UTC by jenkins@magiclantern.fm.
Free Memory  : 253K + 1126K
Sun Aug 14 15:10:48 2016
     0:     9.236 [STARTUP]
K286 ICU Firmware Version 1.0.2 ( 3.8.3 )
     1:     9.298 [STARTUP]
ICU Release DateTime 2011.11.25 11:00:17
     2:    11.207 [SEQ] seqEventDispatch (Startup, 0)
     3:    11.238 [STARTUP] startupEntry
     4:   112.890 [STARTUP] startupPropAdminMain : End
     5:   113.012 [SEQ] seqEventDispatch (Startup, 1)
     6:   113.042 [STARTUP] startupPrepareProperty
     7:   116.234 [SEQ] seqEventDispatch (Startup, 2)
     8:   116.844 [RSC] hMemoryQueue (0x620010) hStorageQueue (0x640012)
     9:   123.715 [RSC] ERROR SetDevelopImageCondition DevelopCombination.c 107
    10:   124.717 [RTC] !! RTC CHECK ERROR !!

    11:   129.134 [JOB] InitializeJobClass (ID = 17377, Num = 16)
    12:   131.092 [STARTUP] ERROR ASSERT : DevelopCombination.c, Task = RscMgr
    13:   131.182 [STARTUP] ERROR ASSERT : Line 108
    14:   131.231 [STARTUP] ERROR ASSERT : FALSE
    15:   131.319 [STARTUP] ASSERT : Time 1899/12/31 0:0:0
    16:   132.951 [STARTUP] startupErrorRequestChangeCBR (0x1d)
    17:   133.067 [STARTUP] startupErrorRequestChangeCBR : ErrorSend (101, ABORT)
    18:   133.477 [CERES]  RegisterGPSInfoCallback
    19:   134.152 [EM] emLockControl (TYPE_JOBSTATE = 0x0)
    20:   135.368 [JOB] InitializeInnerDevelopJobClass (ID = 17377, Num = 16)
    21:   135.437 [JOB] InitializeMultipleExposureSaveAndEndJobClass ( Num = 10 )
    22:   137.283 [SND] Seq LPC fin
    23:   141.502 [ENG] [ENGIO](Addr:0x4fb40000, Data:0x   30000)
    24:   148.275 [FM] FM_RegisterSpaceNotifyCallback
    25:   148.459 [FM] FM_RegisterSpaceNotifyCallback
    26:   153.607 [SHTP] spsInit
    27:   163.075 [TERMINATE] SHUTDOWN init comp
    28:   163.239 [TERMINATE] Abort init comp
    29:   163.609 [WFT]  PROP_WFT_IMAGE_TRANS (1)
    30:   166.179 [MC] PROP_GUI_STATE 0
    31:   166.722 [MC] JobState 0
    32:   168.650 [MC] PROP_LCD_OFFON_BUTTON : 0
    33:   169.073 [MC] PROP_VARIANGLE_GUICTRL : Enable
    34:   169.508 [MC] regist master CardCover
    35:   174.123 [MC] Disp Error : 70
    36:   174.557 [WFT]  tomSetRawJpgMode (Type = 0x4)

Rom Dump: https://drive.google.com/open?id=0Bw-peOXjn9OJS2ZQU3hYdVdnVEE

As far as I can tell, the next step is to use a modified autoexec.bin to bypass the assert check and reset all the settings. I realize this is slightly dangerous, but at this point I've already accepted that the camera might be doomed. The problem is that with my current setup, I can't compile this on my own, so I would greatly appreciate it if anyone can share the proper file with me (rydgel.code@gmail.com).

Any other help would be greatly appreciated, thanks!