Author Topic: Lua.mo: Canon settings not saved with camera.reboot  (Read 2737 times)

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 6700
Lua.mo: Canon settings not saved with camera.reboot
« on: April 03, 2016, 11:50:29 AM »
Hi, Dan and Gerry!

Description:
Using "camera.reboot" cam settings will not be saved under certain circumstances.
Reproduced in 7D and 650D. April, 1st build + tonights Lua.mo

How to reproduce:
Photo mode M.
Open Canon settings screen by pressing Q button.
Select WB settings and change using wheel.
Now press Half Shutter to exit.
Open ML screen by pressing trashcan button.
Run Lua script with "camera.reboot".

After reboot open Canon settings and check WB setting: Change undone.

Workaround:
After changing WB exit screen by pressing Q.
-> Setting persistent after "camera.reboot".

Script used:
Reb_Modu.lua
Code: [Select]
-- Unsophisticated reboot (Modules)

function main()
    camera.reboot()
end

keymenu = menu.new
{
    parent = "Modules",
    name = "Reboot",
    help = "Reboots cam. Will not ask for confirmation!",
    select = function(this) task.create(main) end,
}

WB is not the only setting affected. But it is one of the settings reproducable on both cams.

How to prevent this? Which function/command will force settings to be stored before "camera.reboot"?
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12198
  • Maintenance mode
Re: Lua.mo: Canon settings not saved with camera.reboot
« Reply #1 on: May 05, 2016, 09:07:01 AM »
Happens on 5D3 as well.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5334
Re: Lua.mo: Canon settings not saved with camera.reboot
« Reply #2 on: June 06, 2018, 09:30:53 AM »
Cool script @Walter(a little late here to the lua fiesta...)