Author Topic: Cant downgrade my Firmware on my Canon 5d Mark III  (Read 1527 times)

erikdman

  • New to the forum
  • *
  • Posts: 2
Cant downgrade my Firmware on my Canon 5d Mark III
« on: March 16, 2016, 10:15:15 PM »
Hey guys,
I tried to downgrade my Firmware from 1.3.3 to 1.2.3 in much different ways...
It didnt work. My Camera says: This Firmware Version is too old (older than 1.3.0)
So is there another way to downgrade successfully?
I tried it over eos utility too but the Firmware butten is greyout...
I hope you have an Anwer :(

Erik


GutterPump

  • Member
  • ***
  • Posts: 180
  • 5DIII/5DII/550D
Re: Cant downgrade my Firmware on my Canon 5d Mark III
« Reply #1 on: March 17, 2016, 10:09:21 AM »
Hello,

You should try with Eos Utility v2.xx, not over the v2.
for me it work  with the 2.14

http://support-th.canon-asia.com/contents/TH/EN/0200388402.html

erikdman

  • New to the forum
  • *
  • Posts: 2
Re: Cant downgrade my Firmware on my Canon 5d Mark III
« Reply #2 on: April 10, 2016, 12:18:08 PM »
I tried but i need a cd to install this version...

edit: 
aaah. It worked.
Thanks a lot.

Erik