Author Topic: M42 lens mount with focus confirmation chip  (Read 3925 times)

extremelypoorfilmaker

  • Senior
  • ****
  • Posts: 255
M42 lens mount with focus confirmation chip
« on: December 11, 2015, 10:42:55 PM »
Hi guys, not to sure this is the right section of the forum to post this, but I will go ahead anyway. Hopefully one of the "big guys" will pick it up.

In short, I recently bought this:

http://www.amazon.co.uk/dp/B008H2I1M2/ref=pd_luc_rh_bxgy_01_01_t_img_lh?_encoding=UTF8&psc=1

It is an M42 to EF adapter with AF confirmation chip. Sold by Xsource on Amazon UK, made by don't know who.

In short: It does not work well with ML 5D3 1.2.3 August 2014 version.

This is what happened: (just 5 mins ago by the date of this post)

Camera off,
adapter and lens mounted
LED blinking weirdly
Turn camera on: Failed firmware update screenshot.

Panicking and cold sweat (have a shoot sunday the 13th)

taking battery out
wait 10 sec
put battery back in
camera on
all normal.

That's good!

Camera on
Removing lens
putting the same adapter with AFchip on
As soon as it is in place, Error message.

Mini heart attack

Remove battery
Wait 10 sec.
Turn camera back on
All normal.

Apparently, it does not seem to fuck your camera up, BUT IT DEFINITELY messes with Magic Lantern / (canon firmware?).

I am very sorry not to have recorded or memorized the error message i received or how many time he LED blinked when I putted it in the first time. But the fear of losing my 5D3 just took over and the only thing I was focused on was to get the battery out ASAP.

I am doubly sorry not to be able to replicate this test because I scraped the chip out of the adapter straight away out of pure fear. Hopefully, this event has been documented before. If not, I hope this post will help future people looking to buy AF confirmation third party adapters.

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8339
Re: M42 lens mount with focus confirmation chip
« Reply #1 on: December 11, 2015, 10:55:56 PM »
The one I own doesn't work with 650D but with 7D. 650D gives firmware update error every time after power on. And it doesn't matter if ML is installed or not. Yes, error will come up after clean ML deinstallation, too.

So: Your 5D3 is not listed as a compatible device. Makes one think ...

extremelypoorfilmaker

  • Senior
  • ****
  • Posts: 255
Re: M42 lens mount with focus confirmation chip
« Reply #2 on: December 12, 2015, 09:12:50 PM »
Makes one think that I am a fast buying Idiot..

sorry. Probably better delete this post.. I would do it, but I "do not have the powers" :)