Author Topic: EOS M srewed up (doesn't seem bricked however)  (Read 23605 times)

Ernani

  • New to the forum
  • *
  • Posts: 37
EOS M srewed up (doesn't seem bricked however)
« on: November 27, 2015, 01:49:08 AM »
Hi all. for a week I haven't been able to properly boot my EOS M.
I have a feeling that I screwed it up by removing the card too soon a few times (should have paid more attention to the warnings before. oops)
so, when I try to turn it on with an ML card the LED starts blinking rapidly in red indefinitely. the only thing that can be done is either press off (which makes the LED turn solid red indefinitely) or remove the battery.

When I try to turn the camera on without the ML card the LED again rapidly blinks indefinitely, only this time in green.

Funny enough, I still manage to boot the camera up after some 5 or 10 minutes of retries, but it will give me a hard time again next boot.

question: has anyone come across this before? can this camera be saved?

If it helps I have had the camera for over a year and have been using ML from day one. May be unrelated but never had a glitch until a week ago when I started fiddling with the DualISO (photo) feature. removed the card without wait a few times (dumbass, I know).

Thanks everyone involved in ML. I film live events and without ML this camera is of no use to my work.

Ernani

  • New to the forum
  • *
  • Posts: 37
Re: EOS M srewed up (doesn't seem bricked however)
« Reply #1 on: November 27, 2015, 04:37:40 AM »
an update:

lately it's taking a lot longer than 10 minutes to boot the camera (around 40 min).

thanks already

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3751
Re: EOS M srewed up (doesn't seem bricked however)
« Reply #2 on: November 27, 2015, 05:23:43 AM »
It seems that maybe it is hanging when reading the card. Have you tried other cards? You might also try this:

Remove card, remove battery, reinsert battery and start camera without card--that usually works for me. Next step is in the Canon menus reset to default settings. If that helps you should probably also delete the ML settings file on the card to go back to the ML default settings. If you're still having problems turn off the camera boot flag by running the ML installer and waiting a minute for it to turn off the boot flag. Worse case scenario reinstall the Canon 2.0.2 firmware and hope for the best.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

Ernani

  • New to the forum
  • *
  • Posts: 37
Re: EOS M srewed up (doesn't seem bricked however)
« Reply #3 on: November 27, 2015, 01:02:22 PM »
hi Daniel, thanks for your work with ML and eos M.
So, with no card the camera behaves in the same way (blinking green light). already tried resetting canon's and ML's to default; no cake.
I am now in the process running ML installer to turn off camera boot flag, if I manage to turn the camera on that is.

one thing I didn't mention: When the camera boots from the ML card it works just fine. When it boots from non ML cards it goes haywire, freezing whenever I take a picture, turning off unexpectedly and other bugs . what gives?

I have a baaad feeling...

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: EOS M srewed up (doesn't seem bricked however)
« Reply #4 on: November 27, 2015, 02:56:15 PM »
A little warning: if you turn off the boot flag, and you can no longer turn it back on, we will have no possibility to investigate the issue.

Can you try the display test from here? http://www.magiclantern.fm/forum/index.php?topic=14732

Can you run it a couple of times without issues? (to rule out a hardware problem)

Do you have access to a second Canon camera that runs ML? That would make it easier to get Canon's diagnostic messages from the startup process.

Also, if you still have a ML card with ROM0.BIN and ROM1.BIN under ML/LOGS, make a backup of those files. I hope we won't need those, but just in case.

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3751
Re: EOS M srewed up (doesn't seem bricked however)
« Reply #5 on: November 27, 2015, 05:12:20 PM »
A little warning: if you turn off the boot flag, and you can no longer turn it back on, we will have no possibility to investigate the issue.

Yikes! Good to know.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

Ernani

  • New to the forum
  • *
  • Posts: 37
Re: EOS M srewed up (doesn't seem bricked however)
« Reply #6 on: November 27, 2015, 05:48:40 PM »
I do have access to a second ML ready eosM to run tests. already backed up roms, also saved a file named log000.log which was sitting in the sd's root.
for the display test all I need is copy the autoexec_2.bin to the sd?

thanks for the hand.

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3401
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
EOS M srewed up (doesn't seem bricked however)
« Reply #7 on: November 27, 2015, 05:59:31 PM »
Yikes! Good to know.

That's the scary feeling that we all thrive on, right?

Love living on the edge...

Btw, I hope you get your M back in working order soon @Ernanie
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: EOS M srewed up (doesn't seem bricked however)
« Reply #8 on: November 27, 2015, 06:18:17 PM »
for the display test all I need is copy the autoexec_2.bin to the sd?

Yes, but make sure the filename remains autoexec.bin (overwrite the old one).

Ernani

  • New to the forum
  • *
  • Posts: 37
Re: EOS M srewed up (doesn't seem bricked however)
« Reply #9 on: November 27, 2015, 06:22:22 PM »
Quote
Btw, I hope you get your M back in working order soon @Ernanie
  thanks mate. :)

update: I replaced the autoexec.bin from an ML card with the display test autoexec. after closing the card door the display backlight turned on but no image appeared. pressing the on/off button brought me back to the "forever blinking green LED".

today I had no luck in turning on the camera like I did before. it just stays there blinking its LED like there's no tomorrow.

if I ever manage to boot it again I might as well try Daniel's idea to turn off the boot flag as kind of a last resort. may be worth a try.

grateful u guys.

Ernani

  • New to the forum
  • *
  • Posts: 37
Re: EOS M srewed up (doesn't seem bricked however)
« Reply #10 on: November 27, 2015, 06:30:24 PM »
by the way, same card with replaced autoexec works perfectly on the second M1.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: EOS M srewed up (doesn't seem bricked however)
« Reply #11 on: November 27, 2015, 07:00:13 PM »
That means, our test code is running. However, the display not showing anything is a big warning - it might be a hardware issue. If you start the camera a couple of times, it might work at some point, I guess.

Here's a LED blinking test for EOS M: autoexec.bin

It should blink the card activity LED (I guess the red one). On EOS M, the green blink you are seeing is done from a different CPU. I hope at least this one works every time.

The next step would be printing Canon's debug messages and decoding them with a different camera. You may get in touch with me on IRC once you are ready.




Ernani

  • New to the forum
  • *
  • Posts: 37
Re: EOS M srewed up (doesn't seem bricked however)
« Reply #12 on: November 27, 2015, 07:17:27 PM »
The led blinking autoexec is working. whenever I close the battery door I get a continuous red LED intermittent signal.
tried the display test some 20 times having the same result. backlight on/no image.

Ernani

  • New to the forum
  • *
  • Posts: 37
Re: EOS M srewed up (doesn't seem bricked however)
« Reply #13 on: November 27, 2015, 07:21:13 PM »
I'd appreciate a lot your help but I'm afraid I'll bug the hell out of you for the lack of computer skills. I'm not "stoopid" but seeing you guys I feel kinda dumb.

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8071
Re: EOS M srewed up (doesn't seem bricked however)
« Reply #14 on: November 27, 2015, 07:27:25 PM »
Should not be a problem (most of us feel the very same at times). Trust him, he knows what he is doing.

Ernani

  • New to the forum
  • *
  • Posts: 37
Re: EOS M srewed up (doesn't seem bricked however)
« Reply #15 on: November 27, 2015, 07:53:49 PM »
ok. let me first learn how to use irc then I get back for the lesson.

Ernani

  • New to the forum
  • *
  • Posts: 37
Re: EOS M srewed up (doesn't seem bricked however)
« Reply #16 on: November 27, 2015, 08:00:06 PM »
a1ex, I got to your post about Blinking debug message (who's idea was it anyway? genius...). it took me to a page with a programming language but I don't know how to compile it.

Am I in the right track?

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: EOS M srewed up (doesn't seem bricked however)
« Reply #17 on: November 27, 2015, 08:16:14 PM »
The decoding module is already compiled (copy the .mo to ML/MODULES on the card).

The blinker: autoexec.bin

The messages are not saved on the card (yet), so you can just take a screenshot with the latest messages (which probably look like an error).

Ernani

  • New to the forum
  • *
  • Posts: 37
Re: EOS M srewed up (doesn't seem bricked however)
« Reply #18 on: November 27, 2015, 08:27:30 PM »
ok, the deblinker module is loaded to the active camera. the autoxec blinker is on the faulty camera which was turned on and now is blinking like crazy. display is pitch black.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: EOS M srewed up (doesn't seem bricked however)
« Reply #19 on: November 27, 2015, 08:30:36 PM »
Forgot to add: on the active camera, select Debug -> Decode LED blinks. After that, start the faulty camera and let it blink.

Ernani

  • New to the forum
  • *
  • Posts: 37
Re: EOS M srewed up (doesn't seem bricked however)
« Reply #20 on: November 27, 2015, 09:03:47 PM »
the cameras seem to be talking to each other. I let them chat for some minutes but was unable to save a screenshot. will try again.

just to be sure, for how long should I let them talk: 20 seconds, 30 minutes?

I'm pointing the camera lens directly onto the faulty cam's LED even if there's no focus. seem to work best.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: EOS M srewed up (doesn't seem bricked however)
« Reply #21 on: November 27, 2015, 09:08:35 PM »
When I tested it, the 60D took exactly 15 minutes, then it shut down before it finished to boot properly (probably some watchdog timer).

I hope the EOS M is a bit more patient, since I don't know how to disable this timer. If the timeout occurs without any error, we'll try a second binary, which will skip the first messages.

Ernani

  • New to the forum
  • *
  • Posts: 37
Re: EOS M srewed up (doesn't seem bricked however)
« Reply #22 on: November 27, 2015, 09:10:32 PM »
on it

Ernani

  • New to the forum
  • *
  • Posts: 37
Re: EOS M srewed up (doesn't seem bricked however)
« Reply #23 on: November 27, 2015, 09:22:33 PM »
they're doing their business at the moment. is it normal to get random characters like "__B_@_A_ _ _ ML" ?

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: EOS M srewed up (doesn't seem bricked however)
« Reply #24 on: November 27, 2015, 09:36:01 PM »
Nope; unfortunately, if that happens, you have to restart. It can probably be fixed by adjusting the exposure and taking care with nearby light sources.