Author Topic: Canon 100D / SL1  (Read 291322 times)

IDA_ML

  • Senior
  • ****
  • Posts: 429
Re: Canon 100D / SL1
« Reply #1450 on: July 03, 2018, 12:00:14 PM »
Try underexposing by one stop.

OlRivrRat

  • Senior
  • ****
  • Posts: 407
Re: Canon 100D / SL1
« Reply #1451 on: July 04, 2018, 02:33:31 AM »
No change, even @ as many stops under as I could go.
ORR~DeanB  ~~  80D-ML  &  SL1+ML  &  5D2+ML  &  5DC+ML  &  70D+ML.111B(DEAD)

IDA_ML

  • Senior
  • ****
  • Posts: 429
Re: Canon 100D / SL1
« Reply #1452 on: July 04, 2018, 12:36:02 PM »
Hello Danne,

I have now tested your alternative "allbadpixels" focus pixel (FP) cleaning method that you suggested in your post #1445.  It works but just partially.  It cleans part of the FP but leaves the others.  I have uploaded two DNGs - one from the original and one cleaned, for you to check and compare.  Please download them from here:

https://we.tl/fwnrz4x7xy

If that method could be fixed to clean all the FP, I think it could be a good way for express testing of MLV files for which the new FP maps have not been generated yet and do not exist.  Please let us know if that is possible.

IDA_ML

  • Senior
  • ****
  • Posts: 429
Re: Canon 100D / SL1
« Reply #1453 on: July 04, 2018, 12:43:16 PM »
No change, even @ as many stops under as I could go.

The only thing that remains to do is to reformat your card, install the build again and give it a try.  If that doesn't work, just go out and shoot some videos with whatever works for you.  I am sure, you will enjoy tremendously this new functionality of your camera.

Danne

  • Hero Member
  • *****
  • Posts: 4306
Re: Canon 100D / SL1
« Reply #1454 on: July 04, 2018, 12:59:30 PM »
I created one better before. Not home atm. If you could it would be nice to get three centred files where you film against a white or grey surface. Film at highest resolution a couple of seconds per clip will do. Three files in total.

Scubadude

  • New to the forum
  • *
  • Posts: 1
Re: Canon 100D / SL1
« Reply #1455 on: July 04, 2018, 04:08:59 PM »
Hi people.
Mighty impressed by your work.

I use my 100D mainly under water, and have a few questions...

What is the most stable version for 24fps and at which resolution? I hate it when the camera freeze and needs a battery pull. Especially when I'm 30m under water... I have a 256GB SanDisk Extreme card.

Is lossless raw format equal to regular raw format, when it comes to editing in Camera RAW? Since the light conditions under water is galaxies away from over water, I need to have the best possible raw material. Is it better to film with 12bit regular vs 14bit lossless?

Will I get automatic exposure to work while filming, or should I just make smaller clips with the right exposure for each?

Than you all for your efforts!

OlRivrRat

  • Senior
  • ****
  • Posts: 407
Re: Canon 100D / SL1
« Reply #1456 on: July 04, 2018, 05:17:07 PM »
                     @IDA_ML

           Already tried the Reformat, Reload as stated earlier. Regarding Format, is Your SD ExFat or Fat32?

Just doing this Testing for the sake of the Test & Feedback, would not consider taking it to The Field unless

it is Easy to get into & Rock Solid.
ORR~DeanB  ~~  80D-ML  &  SL1+ML  &  5D2+ML  &  5DC+ML  &  70D+ML.111B(DEAD)

IDA_ML

  • Senior
  • ****
  • Posts: 429
Re: Canon 100D / SL1
« Reply #1457 on: July 04, 2018, 05:31:49 PM »
                     @IDA_ML

           Already tried the Reformat, Reload as stated earlier. Regarding Format, is Your SD ExFat or Fat32?

Just doing this Testing for the sake of the Test & Feedback, would not consider taking it to The Field unless

it is Easy to get into & Rock Solid.

I formatted mine in the camera - Fat32 as far as I know.  If you want a "Rock Solid" camera you have to buy an Ari Alexa, RED, Black Magic or similar.  You cannot expect rock solid performance from a 200$ low-end consumer camera with ML on it.

IDA_ML

  • Senior
  • ****
  • Posts: 429
Re: Canon 100D / SL1
« Reply #1458 on: July 04, 2018, 05:39:16 PM »
I created one better before. Not home atm. If you could it would be nice to get three centred files where you film against a white or grey surface. Film at highest resolution a couple of seconds per clip will do. Three files in total.

Danne,

I want to make sure, I understand what you want.  You want me to shoot 3 identical clips, one after the other??? (a couple of seconds each) of a white or grey surface at the highest resolution which is 4056x2880 at the moment and then send the three MLV files to you.  Is that what you want?

Danne

  • Hero Member
  • *****
  • Posts: 4306
Re: Canon 100D / SL1
« Reply #1459 on: July 04, 2018, 05:40:48 PM »
One file from each mode. 2k, 3k, 4k.
I want scare out the pixels :).

IDA_ML

  • Senior
  • ****
  • Posts: 429
Re: Canon 100D / SL1
« Reply #1460 on: July 04, 2018, 05:43:04 PM »
OK, this makes sense, I understand. 

OlRivrRat

  • Senior
  • ****
  • Posts: 407
Re: Canon 100D / SL1
« Reply #1461 on: July 04, 2018, 05:43:22 PM »
"If you want a "Rock Solid" camera you have to buy an Ari Alexa, RED, Black Magic or similar.  You cannot expect rock solid performance from a 200$ low-end consumer camera with ML on it."

       Strongly Disagree with that > Been using M'L' on Many Canons for Many Years & RockSolid Builds Do Exist once the Bugs get Discovered & Fixed.

In this case it seems as though there must be some Setting that I have incorrect as it doesn't seem logical that it would work fine in 1 Sl1 & Not Fine

in another.
ORR~DeanB  ~~  80D-ML  &  SL1+ML  &  5D2+ML  &  5DC+ML  &  70D+ML.111B(DEAD)

IDA_ML

  • Senior
  • ****
  • Posts: 429
Re: Canon 100D / SL1
« Reply #1462 on: July 04, 2018, 06:09:59 PM »
For those who use MLVFS in their workflow and are eager and impatient to test the new 2,5k-crop recording RAW video mode at 2520x1304 resolution on their 100D cameras, (see my post #1435), without focus pixels on the clips, here is a focus pixel map (FPM) that I have just uploaded for you and that works very well with MLVFS by totally killing all focus pixels:

https://we.tl/gDyJ1dsS9z

The above download will be active for 7 days. 

All you need to do is copy the .fpm file into your MLVFS-software directory and you are ready to go.  Video quality after post processing in DaVinci Resolve 14 is breath taking!

I would like to thank Dfort for responding to our eagerness so quickly and creating this wonderful FPM.  Please note that all this is still work in progress and this FPM is just temporary.  Once the final resolutions and center offsets have been established it will have to be updated again.

HAVE FUN !!!

OlRivrRat

  • Senior
  • ****
  • Posts: 407
Re: Canon 100D / SL1
« Reply #1463 on: July 04, 2018, 09:15:07 PM »
      @ IDA_ML & Danne

   So the Gremlin seems to have decided to stop messing with Me. After some "Shot In The Dark"

changes to some Canon Menu Settings & M'L' Settings I am able to Rec 2520x1304 @ 18FPS Cont'.

In an attempt to Diag' which change might have been the Culprit, I 1x1 Reversed the Changes I

had made & 2520x1304 @ 18FPS Cont' still works Just Dandy.

   'Tis a bit annoying to not know why it wasn't working & now it is, but it is & That Be Good.

Also now getting ReadOut of SD Write Speed in Upper Right Corner.
         
ORR~DeanB  ~~  80D-ML  &  SL1+ML  &  5D2+ML  &  5DC+ML  &  70D+ML.111B(DEAD)

Danne

  • Hero Member
  • *****
  • Posts: 4306
Re: Canon 100D / SL1
« Reply #1464 on: July 05, 2018, 01:41:40 PM »
@IDA_mL
Did three new pixel map files which I think will work better:
https://bitbucket.org/Dannephoto/magic-lantern/downloads/pixelmaps_2k_3k_4k_100D.zip
Feel free to take a look.

IDA_ML

  • Senior
  • ****
  • Posts: 429
Re: Canon 100D / SL1
« Reply #1465 on: July 05, 2018, 02:26:18 PM »
Thanks Danne,

I have downloaded the three maps and will test as soon as I get back from work.

I also have prepared the three sample files (2,5K, 3.1K and 4K, shot at the maximum resolution as you requested).  The grey board that I used was scratched a little but the focus pixels are there and visible.  Please let me know if these files work for you.  Download from here:

https://we.tl/iQqOLpvOj9

Danne

  • Hero Member
  • *****
  • Posts: 4306
Re: Canon 100D / SL1
« Reply #1466 on: July 05, 2018, 05:16:41 PM »
Thanks. Will download and check them as soon as possible.

IDA_ML

  • Senior
  • ****
  • Posts: 429
Re: Canon 100D / SL1
« Reply #1467 on: July 05, 2018, 07:29:53 PM »
Danne,

You are a wizard!  At 100% magnification, I do not see any focus pixels at all.  With the 3,1K allbadpixels.map I see a few very faint light blue residues of focus pixels but they are noticeable only at 300% magnification.  In my opinion, this method really works well. Please test by yourself and confirm this statement whenever you can.  Of course, further tests on real life video files are necessary to prove it, (I already did that at 2,5k), but these results at 3,1 and 4k are very encouraging!

I was wondering if it might be possible to automate the whole thing.  MLV_dump should automatically recognize the resolution mode each clip in a given folder was shot at and should also automatically apply the correct map to it.  If that could be done with Batch_MLV for windows if would be golden for early stage tests when the correct FP maps have not been created yet.

Next step: Cleaning FP in Dual ISO files at 4k - do you think that would be possible with this method?

Keep up the good work!

Danne

  • Hero Member
  • *****
  • Posts: 4306
Re: Canon 100D / SL1
« Reply #1468 on: July 05, 2018, 09:02:09 PM »
Cool. I'll see if I can get even closer to perfect here.
Automation is dfort's and bouncyball's territory. After all, the code is coming from raw2dng(neighbouring pixels) and there's refined code in mlvfs and recent mlv_dump som maybe those tools work even better. Still, it's good to have comparative tools to see if results can get even better :)

IDA_ML

  • Senior
  • ****
  • Posts: 429
Re: Canon 100D / SL1
« Reply #1469 on: July 07, 2018, 10:33:54 PM »
Hello 100D users,

I am happy to report another impressive result from our little beasty 100D:

https://we.tl/GhLdeiloLw

It concerns filming high-contrast scenes in Dual ISO and postprocessing with MLVApp v.017.  More details here:

https://www.magiclantern.fm/forum/index.php?topic=20025.msg203799;topicseen#msg203799


IDA_ML

  • Senior
  • ****
  • Posts: 429
Re: Canon 100D / SL1
« Reply #1470 on: July 11, 2018, 12:58:43 PM »
Hello A1ex,

I tested your latest experimental build from July 9-th on my 100D and would like to provide some feedback:

1) I had to disable the raw_tweak.mo that I had previously loaded.  With this module active, camera crashes all the time giving "Threads failed to start" and "RAW detect error" messages.  With this module deactivated, all video modes as well as in-camera playback work just fine as follows:

2) RAW video works perfectly and with synchronous sound at all compressed and uncompressed bit rates in all three modes:

Normal: 1736x976
Movie crop mode: 1800x1012
5x-Magnification: 2520x1078 (there is a slight offset to the left and bottom of the frame in this mode).

Also in-camera playback works fine with clips recorded in these resolutions.

3) MLV video works but without sound and there is no in-camera playback (black screen) with clips recorded at 10 and 12 bits.  I think, now that MLV-Lite works so well with sound, this MLV video mode is redundant.

MISSING:
----------

4) Danne's SD-UHS module for SD-card interface overclocking.  I have been using it a lot over the last two months and did not have a single glitch or data loss.  I think that it is safe enough and should be implemented with automatic self activation in the next Experimental build;

5) The 2,5K, 3,1K and 4K resolutions in the crop mode.  These work very well at 14-bit lossless in Danne's build from June 30-th and could serve as a good starting point.  If 10 and 12-bit lossless bit rates could be fixed for these high-resolutions, as this is the case for the 2520x1078 resolution now, that would increase recording times on the 100D and make this camera much more usable for crop-recording in high resolution.

6) The WiSyWiG preview during recording at 5x-magnification and future 2,5, 3K and 4K resolutions.  It does not work in the 5x mode at 2520x1078 resolution now.  Fixing the preview for the high-resolutions is crucial for proper framing during recording and must be implemented.

7) The old user interface with the RAW histogram, Zebras, Focus peaking, etc.  Working without these functions  makes precise focusing and metering very difficult, especially metering, which is a cut and try process now and I personally feel that most users will miss these features a lot! So, please return the old UI.

Thanks for your continued efforts!

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 11517
  • 5D Mark Free
Re: Canon 100D / SL1
« Reply #1471 on: July 11, 2018, 02:50:05 PM »
1: nothing changed, anything different from previous builds?

3: in-camera playback of 10/12-bit files (still) requires raw_twk; nothing changed here.

4, 5: WIP, I didn't include them yet. Stuck with some basic issues, such as shutter speed and detecting video mode changes.

6, 7: nothing changed, make sure you are using the correct preview options in the menu. If the menu items are grayed out, read the fine print at the bottom of the screen; it tells you why they are not working.

Kouglov

  • New to the forum
  • *
  • Posts: 9
Re: Canon 100D / SL1
« Reply #1472 on: July 21, 2018, 10:06:37 PM »
Hello, I Hope it's not problematic that I post a strange behaviour here. I havn't found other pages here talking about that.

When I open the battery door, the card reader led does not blink.
I wait some time before pulling the sd out but today I forgot it, and crashed the camera.

Had to pull battery out for like a minute and put it to charge 5 mins to make the camera boot again.
Everything works just fine.
Do you have any ideas why the card reader led does not blink ?
6D

sebi2k4

  • New to the forum
  • *
  • Posts: 7
Re: Canon 100D / SL1
« Reply #1473 on: July 21, 2018, 11:47:37 PM »
Hi guys,

first of all, thank you for the effort you spend in this to make our 100D / SL1 way better. I really appreciate it.
As I've been reading a lot on this forum in the last weeks I now wanted to try this new achievements regarding raw video with 1080p resolutions and larger.

I did download and install this build from Danne (thanks again  ;) ) as recommended in the post quoted below:
https://bitbucket.org/Dannephoto/magic-lantern/downloads/magiclantern-Nightly.2018Jun30.100D101_2K-3K-4K.zip

I strongly encourage all 100D users to test the above build and share their findings here.  Not only will this help our developers but also playing around with this build is a lot of fun!  I am sure, you will not regret.

Unfortunately I need some short instructions for me as a beginner similar to those in post #1417 written by IDA_ML. Seems like adtg_gui module isn't needed any more.
I did load the 3 modules which are left 'lua', 'mlv_lite' and 'sd_uhs' but in MLV Menu I am not able to get larger resolutions. Experimented with 'mlv_snd' and 'mlv_play' additionally but didn't change anything.

Note: I do only have a 30 MBit/s SD card atm. I will buy the recommended one asap. But I thought if I reduce the fps to lets say 2 or 6 or something recording has to be possible with my SD card too right?

I would really appreciate if one of you experts could help me out on that one and again thank you for what you are doing to the Canon-Community.

//EDIT: I tried running the 'enable SD overclocking' script but the highest resolution I get (even with 2 fps) is 1800x1008.
I guess I do need some basic instructions like which mode do I have to use 'Picture' or 'Video' mode?
How can I get this 5x crop thing done? Pressing the magnifier button twice doesn't do anything in video mode.

Walter Schulz

  • Hero Member
  • *****
  • Posts: 6173
Re: Canon 100D / SL1
« Reply #1474 on: July 22, 2018, 12:21:54 AM »
How can I get this 5x crop thing done? Pressing the magnifier button twice doesn't do anything in video mode.

Turn AF off and retry.