Author Topic: Canon 100D / SL1  (Read 403751 times)

theBilalFakhouri

  • Contributor
  • Senior
  • *****
  • Posts: 362
Re: Canon 100D / SL1
« Reply #1125 on: February 04, 2018, 10:08:36 PM »
magiclantern-crop_rec_4k.18-02-04.100D101

   mlv_snd Module is present & activateable but Audio Tab/Page is Missing.
Now it's under mlv_lite settings, check it out! 
700D 1.1.5 | no more ISOless LV err 8

OlRivrRat

  • Hero Member
  • *****
  • Posts: 538
Re: Canon 100D / SL1
« Reply #1126 on: February 04, 2018, 11:07:13 PM »
"Now it's under mlv_lite settings, check it out!"

   Where does One find "mlv_lite settings"?

      Saw this >

"mlv_snd: moved the menu inside the mlv_rec/mlv_lite submenu;"

But Don't have SubMenus Named mlv_rec or mlv_lite.

   Checked in SubMenus "Raw video" & "Raw video (MLV)" & not there either.

But Thanks anyway for the attempt & any further help would be appreciated.
ORR~DeanB  ~~  80D-ML  &  SL1+ML  &  5D2+ML  &  5DC+ML  &  70D+ML(AliveAgain)

theBilalFakhouri

  • Contributor
  • Senior
  • *****
  • Posts: 362
Re: Canon 100D / SL1
« Reply #1127 on: February 05, 2018, 12:36:46 AM »
@OlRivrRat
1. Go to Modules menu and enable mlv_lite + mlv_snd
2. Restart camera
3. Go to Movie menu > select RAW video > Press Q button > You will find mlv_lite settings or submenu
1" border="0
Press Q
2" border="0
mlv_lite settings
3" border="0

If something like this happened
4" border="0
Restart the camera again and you will have it under mlv_lite settings
@a1ex Maybe this a small issue with new build it's only happen for the first time when enable mlv_snd. (EDIT: Solved)
(Tested on canon 700d build crop_rec_4k.2018Feb04.700D115)
700D 1.1.5 | no more ISOless LV err 8

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12390
  • Quarantined
Re: Canon 100D / SL1
« Reply #1128 on: February 05, 2018, 01:09:25 AM »
Solved, thanks for pointing out.

Anything specific you want to be tested? I Just clicked inside the quick control and a bit in canon menus

I'm not 100% sure how to interpret the touch events from the log, so if you can record a video of the camera screen (so I could see what exactly you were doing), would be great. The video should include the power on event, so I could timestamp the touch interactions and match them to log messages.

Otherwise, please enable the option to show GUI events (Debug menu), as these would appear in the video, and make sure to include a few short taps, a simple drag gesture, a short 2-finger tap and a 2-finger zoom gesture.

Should the log size reach 2MB, try capturing 2 smaller logs. Unlikely to happen, since the current ones were smaller than 1MB; maybe the zoom gesture could give some surprises, if performed on some image in playback mode.

Current log: touch.png

OlRivrRat

  • Hero Member
  • *****
  • Posts: 538
Re: Canon 100D / SL1
« Reply #1129 on: February 05, 2018, 01:44:40 AM »
                  @ theBilalFakhouri

   ReInstalled the Build & Now it is there but only in "Raw video" SubMenu,

does not show in "Raw video (MLV)". Is that as it Should Be?
ORR~DeanB  ~~  80D-ML  &  SL1+ML  &  5D2+ML  &  5DC+ML  &  70D+ML(AliveAgain)

theBilalFakhouri

  • Contributor
  • Senior
  • *****
  • Posts: 362
Re: Canon 100D / SL1
« Reply #1130 on: February 05, 2018, 07:17:31 AM »
@OlRivrRat
Check the new build it solved this problem! thanks a1ex
Scroll down for "Raw video (MLV)" submenu and you will get the audio function in front of your eyes  :)
700D 1.1.5 | no more ISOless LV err 8

IDA_ML

  • Hero Member
  • *****
  • Posts: 793
Re: Canon 100D / SL1
« Reply #1131 on: February 05, 2018, 01:10:20 PM »
Hello A1ex,

With your Feb. 05-th build:

magiclantern-crop_rec_4k.2018Feb05.100D101 (Experimental page),

you have provided a significant achievement with the ML development of the 100D.  Congratulations and thank you so much!  For me, it is a KEY BUILD which I will store at 3 different locations and will keep it installed all the time on my 100D for use on travel and vacations. 

Here are my first impressions:
====================

1) RAW video with sound works very well in all crop modes and at all bit depths now. 

2) The silent module with IS lenses works very well now with and without intervalometer.  The shutter speed range is 1/25-th of a sec. to 16 s.  Extremely useful, especially with Dual ISO!

Not working:
=============

3) The raw_tweak module.  It affects all RAW video modes and has to be deactivated for them to work properly.  It cannot play previously recorded 10/12-bit uncompressed video either.  I have given details on that in my earlier posts in this tread.

4) The RAW video (MLV) mode works somewhat better now but still very unstable.  It records WITHOUT sound (even when sound is activated), but when switching between bit depths the "Threads failed to start" message appears and a battery pull and restart is required.  In this case, M00 to M06 files of 1 KB size are recorded and the actual .MLV file is just 3 KB.

5) When trying to playback a single DNG file in the File Manager, a horizontal line (about 25% from top), cuts through the picture.

6) The shutter speed with single FRSP DNGs is not reported correctly in ACR.  On my EF 70-300/4-5,6 IS it shows just 1/3 s., no matter what the actual value was.  0n the 24/2,8 it shows 1/2 s.

7) Aperture control on recent lenses (I have tested with the 18-55 STM, 24/2,8 IS and 35/2 IS), cannot be properly controlled - just by 2/3 of a stop.  Is it possible to fix that?  On older lenses like EF 70-300/4-5,6 IS aperture control works fine.

SUGGESTIONs for Improvement:
======================

I.  It would be very helpful if an option to the silent module is added which allows for lossless DNGs also to be written into a MLV container to save about 35% card space.  Hoewever, to distinguish these picture sets from the regular video MLVs, they should start with the letter "S" if they contain single lossless FRSPs and "T" if they contain time lapses.  This will make sorting much easier afterwards.

II.  It would be great if a red stricken out loudspeaker icon is added to the screen when sound is deactivated.  Otherwise, it is very easy to forget to turn sound on after it has been turned off for certain videos.

REQUEST to other 100D owners using ML:
============================

We are now very close to the point where the 100D is about to become the perfect travel camera.  Please check all other functions that you use in the photo and video modes and report possible bugs here.  In this way, we will have a refined and completed build that you can trust and use with confidence when you travel with your 100D.

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3749
Re: Canon 100D / SL1
« Reply #1132 on: February 05, 2018, 06:14:49 PM »
I.  It would be very helpful if an option to the silent module is added which allows for lossless DNGs also to be written into a MLV container to save about 35% card space.  Hoewever, to distinguish these picture sets from the regular video MLVs, they should start with the letter "S" if they contain single lossless FRSPs and "T" if they contain time lapses.  This will make sorting much easier afterwards.

I was thinking about this too. Shouldn't it be possible to do reduced bit depth and lossless compression with silent still just like you can with video?

As far as naming, from what I'm seeing on the MLV files on the card there shouldn't be any problem distinguishing which are stills and which are video.

Code: [Select]
59410000.MLV
59410001.MLV
M05-1012.MLV
M05-1013.MLV

The movie files start with M. There's a naming option on the 5D3 but I don't think that option is on the 100D. I can't find it on the EOSM.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

OlRivrRat

  • Hero Member
  • *****
  • Posts: 538
Re: Canon 100D / SL1
« Reply #1133 on: February 05, 2018, 06:16:49 PM »
   So here is what I am now seeing & am assuming is correct >

With Both "mlv_lite" & "mlv_rec" Modules Activated/"OK" the "Sound recording" control shows in the

"RAW video" SubMenu. With only the "mlv_rec" Module Activated/"OK" the "Sound recording" control

shows in the "RAW video (MLV)" SubMenu.

   I'm sure that Alex has Very Good reasons for doing it that way but it seems complex & that it

Might have been easier to just let "Sound recording" be It's Own SubMenu under the "Movie" Tab >

But then I don't have the slightest Savvy on how the M'L' Wizards work their Magic, Just Very Glad

& Thankful that They Do !!!
ORR~DeanB  ~~  80D-ML  &  SL1+ML  &  5D2+ML  &  5DC+ML  &  70D+ML(AliveAgain)

IDA_ML

  • Hero Member
  • *****
  • Posts: 793
Re: Canon 100D / SL1
« Reply #1134 on: February 05, 2018, 06:44:47 PM »
One more bonus from the 19 MB lossless FRSPs - they open nicely in ACR and way faster than the uncompressed 31 MB ones!

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3749
Re: Canon 100D / SL1
« Reply #1135 on: February 05, 2018, 07:05:41 PM »
Compressed lossless FRSP vary in size, just like CR2 files do. I've gotten some 16MB DNG's. Wonder how small they can get with 8...11bit lossless.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

OlRivrRat

  • Hero Member
  • *****
  • Posts: 538
Re: Canon 100D / SL1
« Reply #1136 on: February 05, 2018, 07:12:24 PM »
   Intervalometer + FRSP test in "magiclantern-crop_rec_4k.18-02-05.100D101"

FRSP FullResLV   MLV or DNG or Lossless DNG   No Files Saved to Disc
ORR~DeanB  ~~  80D-ML  &  SL1+ML  &  5D2+ML  &  5DC+ML  &  70D+ML(AliveAgain)

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3749
Re: Canon 100D / SL1
« Reply #1137 on: February 05, 2018, 07:25:29 PM »
That might be a 100D issue. Intervalometer is working fine on the EOSM - DNG, lossless, MLV.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

canneloni

  • Freshman
  • **
  • Posts: 96
Re: Canon 100D / SL1
« Reply #1138 on: February 05, 2018, 08:15:57 PM »
@IDA How do you get any kind of aperture control and this shutter speeds ? Whatever I do I cat get the aperture higher than 2.8 (wich is the lowest possible) and shutter speed gets only to 1/4th of a second, but i have to select 1/250 in the settings to get it there.
100D.100B ; Canon 18-55 STM ; Canon 50 1,8 II ; Canon 75-300 4,0 - 5,6 III ; Sigma 17-50 2,8

OlRivrRat

  • Hero Member
  • *****
  • Posts: 538
Re: Canon 100D / SL1
« Reply #1139 on: February 06, 2018, 06:48:10 PM »
      @DFort

   Since IDA_ML is having success, I'd guess that the SL1/100D is not the problem but that the

problem is that the ORR~DeanB has something incorrectly Set. > But, with All the Available Choices

& No Clear Instructions on what the Settings Need To Be to make it work, I'm having No Luck with

being able to figure it out.
ORR~DeanB  ~~  80D-ML  &  SL1+ML  &  5D2+ML  &  5DC+ML  &  70D+ML(AliveAgain)

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3749
Re: Canon 100D / SL1
« Reply #1140 on: February 06, 2018, 07:39:21 PM »
No Clear Instructions on what the Settings Need To Be to make it work...

You mean for your issue of not saving FRSP with the intervalometer?

Ok--let's first reset everything. Delete the ML/SETTINGS folder from the card and reset your Canon settings and custom settings. The 100D Canon defaults to JPEG so switch that to RAW and you'll need to change to back button focus for silent stills to work. Not sure which setting that is on the 100D but on the EOSM I need to change Shutter/AE lock button from AF/AE lock to AE lock/AF.

Turn on only the silent module and set for FRSP/DNG, don't go for anything fancy just yet. Activate the intervalometer and see if that works.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

OlRivrRat

  • Hero Member
  • *****
  • Posts: 538
Re: Canon 100D / SL1
« Reply #1141 on: February 07, 2018, 10:58:57 PM »
   As Per suggestions from DFort I Reset the SL1 & Trashed the ML Settings Folder.

With only crop_rec, mlv_lite, mlv_rec & silent Modules Active

FRSP + Intervalometer produces >

      Setting                      Saved to Disc

FRSP FullRes   DNG             DNGs

FRSP FullRes   L-DNG           Lossless DNGs

FRSP FullRes   MLV               MLV

 Canon Movie Res set to  1280x720/60FPS + ML Crop mode 3x3 720p

FRSP FullResLV   DNG            No Files

FRSP FullResLV   L-DNG         No Files

FRSP FullResLV   MLV            No File

       Build used >

magiclantern-crop_rec_4k.2018Feb05.100D101
ORR~DeanB  ~~  80D-ML  &  SL1+ML  &  5D2+ML  &  5DC+ML  &  70D+ML(AliveAgain)

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3749
Re: Canon 100D / SL1
« Reply #1142 on: February 07, 2018, 11:32:29 PM »
Canon Movie Res set to  1280x720/60FPS + ML Crop mode 3x3 720p

Try leaving the camera in movie mode when shooting Full-res LV.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

OlRivrRat

  • Hero Member
  • *****
  • Posts: 538
Re: Canon 100D / SL1
« Reply #1143 on: February 08, 2018, 06:37:57 AM »
                     @ DFort

           Had already tried that & did so again > Intervalometer goes through the motions but

No Files get Saved To Disc.
ORR~DeanB  ~~  80D-ML  &  SL1+ML  &  5D2+ML  &  5DC+ML  &  70D+ML(AliveAgain)

IDA_ML

  • Hero Member
  • *****
  • Posts: 793
Re: Canon 100D / SL1
« Reply #1144 on: February 08, 2018, 11:40:08 AM »
   
Canon Movie Res set to  1280x720/60FPS + ML Crop mode 3x3 720p

FRSP FullResLV   DNG            No Files

FRSP FullResLV   L-DNG         No Files

FRSP FullResLV   MLV            No File

       Build used >

magiclantern-crop_rec_4k.2018Feb05.100D101

OlRivrRat,

I am not sure what you are trying to do.  Do you expect the 100D with its 40 MB/s write speed to record 5K RAW video at 60 fps?  Because FRSP means "FULL RESOLUTION SILENT PICTURE".  This means that every single frame has the full resolution of the sensor which is 5184x3456pp on the 100D.  Now multiply this by 60 (for 60 fps) and check for yourself how much bandwidth, [MBytes/s], you need to record such type of video.  Do you think this makes sense and poor 100D can handle that?  If not, then you understand why "No Files" get recorded with the above settings of yours.

The 100D can record at 60 fps RAW video at the maximum resolution of 1736x688.  This is also clearly written on the Experimental page under "4K raw video recording; lossless compression".  I get between 200 and 260 frames recorded with sound at that resolution before camera stops due to buffer full condition.  To achieve this, you need to activate:

1) 1280x720/60FPS in the Canon menu
2) Crop mode - 3x3 720p in the Movie mode of ML
3) RAW video - ON, 1736x688 with aspect ratio set to 3:2 and Data format - 11...8 bit lossless
4) Press half shutter to go to Life View and then the Record button to record your video.

That's all.




IDA_ML

  • Hero Member
  • *****
  • Posts: 793
Re: Canon 100D / SL1
« Reply #1145 on: February 08, 2018, 05:43:06 PM »
@IDA How do you get any kind of aperture control and this shutter speeds ? Whatever I do I cat get the aperture higher than 2.8 (wich is the lowest possible) and shutter speed gets only to 1/4th of a second, but i have to select 1/250 in the settings to get it there.

Make sure you have selected RAW quality and back button focusing in Canon's menu and you are in PHOTO mode. Activate Life View. Read your camera manual to learn how to adjust these settings.  Activate the Silent module and adjust your desired settings there - Full-Res, Lossless DNG, etc.   Go back to Life View.  Now, with the main dial you can adjust the shutter speed anywhere between 16 s. and 1/25-th of a sec.  You can set faster speeds but the fastest actual speed in this mode will only be about 1-25-th of a sec.  By holding down the Av button and turning the main dial you can also adjust the aperture, unfortunately, only on older lenses like the EF 50/1,4 USM.  On STM lenses and newer ones (I have listed some in my post #1131) adjustment range is limited to less than 1 stop.  Use a variable ND filter with such lenses. 

That's it, really simple!

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3749
Re: Canon 100D / SL1
« Reply #1146 on: February 08, 2018, 05:53:24 PM »
I am not sure what you are trying to do.

He's using FRSP with the intervalometer to record timelapse so your comments about high frame rate don't really apply to what OlRivrRat is trying to do.

Great comments about adjusting aperture and shutter speeds. You've also been doing some handheld FRSP with IS lenses, right?
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

OlRivrRat

  • Hero Member
  • *****
  • Posts: 538
Re: Canon 100D / SL1
« Reply #1147 on: February 08, 2018, 05:57:24 PM »
      @IDA_ML

   It Appears as though You May have Missed the word >Intervalometer< just above My list of test results >

I'm trying to get FRSP "Full-res LV" to Save Images to Disc for TimeLapse purposes & was informed by DFort

that I should set Canon Movie Res to  1280x720/60FPS as part of the SetUp.
ORR~DeanB  ~~  80D-ML  &  SL1+ML  &  5D2+ML  &  5DC+ML  &  70D+ML(AliveAgain)

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3749
Re: Canon 100D / SL1
« Reply #1148 on: February 08, 2018, 06:33:09 PM »
I'm trying to get FRSP "Full-res LV" to Save Images to Disc

Right--sorry, I missed that part. The reason for that is because Full-res LV is for use with the crop_rec module. The only option currently supported in crop_rec on the 100D is the one where the mv720 raw buffer is used with a 3x3 sampling instead of the usual 3x5. Even though the camera is set to 60fps, all we're doing here is shooting stills with that raw buffer.

Someone please correct me if I'm wrong.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

IDA_ML

  • Hero Member
  • *****
  • Posts: 793
Re: Canon 100D / SL1
« Reply #1149 on: February 08, 2018, 06:35:48 PM »
He's using FRSP with the intervalometer to record timelapse so your comments about high frame rate don't really apply to what OlRivrRat is trying to do.

Great comments about adjusting aperture and shutter speeds. You've also been doing some handheld FRSP with IS lenses, right?

Yes, I did but I used the very usual Photo mode in Life View to take them.  What I don't understand is why one would use the 1280x720/60FPS setting for time lapse work, especially with intervalometer.  Time lapse means recording at a slow speed (typically 1 frame/s) and playing back at a much faster speed (typically 24 fps.)  So why the 60 fps?  Am I missing something?