Author Topic: ML on EOS-M2  (Read 108551 times)

jonkjon

  • New to the forum
  • *
  • Posts: 23
Re: ML on EOS-M2
« Reply #575 on: July 19, 2019, 03:14:58 AM »
Test footage shot today (7/18-2019)..https://youtu.be/c-OG6xFfjjE

jonkjon

  • New to the forum
  • *
  • Posts: 23
Re: ML on EOS-M2
« Reply #576 on: July 20, 2019, 07:28:01 PM »
Working with the latest build from dforts repository and replacing the crop_rec with the presets from Danne is giving me the best results. I had some issues with Magic Zoom flickering using Danne's build but I get slightly higher res. using his. I do have to punch into the menu occasionally to get out of a lock up but it is much, much better than previous. Other than the shutter speed being off slightly, this thing is working pretty darn great. THANK YOU to everyone for the fantastic work!!!

--Jon

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5634
Re: ML on EOS-M2
« Reply #577 on: July 20, 2019, 07:33:40 PM »
Yeah, that´s pretty nice. Branch should be merged and fixed but dfort seems busy these days. I have no cam so focusing on other stuff atm.

ZEEK

  • Freshman
  • **
  • Posts: 81
Re: ML on EOS-M2
« Reply #578 on: July 21, 2019, 07:49:25 AM »
Magic Lantern on the EOS M2 has been going really great, really useable now. I have noticed that the M2 produces less noise as well as minuscule aliasing when compared to the EOS M.

One thing, though not major, is that the M2 doesn't work well with a monitor. It doesn't even recognize it is being connected to one and won't connect. Not sure what the issue is here, works well with the original M, guess ill have to play around with it more.
EOS M - EOS M2 - EOS M50 - 6D

jonkjon

  • New to the forum
  • *
  • Posts: 23
Re: ML on EOS-M2
« Reply #579 on: July 21, 2019, 08:40:49 PM »
One thing, though not major, is that the M2 doesn't work well with a monitor. It doesn't even recognize it is being connected to one and won't connect. Not sure what the issue is here, works well with the original M, guess ill have to play around with it more.

I think the A/V out has been crippled by Canon from the start with the M2. I haven't ever been able to get them to work except for using the wireless functionality and an iPad. I was holding out hope that they didn't actually cripple it via hardware....

--Jon

ZEEK

  • Freshman
  • **
  • Posts: 81
Re: ML on EOS-M2
« Reply #580 on: July 22, 2019, 12:22:25 AM »
Thanks Jon,
 yeah thats a shame, though not a big deal. Thanks for the response. :)
EOS M - EOS M2 - EOS M50 - 6D

Aperture Science

  • New to the forum
  • *
  • Posts: 12
Re: ML on EOS-M2
« Reply #581 on: July 24, 2019, 07:51:31 AM »
Hi, my EOS m2 is about to arrive in 2 days (including a external monintor)
I can't wait to test this out.
I lens I got is 17-40 & 50 1.4
Also I have eos m1 in the same time, it is excited to have a compare between these two models since there aren't many video about this.

jonkjon

  • New to the forum
  • *
  • Posts: 23
Re: ML on EOS-M2
« Reply #582 on: July 24, 2019, 06:21:11 PM »
Thanks Jon,
 yeah thats a shame, though not a big deal. Thanks for the response. :)

Good News! I was wrong! (As I often am) I discovered that having wi-fi enabled on the device disables the HDMI output. I haven't tried the usb connection as I don't think I have the proper cable.

--Jon

ZEEK

  • Freshman
  • **
  • Posts: 81
Re: ML on EOS-M2
« Reply #583 on: July 24, 2019, 10:46:26 PM »
Cool to know! I'll give it a go and see how it plays out :) Thanks. Would be a game changer.
EOS M - EOS M2 - EOS M50 - 6D

Aperture Science

  • New to the forum
  • *
  • Posts: 12
Re: ML on EOS-M2
« Reply #584 on: July 25, 2019, 06:32:57 PM »
From what I get:
The AF system works well during recording the raw video
by using the settings:
mv 1080p_rewired on (12bit 16:9)
RAW Video on
Sound record on
All the Modules are loaded
with 50mm F1.4 @1.8
Used "crop_rec_4k_mlv_snd_isogain_1x3_presets_EOSM2_2019Jul07.EOSM2103.zip" by Danne

Here is the video:
However, I found that the camera will dead after record the raw video (Menus are available, but no images on the display. Won't fix by enter into the canon menu and exit)
And screen may froze after enter into the ML menu and exit (only once during my test).
The build is still kind of unstable, some problem like randomly black display or frozen; but a big thanks to you guys, the progress is so far so good

Also I found the focus pixel can not be removed even in the latest MLV APP

GOOD JOB GUYS

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5634
Re: ML on EOS-M2
« Reply #585 on: July 25, 2019, 06:39:10 PM »
See reply #576 for better performance.

Aperture Science

  • New to the forum
  • *
  • Posts: 12
Re: ML on EOS-M2
« Reply #586 on: July 25, 2019, 07:00:31 PM »
I see...there are even more interesting models lolll
I will test it for a while and give you guys feedbacks

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 1215
Re: ML on EOS-M2
« Reply #587 on: July 25, 2019, 07:11:22 PM »
Also I found the focus pixel can not be removed even in the latest MLV APP
Really? I could remove all focus pixels from EOS M2 MLV (mv1080p) files from 14 days ago without any problem. Have you installed focus pixel maps?
5D2.212 | EOSM.202

ZEEK

  • Freshman
  • **
  • Posts: 81
Re: ML on EOS-M2
« Reply #588 on: July 26, 2019, 02:29:47 AM »
I could get rid of focus pixels since day one of using ml with the M2, even with 3x3 chroma smooth they're all gone!
I used Danne's July 07, but copied the crop_rec and replaced it into DForts July 06 Crop_rec. Works as good as the M now, with zero pink frames even with a monitor. Amazing Camera cheers to the team :)
EOS M - EOS M2 - EOS M50 - 6D

kaworu9527

  • Just arrived
  • *
  • Posts: 1
Re: ML on EOS-M2
« Reply #589 on: July 26, 2019, 03:17:09 AM »
Hi guys!

I saw this fantastic project 2 days ago, and then I bought a pre-owned EOS M2 ,even I had a EOS M at the same time.

I know a little about camera, video, coding, and so on. I will test this ML on EOS M2 and give feedback to you.

I hope I can help.

thank you very much for all the people who work in this project!

Aperture Science

  • New to the forum
  • *
  • Posts: 12
Re: ML on EOS-M2
« Reply #590 on: July 26, 2019, 12:03:30 PM »
Really? I could remove all focus pixels from EOS M2 MLV (mv1080p) files from 14 days ago without any problem. Have you installed focus pixel maps?

interesting...I am using MLV APP v1.8 and I noticed there are many fpm files in the folder. Let me see if these can be installed into the MLV APP

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 1215
Re: ML on EOS-M2
« Reply #591 on: July 26, 2019, 12:57:51 PM »
interesting...I am using MLV APP v1.8 and I noticed there are many fpm files in the folder. Let me see if these can be installed into the MLV APP

->

5D2.212 | EOSM.202

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3713
Re: ML on EOS-M2
« Reply #592 on: July 26, 2019, 04:50:23 PM »
The build is still kind of unstable...

I'm surprised it is somewhat usable. Seems the most success is by using my latest builds with Danne's crop_rec module from his EOSM2 build. I tried merging to get Danne's more advanced EOSM2 settings but there are way too many conflicts and it will regress some things that we don't want to regress. Since it is "only" adding mcm_mv1080 and anamorphic_rewired it shouldn't be that hard. The hard part is keeping up with Danne's changes without breaking anything that is already working.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5634
Re: ML on EOS-M2
« Reply #593 on: July 26, 2019, 05:38:56 PM »
Maybe easiest to put in my rewired presets into your branch so at least those will work and then keep going from there?

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3713
Re: ML on EOS-M2
« Reply #594 on: July 26, 2019, 07:26:34 PM »
Done -- I think. Haven't had time to try it but it looks like there are some willing testers out there.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5634
Re: ML on EOS-M2
« Reply #595 on: July 26, 2019, 10:14:44 PM »
Nice. Will check later. Did you upload a build?

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3713
Re: ML on EOS-M2
« Reply #596 on: July 27, 2019, 02:43:21 AM »
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

ZEEK

  • Freshman
  • **
  • Posts: 81
Re: ML on EOS-M2
« Reply #597 on: July 27, 2019, 04:35:24 AM »
New Settings July 26 Build has a few problems:
- New zoom modes are cool and work smoothly
- Shutter speed is working fine (1/49 compared to 1/56)
- The resolution has gone down from 1736x956 to 1736x568 or somewhere around there.
- When Global draw is on, pink frames are everywhere through the frames.
- Crop Mode Bid Depth is a "no-go zone". Enable it, and the whole image will go very dark with pink clipped areas in the highlights.
- Must enable 16:9 in Crop sub-menu otherwise image is black.
- When recording normally, in MV_1080, it has the anamorphic stretch with focus pixel dots all over the frame.

*Busy right now, but ill see if I can upload some MLV's sometime soon...
EOS M - EOS M2 - EOS M50 - 6D

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5634
Re: ML on EOS-M2
« Reply #598 on: July 27, 2019, 09:30:00 AM »
Hm, not sure how dfort implemented stuff here but there are still plenty code missing. I can take a look later.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5634
Re: ML on EOS-M2
« Reply #599 on: July 27, 2019, 10:10:07 AM »
Ok, pushed a lot of missing code into dfort branch. Feel free to test the crop_rec presets:
https://bitbucket.org/Dannephoto/magic-lantern/downloads/crop_rec_4k_mlv_snd_isogain_1x3_presets_EOSM2_dfort_2019Jul27.EOSM2103.zip