Author Topic: ML on EOS-M2  (Read 293652 times)

dfort

  • Guest
Re: ML on EOS-M2
« Reply #525 on: July 07, 2019, 09:04:29 PM »
Does it affect handling in Mlv App for instance?

I'm not sure. What is happening here is when opening ZEEK's sample file in MLV App the "Fix Focus Dots" defaults to Off while both your cat files default to On. Maybe MLV App doesn't recognize the EOSM2 as a camera that needs focus pixel fixing?

Latest patch:
https://bitbucket.org/Dannephoto/magic-lantern/downloads/hack3.patch

These are huge patch files. Why not start a new branch so we can see just the small changes you're making? Seems like users are happy with these new builds you are posting even if they aren't "proper" fixes. At least some of the ML features are usable.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7557
Re: ML on EOS-M2
« Reply #526 on: July 07, 2019, 09:27:34 PM »
Pushed all in here:
https://bitbucket.org/Dannephoto/magic-lantern/branch/crop_rec_4k_mlv_snd_isogain_1x3_presets_EOSM2

About pixel maps enabling. In Mlv App:
/* returns focus pixel pattern A, B or NONE in case of unsupported camera */
Code: [Select]
static int fpm_get_pattern(uint32_t camera_model)
{
    switch(camera_model)
    {
        case 0x80000331:
            return PATTERN_EOSM;

        case 0x80000346:
            return PATTERN_100D;

        case 0x80000301:
            return PATTERN_650D;

        case 0x80000326:
            return PATTERN_700D;

        default: // unsupported camera
            return PATTERN_NONE;
    }
}
What´s the camera model id on eosm2? mlv_dump checking mlv right?

Edit:
Code: [Select]
Camera Model:  0x80000355
Seems easy to include eosm2. Added it into two files in Mlv App code and it now gets applied accrodingly.

@masc, could you take a look?

dfort

  • Guest
Re: ML on EOS-M2
« Reply #527 on: July 07, 2019, 09:49:02 PM »
Thanks.

Hum--shouldn't your crop_rec_4k_mlv_snd_isogain_1x3_presets_EOSM2 and crop_rec_4k_mlv_snd_isogain_1x3_presets be pretty much the same, except for the addition of the EOSM2 and the minimum needed to work without raw slurp? Looks like there are lots of other changes in there. I've been trying to keep my EOSM2 branch in sync with your latest that includes EOSM/100D/650D/700D/6D/5D3 -- did I leave anything out?

Looks like MLV App should support the EOSM2 -- though turning on "Fix Focus Dots" with the new map files does seem to work quite nicely.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7557
Re: ML on EOS-M2
« Reply #528 on: July 07, 2019, 09:56:21 PM »
Well, I think this eosm2 branch is derived from some patch manager branch. Can´t remember exactly. Anyway. Don´t think mixing in that particular branch into my eosm stuff would be good idea atm. Don´t even have the cam here.
If you want you could try and merge eosm2 into my eosm branch. Maybe without patches more like the other cameras? Or what is missing for eosm2 that needs special care?

By the way. Raw_slurp is enabled in this branch. Otherwise anamorphic would never work with higher resolution.

dfort

  • Guest
Re: ML on EOS-M2
« Reply #529 on: July 07, 2019, 11:29:29 PM »
I've got all the cameras working in my EOSM2 branch. It has some other branches merged in there but as far as I can tell it isn't affecting the other platforms. Of course I haven't been doing much testing or am I as familiar with the code as you are but every once in a while I'll compile for the EOSM or 700D or 5D3 and it works.

https://bitbucket.org/daniel_fort/magic-lantern/branch/crop_rec_4k_mlv_snd_isogain_1x3_presets_EOSM2_dfort

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7557
Re: ML on EOS-M2
« Reply #530 on: July 07, 2019, 11:56:55 PM »
Nice.
I checked, seems you merge all kinds of stuff to get all working in one branch. Hopefully working but needs testing :)

dfort

  • Guest
Re: ML on EOS-M2
« Reply #531 on: July 08, 2019, 02:14:59 AM »
Right -- I tried doing a fake pull request against your branches but Bitbucket crashes there are so many changes!

There are literally thousands of things to watch out for. For example, you have this wrong in your branches:

modules/mlv_rec/raw_proc
Code: [Select]
/* focus pixel helper enums */
enum pattern { PATTERN_NONE = 0,
               PATTERN_EOSM = 331,
               PATTERN_EOSM2 = 331,
               PATTERN_650D = 301,
               PATTERN_700D = 326,
               PATTERN_100D = 346
             };

EOSM2 should be 355 but on the pull request it uses your values because your changes are newer than my changes--or at least I think that's what's going on. Tricky stuff going on here.

ZEEK

  • Senior
  • ****
  • Posts: 329
Re: ML on EOS-M2
« Reply #532 on: July 08, 2019, 02:21:45 AM »
Tested July 07 M2 Build, works nicely.

Note:
* Camera screen turns off at times:
- After playback of clips
- After double tapping Menu Button
- At times when cycling through the info button
- After recording a clip

* Frame rate cannot be set to 1/50, its 1/43, 1/56, 1/70

Apart from that, mv1080p_rewired is working nicely, the clips look great, no focus pixel issues.
EOS M

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7557
Re: ML on EOS-M2
« Reply #533 on: July 08, 2019, 06:42:58 AM »
EOSM2 should be 355 but on the pull request it uses your values because your changes are newer than my changes--or at least I think that's what's going on. Tricky stuff going on here.
But it's your branch to begin with :). Run it against your branch you had at early stages and changes should be fewer. What branch did you merge it against to start with?

dfort

  • Guest
Re: ML on EOS-M2
« Reply #534 on: July 08, 2019, 09:15:34 AM »
What branch did you merge it against to start with?

I've got the same question for you--

Your branch:  :-X


My branch:   :D


How did this happen?

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7557
Re: ML on EOS-M2
« Reply #535 on: July 08, 2019, 10:14:37 AM »
Checking some older messages starting out dec 11th it seems I might have gotten it from here:
https://bitbucket.org/ccritix/magic-lantern/src/
No longer available. Well. I don´t have the camera so I think I am pretty much out of the loop for the time being...

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 2057
Re: ML on EOS-M2
« Reply #536 on: July 08, 2019, 06:09:10 PM »
I added the EOS M2 to MLVApp. Now focus pixel fix should work and camera matrix is hopefully correct (is it the same like EOS M / 100D / 650D /... ? ) .
Would be cool if someone could check. I have no EOS M2 files here, so I am not able to test what I implemented.
5D3.113 | EOSM.202

dfort

  • Guest
Re: ML on EOS-M2
« Reply #537 on: July 10, 2019, 07:20:15 PM »
The EOSM2 uses the same sensor as the 100D so that should be the closest match.

ZEEK

  • Senior
  • ****
  • Posts: 329
Re: ML on EOS-M2
« Reply #538 on: July 11, 2019, 12:36:50 PM »
I have some new .MLV files here from the EOS M2 using the July 07 Build. Test shots with the Pentacon 50mm f1.8 + Viltrox EF-M2

Link:
https://drive.google.com/open?id=1La1Fphd6oIvI3RshRG9S5aqejX4qkrfN
EOS M

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 2057
Re: ML on EOS-M2
« Reply #539 on: July 11, 2019, 12:45:04 PM »
Thank you @ZEEK. This will help a lot! ;)
5D3.113 | EOSM.202

ZEEK

  • Senior
  • ****
  • Posts: 329
Re: ML on EOS-M2
« Reply #540 on: July 11, 2019, 12:59:56 PM »
Great!  :)
EOS M

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 2057
Re: ML on EOS-M2
« Reply #541 on: July 11, 2019, 03:07:37 PM »
After installing manually dfort's latest focus pixel maps to MLVApp, I can remove the focus dots from ZEEK's clips (with the same "success" like with other cams -> on some details it looks worse than without fix, depending on chosen method). Important is, that the maps are installed. Otherwise I get vertical stripes and don't know why. ;)
Edit: stripes fixed.
5D3.113 | EOSM.202

ZEEK

  • Senior
  • ****
  • Posts: 329
Re: ML on EOS-M2
« Reply #542 on: July 12, 2019, 10:17:07 AM »
@Dfort, the M2 records nicely indeed, just one issue which if it can be fixed will be amazing.

- Every time after the recording, the M2 live view will go all black but is still on. You can press menu and it will take you to the menu, but when you get out of the menu, the live view is black and requires a restart each time after recording or sometimes even cycling through the live view displays using the info button.

- When you restart, the screen freezes, I double tap menu and it's working again. After recording the same thing happens (The LV goes black and requires a restart).

Build Used: JULY 07. Not sure what's causing this...Thanks.
EOS M

marcelolippi

  • New to the forum
  • *
  • Posts: 42
Re: ML on EOS-M2
« Reply #543 on: July 13, 2019, 01:50:00 AM »
sd sandisk pro 128gb, read speed 170, four hours of shooting with the sd overclocking module, no longer reads the magic lantern firmware. Record normally from the canon menu. I've tried everything, deep format, old builds ... ideas?

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8546
Re: ML on EOS-M2
« Reply #544 on: July 13, 2019, 09:41:33 AM »
Yeah, do not crosspost!

dfort

  • Guest
Re: ML on EOS-M2
« Reply #545 on: July 14, 2019, 06:45:20 AM »
Build Used: JULY 07.

Hum--that must be one of Danne's builds. Does it also happen with my July 6 build? My version might not have the settings you want yet but I can probably get it working. Good getting some actual field testing on the M2. I did some early tests just to see if ML interfered with regular Canon only functionality and it seemed to do fine.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7557
Re: ML on EOS-M2
« Reply #546 on: July 14, 2019, 07:13:11 AM »
Might be a good idea switching to your "omni" branch. I think adding eosm2 presets from crop_rec should do.

ZEEK

  • Senior
  • ****
  • Posts: 329
Re: ML on EOS-M2
« Reply #547 on: July 14, 2019, 12:00:05 PM »
=Does it also happen with my July 6 build? some early tests just to see if ML interfered with regular Canon only functionality and it seemed to do fine.

The July 06 build worked fine but the reason for the July 07 was to fix the fact that it wasn't recording 3x3 metadata and the MLV data was showing 1x1 sampling. Would you prefer I use July 06 for further development? The July 07 is really fine, it's just the fact that you need to reset the camera after recording most times or when you cycle through the info button, apart from that I would classify it as really good.
EOS M

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7557
Re: ML on EOS-M2
« Reply #548 on: July 14, 2019, 12:08:57 PM »
Can you record mcm rewired with the dfort build?

ZEEK

  • Senior
  • ****
  • Posts: 329
Re: ML on EOS-M2
« Reply #549 on: July 14, 2019, 12:25:44 PM »
No MCM Rewire in the July 06 Build. If crop mode is enabled, it only allows 3x3 720p and RAW Video becomes 0X0. Crop Mode off and you can record 1728x696 (1.61x).
EOS M