Author Topic: MLV Clip is Green and Black - Canon T3i  (Read 5256 times)

PaulHarwood856

  • Senior
  • ****
  • Posts: 305
MLV Clip is Green and Black - Canon T3i
« on: August 06, 2015, 11:35:25 PM »
Hello Magic Lantern,

     I am having serious difficulty with one of my MLV clips on my T3i. It is green, and I have tried using MLV Dump to fix the BlackLevel on the MLV file. I have also exported a few dngs using MLV Raw Viewer 1.3.3 and 1.4.3, and tried the Exiftool to fix the Blacklevel. I tried 2048, 1750, and 1024, and nothing changed, but the terminal showed the process was completed. I am now uncertain what the issue is, and cannot seem to find a fix. However, I have had these green and black clips before with raw video on the T3i as well as the 7D, but I think there is a solution. There is a forum post about this, and I have seriously tried everything on that post, and have found no solution. Here is the link to the post: http://www.magiclantern.fm/forum/index.php?topic=11664.0 The weirdest thing is the dng files in this particular MLV show "Embedded" for Camera Profiles n Adobe Camera Raw. I used a command code to achieve Camera Profiles (such as Vision Log and Adobe Standard and others), and the dng files then have the Camera Profiles  and no longer say Embedded. The odd thing is in the preview on my Macbook Pro, the colors of the raw clip show perfectly fine without any green. These colors are identical to the preview on the T3i's screen when recording this raw clip. When I bring in the dng files however, they are green and black. Also, I tried clicking a different dng from the 7D, and did not get an embedded Camera profile in Adobe Camera Raw. I am really stumped as what to do with this issue. I am really hoping for a fix. I am aware this is quite an odd problem, and I apologize if any of what I said above is unclear. Please let me know if it is, and I will make sure to explain the issue better. Also, if this is already on the forum please let me know. I did search the forum all day yesterday however, and I did not find a solution. I will attach pictures via Google below to show the problem. If anyone has a solution or suggestion I would really appreciate it. Thanks.


- Paul Harwood

https://goo.gl/photos/ZVEE3sQxzumNcjj97

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3411
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
Re: MLV Clip is Green and Black - Canon T3i
« Reply #1 on: August 07, 2015, 09:25:34 AM »
Post a sample of MLV or at least one DNG to a link here and let's see if there's a fix.

Did you try playing with the WB/Tint sliders in ACR?
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

Andy600

  • Contributor
  • Hero Member
  • *****
  • Posts: 1863
  • Have you tried turning it off and on again?
Re: MLV Clip is Green and Black - Canon T3i
« Reply #2 on: August 07, 2015, 12:56:34 PM »
@PaulHarwood856 - I think it's white level related and I'm 99% sure it's MLRawViewer causing the problem. Try using MLVFS.
Colorist working with Davinci Resolve, Baselight, Nuke, After Effects & Premier Pro. Occasional Sunday afternoon DOP. Developer of Cinelog-C Colorspace Management and LUTs - www.cinelogdcp.com

PaulHarwood856

  • Senior
  • ****
  • Posts: 305
Re: MLV Clip is Green and Black - Canon T3i
« Reply #3 on: August 07, 2015, 08:23:09 PM »
Hey DeafEyeJedi,

     Thanks for getting back to me. The only way I could figure out how to upload a dng onto a site was through DropBox. I think you have to sign in to download, please let me know if that is a problem. I did try messing with the white balance settings, but I don't think that's the issue. The MLV is long, but if you need that file I can upload it through DropBox as well.

- Paul Harwood



PaulHarwood856

  • Senior
  • ****
  • Posts: 305
Re: MLV Clip is Green and Black - Canon T3i
« Reply #5 on: August 07, 2015, 08:25:53 PM »
Hey Andy600,

     I tried MLVFS, and had the same results. I'll see if I can try fixing the white level. Do you have numbers I could try entering for white levels? Thanks for getting back to me, much appreciated.

- Paul Harwood

Andy600

  • Contributor
  • Hero Member
  • *****
  • Posts: 1863
  • Have you tried turning it off and on again?
Re: MLV Clip is Green and Black - Canon T3i
« Reply #6 on: August 07, 2015, 10:19:55 PM »
I checked the metadata and the levels are different to Adobe's - I'm not sure the extent of changes that MLVDump can make so I would suggest using Exiftool.

Change the BlackLevel to 2048 and change the UniqueCameraModel tag to:
Code: [Select]
Canon EOS 600D
The UCM tag will ensure ACR compatibility

Colorist working with Davinci Resolve, Baselight, Nuke, After Effects & Premier Pro. Occasional Sunday afternoon DOP. Developer of Cinelog-C Colorspace Management and LUTs - www.cinelogdcp.com

PaulHarwood856

  • Senior
  • ****
  • Posts: 305
Re: MLV Clip is Green and Black - Canon T3i
« Reply #7 on: August 08, 2015, 12:35:07 AM »
Hey Andy600,

     Thanks for getting back to me. I was able to change the camera profile, but still cannot figure out how to change the BlackLevel to 2048. I have followed the instructions on the forum, but am having serious difficulty. Do you mind posting a screen shot on how I would enter this command? I'm on a Mac. If that isn't possible, can you tell me what to type? I get the error 0 files updated, and tried looking that up and I think maybe I'm entering the code in wrong somehow. I converted these dng files using MLRaw Viewer. I appreciate any input you have. Thanks.

- Paul Harwood

Andy600

  • Contributor
  • Hero Member
  • *****
  • Posts: 1863
  • Have you tried turning it off and on again?
Re: MLV Clip is Green and Black - Canon T3i
« Reply #8 on: August 08, 2015, 12:58:05 AM »
Try a simple:

Code: [Select]
exiftool -Black Level=2048 image_name.dng
If that doesn't work you need to find where the black level is stored using the command below - it will likely be in a group - something like IFD0 etc

Code: [Select]
exiftool -G1 -blacklevel image_name.dng
change it by using:

Code: [Select]
exiftool -IFD0:BlackLevel=2048 image_name.dng
The Exiftool forum is a the best place for this info but I also suggest using ExiftoolGUI or PYExifToolGUI as they can make some tagging procedures a little easier to understand as well as showing you most meta tags.

Forum: http://130.15.24.88/exiftool/forum/index.php?PHPSESSID=sa2rbp5kh0dfp7vl6ei10mk6d6&
Colorist working with Davinci Resolve, Baselight, Nuke, After Effects & Premier Pro. Occasional Sunday afternoon DOP. Developer of Cinelog-C Colorspace Management and LUTs - www.cinelogdcp.com

PaulHarwood856

  • Senior
  • ****
  • Posts: 305
Re: MLV Clip is Green and Black - Canon T3i
« Reply #9 on: August 09, 2015, 04:26:21 AM »
Hey Andy600,

     Thank you so much! This worked, and I am so relieved. When I got the green and clips before, I alway thought they were corrupted and there was no fix. Through the forum I was able to find there was a way to fix, tried for hours, and couldn't figure out the terminal codes. Thanks to you my clip is saved!

     I just have one question. Can you tell me what to enter to fix the black level of the MLV? I tried looking this up, and tried the command code via Terminal with MLV Dump but couldn't figure out how to get it to work. The only reason I ask is if I'm in a situation where I'm running out of space on my computer and need to use ProRes instead of dngs (which I then convert to TIFs = more space).

     Thanks again for all your help, I'm very appreciative and happy my clip (and possible future clips) is saved. I hope all is well with you, and that you are enjoying your summer.

- Paul Harwood

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7362
Re: MLV Clip is Green and Black - Canon T3i
« Reply #10 on: August 09, 2015, 05:27:54 AM »
Also if you,re inside a folder you can run a wildcard argument to change the level for all files inside the folder

Code: [Select]
cd (folder)run the following argument
Code: [Select]
find . -maxdepth 1 -mindepth 1 -name '*.dng' -print0 | xargs -0 exiftool -IFD0:BlackLevel=2048 -overwrite_original
Or if you have many subfolders you can enter a parent folder and run this argument on all subfolders.

Code: [Select]
cd (parent folder)run the following argument which will change black level for all subfolders
Code: [Select]
find . -name '*.dng' -print0 | xargs -0 exiftool -IFD0:BlackLevel=2048 -overwrite_original

Also tried the mlv_dump argument for fixing black level which worked.
Code: [Select]
mlv_dump -o (outputname.MLV) --black-fix=2048 (inputfile)
This creates a new file which will land in user directory (drag an output folder after -o argument to specifiy output location).  This fix I would create a script for if I were using.

PaulHarwood856

  • Senior
  • ****
  • Posts: 305
Re: MLV Clip is Green and Black - Canon T3i
« Reply #11 on: October 03, 2015, 10:48:02 PM »
Hey Danne,

     Sorry for the late response. This is very helpful, and I will definitely try this when I get a chance. Thanks for your help, much appreciated!

- Paul Harwood